Solved

Outlook can't use Outlook Anywhere to Exchange 2007 - RPC issue?

Posted on 2014-02-07
10
304 Views
Last Modified: 2014-02-19
I'm unable to auto-create an Outlook 2013 profile by using the new account wizard in Outlook and also I'm unable to do so even if I manually add the settings.

After using the testexchangeconnectivity.com tool I noticed I'm getting the errror:

Attempting to ping RPC endpoint 6004 (NSPI Proxy Interface) on server mail.server.com.
       The attempt to ping the endpoint failed.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       
The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process.
Elapsed Time: 3112 ms.

I did connect directly to the Exchange server and tried to telnet to port 6004 and it does not work. I believe this is Exchange 2007 SP3, it says the version is 8.3.

Not sure where to go from here.. I've checked all the registry keys, tried to modify some etc. I did make sure ipv6 was disabled but when I ping the machine to its own FQDN I get an IPv6 response.. not sure why.. nor not sure if related.
0
Comment
Question by:Metaltree
  • 7
  • 3
10 Comments
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
Comment Utility
If you have tried to disable IPv6, then reverse that. It causes more problems than it is worth and is a very old fix for a very old problem.

The quickest fix for this kind of issue is to
a. disable Outlook Anywhere in Exchange,
b. wait 15-20 minutes for an entry in the event viewer to say it has been disabled.
c. Remove the RPC Proxy feature from IIS. Run IISRESET after doing so.
d. Check in IIS manager that the two RPC virtual directories have been removed. If not, remove them and run IISRESET again.
e. Reinstall the RPC proxy feature.
f. Enable Outlook Anywhere again.

That fixes it 90% of the time.

However do ensure that whatever you did for IPv6 has been corrected.

Simon.
0
 
LVL 5

Author Comment

by:Metaltree
Comment Utility
ipv6 is currently and has always been disabled. should it be enabled?
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
Comment Utility
IPv6 would have been enabled by default and that is the only scenario that Microsoft test. They do not support IPv6 being disabled. Furthermore a lot of people don't disable it correctly - it is a little more than deselecting the box in network connections. If find a machine with it disabled then I enable it, reversing whatever has been done to try and disable it. Only then do I do further troubleshooting.
The product expects IPv6 to be enabled.

Simon.
0
 
LVL 5

Author Comment

by:Metaltree
Comment Utility
I went through the entire process you listed. It did not resolve the issue and I'm still unable to telnet to 6004  even on the localhost and it fails the ms testexchange test.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
Comment Utility
What about the Ipv6 fixing? Did you resolve that? Have you undone the changes to IPv6 to try and disable it?

Simon.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 5

Author Comment

by:Metaltree
Comment Utility
It was previously disabled, I had it enabled then tried to perform these steps. I'm not sure how I can test if ipv6 is "broken" or even how to begin to fix it.
0
 
LVL 5

Author Comment

by:Metaltree
Comment Utility
Ok, I enabled ipv6 on the ESX host which this VM resides on and now I'm not getting an error on port 6004 when I putty in.

However, the issue is still happening, so I'll go through the previous steps again now that this ipv6 issue appears to be resolved.
0
 
LVL 5

Author Comment

by:Metaltree
Comment Utility
Alright, IPv6 is fixed, I've gone through all these steps again. Still not working.
0
 
LVL 5

Assisted Solution

by:Metaltree
Metaltree earned 0 total points
Comment Utility
Figured it out, ended up being a HOSTS file issue. It was blank, and for some reason when I would try to resolve MAIL.SERVER.DOMAIN locally on any port, it would fail. So I added all of the NetBios and FQDN ipv4 address to the hosts file and it resolved the issue.

It could resolve when I pinged etc locally, so I'm not sure what the issue actually was.
0
 
LVL 5

Author Closing Comment

by:Metaltree
Comment Utility
Found the solution on my own with the help of Sembee
0

Featured Post

Want to promote your upcoming event?

Are you going to an event? Are you going to be exhibiting at a tradeshow? Talking at a conference? Using a promotional banner in your email signature ensures that your organization’s most important contacts stay in the know and can potentially spread the word about the event.

Join & Write a Comment

"Migrate" an SMTP relay receive connector to a new server using info from an old server.
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now