Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Total IIS Newbie Struggling At the off

Posted on 2014-02-07
12
Medium Priority
?
244 Views
Last Modified: 2014-02-13
I just copied a static website into a local folder, and I want to view locally thru IIS so no big ambitions.
Win 8.1, IIS, in the IIS snap-in, I've already removed 'Default Website', not sure how, but anyway, I click 'Add Website', Site Name=arbitryname, physical path= to static folder, IP address (leave All Unassigned), host name-another arbitrary name, adds OK but I can't browse to it.
I don't know to browse to http://localhost/arbitryname, or http://anotherarbitaryname, or etc. but anyway, nothing coming up, any Ideas?
0
Comment
Question by:Silas2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
12 Comments
 
LVL 17

Expert Comment

by:Kent Dyer
ID: 39842382
Being able to browse or open a folder in IIS is a vulnerability.  By default, it is turned off.  You can turn it on in settings..

In IIS, you can view webpages in MMC..  Depending on GPO and security settings, you may not be able to browse to localhost.

You do need to keep one thing in mind..  Windows 8.1, 8, 7, etc. and the use of IIS is called personal web services.  While OK as a "Playground" it is not a good "enterprise solution".
0
 

Author Comment

by:Silas2
ID: 39842434
This is really a playground purpose.
I may not be explaining myself, I'm not 'Being able to browse or open a folder' but just trying to get IIS to dish out static pages from the folder, I just keep getting 502, DNS lookup failure.
0
 
LVL 17

Expert Comment

by:Kent Dyer
ID: 39842457
in your local hosts file (C:\Windows\System32\drivers\etc). And still holds true on 64-bit implementations.  Do you have have:

#      127.0.0.1       localhost

You may need to turn this to:
      127.0.0.1       localhost

Save and close..  Try again..  if it still does not work..  Try - http://127.0.0.1 in place of http://localhost
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:Silas2
ID: 39842501
Its says in the hosts file:
# localhost name resolution is handled within DNS itself.
#      127.0.0.1       localhost
so...that's the windows I default, I haven't touched it, myself. knowingly...
When I try http://localhost/websitename/filename.html I'm getting a 404, it's definitely there, and I'm copy/pasting the websitename from 'Edit Site Bindings/Host Name' in the snap-in...
0
 
LVL 17

Expert Comment

by:Kent Dyer
ID: 39842508
Just try this..  If you are not going to edit the hosts file with notepad then...

try - http://127.0.0.1 and see if that comes up..

in IIS itself as well you should be able to browse to page as well.
0
 

Author Comment

by:Silas2
ID: 39842522
If I do  http://127.0.0.1 I get a blank page, but when I do http://localhost/, I get the iisstart.htm page, so I guess localhost is working, dunno whats wrong with 127.0.0.1 though..
0
 
LVL 17

Expert Comment

by:Kent Dyer
ID: 39842561
That is good..  Can you get to http://localhost/somepage.htm does it display?
0
 

Author Comment

by:Silas2
ID: 39842587
I'm getting 404's
0
 
LVL 17

Expert Comment

by:Kent Dyer
ID: 39842598
let me fire up my xp vm..  just a sec.
0
 

Author Comment

by:Silas2
ID: 39842609
I really appreciate your help, I gotta go out now though, I'll be back on it tomorrow though...
0
 
LVL 17

Accepted Solution

by:
Kent Dyer earned 500 total points
ID: 39842741
OK..  Just completed the setup of IIS and works fine,,

Please review the attached.
IIS-Setup.docx
0
 
LVL 83

Assisted Solution

by:David Johnson, CD, MVP
David Johnson, CD, MVP earned 500 total points
ID: 39843745
in the bindings if you specify a hostname you have to add that name to your hosts file
IIS Bindings
# IP             Hosts

127.0.0.1	testa
127.0.0.1	testb
127.0.0.1	Website1
127.0.0.1	Website2
127.0.0.1	Website3
127.0.0.1	Website4

Open in new window

0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Today I came across an interesting issue that had me pulling my hair out.  I was troubleshooting a new internal web site which uses integrated security instead of anonymous.  When browsing the site from my laptop, I was able to access it with no iss…
Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question