NTFS Permissions on Server 2008 R2, allowing access to subfolder only

Hi,
I have inherited a really messy file server and am having problems getting the right access to  user to a subfolder.

Have a Departments Share. Inside that share there are a large number of sub folders that don't have any individual share, just NTFS permissions.

Have an Accounting folder inside the departments share, and a folder "needs access" inside that. So I have a user I want to be able to mount the share Departments (works), then click Accounting Folder and only be able to see the list of folders underneath and then click "Needs Access folder" to which they have full access.

Thought that setting special permission Traverse Folder/Execute on folder Accounting for this user, then setting NTFS permissions on the Needs Access folder would allow this to work but when I try this the user is unable to open the Accounting Folder.

I have setup a share directly to the "Needs Access" folder to get around this but would like to get this setup correctly.
adamant40Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
adamant40Connect With a Mentor Author Commented:
Well stumbled across the settings that woud give me the desired results.  
ON Accounting I did special and then
Traverse Folder
List Folder
Read Attributes
Read Permissions
and APPLY to: This folder only.
0
 
MaheshArchitectCommented:
What share permissions do you have on departmental share folder ?

It must have change share permissions to users on departmental folder, and then you need to give users list folder contents \ read, read and execute and list folder permissions on same folder with this folders, subfolders and files as a scope if you want users to access all folders underneath departmental share folder
OR
this folder only as a scope if you want that users should be able to access specific folders only underneath departmental share folder.
Further,This permissions must be getting inherited by accounting folder and then on "Need Access" folder you should give him modify \ required permissions.

May be your inherited permissions are not applying \ getting inherited by accounts folder

In that case check ownership of all 3 folders
If ownership is different, you need to take ownership of departmental folder 1st with "Replace owners on sub container" option selected so that you can apply permissions seamlessly

Mahesh
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
A) how is rights inheritance arranged?
Can you post screens of the ntfs and security tabs?
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
adamant40Author Commented:
Stuck on another issue, will respond when I can. Thank you for your replies.
0
 
MaheshConnect With a Mentor ArchitectCommented:
If need access is the only folder underneath accounting folder to which users need access, then you have done correct.
But again you need to give modify NTFS permissions on Need access folder with This folder, subfolder and files as apply to scope so that users can work with that folder

Mahesh
0
 
adamant40Author Commented:
Accepted my comment as it was the exact settings that worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.