Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

All computers on LAN slow down when I have Apache running

Posted on 2014-02-07
5
Medium Priority
?
471 Views
Last Modified: 2014-02-09
I have Apache installed on a Windows Server 2008 computer which I use for LAN purposes only (my firewall blocks port 80 to the outside world). I suddenly noticed that both the server and a Windows 7 box are CRAWLING for all activity (not just network related). As soon as I stop Apache all is well again. I tried uninstalling and reinstalling Apache. Same issue. I tried uninstalling Apache and instead using Mongoose. Same issue. Here is my Mongoose config:

# Mongoose web server configuration file.
# For detailed description of every option, visit
# https://github.com/cesanta/mongoose
# Lines starting with '#' and empty lines are ignored.
# To make a change, remove leading '#', modify option's value,
# save this file and then restart Mongoose.

auth_domain jpresidence.com
document_root D:\roku
listening_port 80

Open in new window


Please help!!
0
Comment
Question by:jpfulton
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 22

Expert Comment

by:dan_blagut
ID: 39843833
hello

did the option automatically detect settings is ON on Internet explorer?
If yes then your web site can be taken as autoconfiguration site by all workstations and servers in the network.

Dan
0
 
LVL 28

Expert Comment

by:FishMonger
ID: 39844116
I suddenly noticed that both the server and a Windows 7 box are CRAWLING for all activity (not just network related).
Based on that wording you're saying that the Win7 box would take longer to edit/save a spreadsheet file when your server is running a web server.  That does not make any sense.

Please explain in more detail what problem you're having and how it relates to the web server.

Is the problem related to browsing web pages hosted on your web server?  If so, are you browsing using a hostname or IP address?  Maybe you have an issue with your DNS resolution.
0
 
LVL 57

Accepted Solution

by:
giltjr earned 1500 total points
ID: 39844146
Install Wireshark on your desktop computer and do a packet capture to see what might be going on.

I can't really think of a way off hand that running a Web server would cause local functions to slow down.  Well, one way.

That is if you were running something on the server that was listening on port 80 and/or 443 that all your desktops need and because of startup order, Apache gets those ports first and the other product can't open them up.  Now all your desktops are connecting to Apache to get/check something that it knows nothing about.

To check and see if that is the case,  stop Apache, wait a minute or two then do the commands:

netstat -an | findstr /c:"LIST" | findstr /c:":80"
netstat -an | findstr /c:"LIST" | findstr /c:":443"

and see if there is something listening on those ports.
0
 

Author Comment

by:jpfulton
ID: 39845301
Based on that wording you're saying that the Win7 box would take longer to edit/save a spreadsheet file when your server is running a web server.  That does not make any sense.

You have that exactly right and I couldn't agree more that it doesn't make any sense. I can only tell you that I've witnessed it.


Before noticing your responses, I tried simply switching the broadcast port from port 80 to port 8080. Problem solved. Obviously there is something else going on that is wrong or at least severely abnormal but for now the immediate problem is fixed. Points going to giltjr because it seems like he/she was very close to the solution or at least how to get there.

Thanks all!
0
 
LVL 57

Expert Comment

by:giltjr
ID: 39845326
Thanks for the points.  I would still suggest you issue those commands.  If something else was listenting on port 80 it should still be listening.

Apache "listens" on port 80/443, actually all HTTP servers (like IIS) listen on those ports by default.   Normally http servers don't broadcast traffic, they only respond.  

So I'm still assuming you have something else running on that server that uses port 80/443 and Apache was starting before it.

The other possibility is that you have an application on all your desktops that is trying to talk to a an application that listens on port 80.   To see if that is the issue you would need to run a packet capture on one of your "normal" desktops that was seeing the problem and see if it is trying to talk to anything on port 80.
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A procedure for exporting installed hotfix details of remote computers using powershell
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question