• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 268
  • Last Modified:

IE 9.0 on windows 7 64-bit

Hi All,

we have few windows 7 PCs running IE9.0. When users are trying to download excel files, it keeps prompting for open or save. Is there a way to disable this and default to opne like it was in IE 8.

Thanks
0
afsaleh
Asked:
afsaleh
  • 5
  • 4
1 Solution
 
Gerwin Jansen, EE MVETopic Advisor Commented:
Can you try Saving an Excel file once, then look in the IE download folder (CTRL-J), right-click the Excel file you've saved and then uncheck the 'Always ask ...' action?
0
 
afsalehAuthor Commented:
Hi Gerwin,

when I right-click on the excel file, I do not getthe Always ask question.

Thanks
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
Can you check the security settings in internet options? What's the current setting for the selected zone? Try setting is one level lower, to Medium for example. Then re-test.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
afsalehAuthor Commented:
The security zone for the trusted site are set to low
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
I did some searching, it seems that MS indeed made some changes from IE8 to IE9 - there are lots of posts/questions about your (or similar) issue. A possible work around is where you have to create a registry key for the application you want to open automatically when downloading a file. I'm not sure if you want to get into making registry changes for your users where other browser (like Chrome) do have the functionality you want.
0
 
afsalehAuthor Commented:
I do not mind to go into thr registry if you provide with instructions. Thanks
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
Ok, let me do some research, what Excel version is this about?
0
 
afsalehAuthor Commented:
microsoft office 2010. Thanks
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
Ok, can you try this, start regedit.exe and go to:

HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046}

If you don't have the keys AttachmentExecute and {0002DF01-0000-0000-C000-000000000046} - create them first.

Next, create a zero length binary value called Excel.Sheet.15

Now try opening an Excel file - it should open automatically. I tested this with Excel 2007 and it worked. I had to enter the value Excel.Sheet.12 but yours should be .15

In case you want extra file types, open a cmd prompt and get the type like this:

assoc .xlsx

You should get a reply like this:

.xlsx=Excel.Sheet.12
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now