Solved

Win 8 Can't Connect to Terminal Server

Posted on 2014-02-08
10
1,028 Views
Last Modified: 2014-03-13
Have a terminal server, been in production 3 years
Running W2K8 R2 SP1
Have Win 7 Pro users, can connect via RDP and via Browser using gateway.

ISSUE:
Have new Win 8 user, cannot connect, says server is not there or is unavailable.

STEPS TAKEN:
Have had the user try both by IP and by url - NO JOY
Have had the user try to use a browser navigate to the gateway, he gets there, but after that, same message.

I thought there was a hotfix for this, but now I am not so sure.

Any thoughts are welcome.
0
Comment
Question by:tech911
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +1
10 Comments
 
LVL 15

Assisted Solution

by:ZabagaR
ZabagaR earned 334 total points
ID: 39844362
Can you go to a command prompt on the win8 pc and telnet to port 3389 on the term server?
You'd type:  telnet <server-ip-here> 3389

If connectivity is OK, the screen should clear and you'll have a blinking cursor.
You need to add telnet client in win8 beause it's not there by default.
Do this to add:

http://www.sysprobs.com/install-and-enable-telnet-in-windows-8-use-as-telnet-client

What are your telnet results?

How about making sure you have Windows 8.1 (most recent version)

http://pcsupport.about.com/od/windows-8/ss/how-to-update-to-windows-8-1.htm
0
 
LVL 3

Author Comment

by:tech911
ID: 39844366
User that is having this issue is on a mountain skiing... apparently this wasn't as important as he made it sound.

I will try the telnet test.

Honestly, I think the connection request is getting to the server, but then because its the newer version of RDP, when the server responds using the older (not 8.0) version of RDP it gives the "No Connection" error.

Can I update the RDP connection at the server.  Do I want to?  Will it blow all my Win7 users out?

Finally we also use a two factor authentication system, but it does not figure into the equation until after you are presented with the TServer login screen.  I don't want to break that either.

As a precaution, since this is a VM, I shut it down and made a complete image of it in case we totally blow it up.

Will advise when he gets back to me.
0
 
LVL 88

Assisted Solution

by:rindi
rindi earned 166 total points
ID: 39844379
Check the firewall on the w8 box. It could be blocking RDP.
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 15

Accepted Solution

by:
ZabagaR earned 334 total points
ID: 39844396
No, there's no RDP update for the server, W2K8 R2 SP1. I was asking if you could update the client to Windows 8.1 - or at least make sure all recent Win8 updates have been ran.
0
 
LVL 3

Author Comment

by:tech911
ID: 39844489
ZabagaR - I understood what you were asking, very clear.

When I was researching this issue, I copied a link to my desktop that said it was a hotfix for Windows 8 not being able to access a terminal server,  and would fix this issue, but now I can't locate it, so I'm wondering if I really did see it or if I was working on something else?

Anyhow, I will advise, once he gets back to me.

If you find my missing hotfix, advise,

Thanks for the help
0
 
LVL 88

Expert Comment

by:rindi
ID: 39844509
Have you already tried disabling the firewall? Such issues are usually caused by firewalls...
0
 
LVL 15

Expert Comment

by:ZabagaR
ID: 39847307
I haven't seen a hotfix but the only other time I ran into this problem, it was fixed when the end user ran windows update to take their workstation from windows 8 to windows 8.1
0
 
LVL 54

Expert Comment

by:McKnife
ID: 39850677
I would also do the telnet test, first.
I can also add that there is no problem connecting 8/8.1 to 2008 R2 RDP - no patch or whatever needed.
0
 
LVL 3

Author Comment

by:tech911
ID: 39886306
OK - I will be working with the user to see if I can test this out.

Chris
0
 
LVL 3

Author Comment

by:tech911
ID: 39928006
USER ERROR....

User did not put in Domain\username, instead they were putting Domain/Username, which will not work.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
ADMFILES.INI 7 59
Blocking Microsoft Edge From Running? 14 137
Any server named Crackers on our network now gives an error message when accessing a network share 15 110
BgInfo help 5 109
No matter the version of Windows you are using, you may have some problems with Windows Search running too slow or possibly not running at all. Before jumping into how you can solve this issue, just know there are many other viable alternative deskt…
New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question