Specific extensions for outgoing route

All of our extensions dialing out, go through tel. number 2222222. What i need to do is have 3 specific extension dialing out through tel. number 3333333. How can i make the three extensions dial out through 3333333. I was able to configure, when someone dials 3333333, it would ring to the three specific extensions. I need to do the opposite. Three specific extensions dialing through 3333333.  
I am using Elastix and Freepbx.
christoforatos1968Asked:
Who is Participating?
 
PhonebuffConnect With a Mentor Commented:
Basic FreePBX will do this for you --

Create an Outbound Route and put the extensions in the fourth column Caller_Id for the patterns and extension you want to select and specify the trunks in the order you want to use them.
0
 
arnoldConnect With a Mentor Commented:
Part of the extension configuration based on http://www.freepbx.org/forum/freepbx/general-help/outgoing-caller-id should include the outgoing caller ID.

freepbx has a plug in that goes through a few checks to determine what the outgoing callerID should be.  The last one is the system default.

There is a USER and there is also the caller ID if you are forwarding inbound calls.
0
 
christoforatos1968Author Commented:
Currently all extensions in the office dial out to number 2111211010. What i need to do is have extensions 421,422 and 423, dialing out through the number 2111211500. Do i create an outbound route in FreePBX? And how do i do this?
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
PhonebuffCommented:
How are these numbers connected to your Asterisk box, PSTN or SIP provider.
0
 
christoforatos1968Author Commented:
The numbers are connected by a SIP provider.
0
 
PhonebuffCommented:
Okay,

     Then assuming that the provider will allow the digit pattern to be sent then it's fairly simple to do, but I am not in front of a system right now, I will try and send you the details latter today.

      ============
0
 
arnoldConnect With a Mentor Commented:
Look at the extension configuration/settings.
There should be a field there OUTBOUND CID.  This is where you would place the number that should be display when this call is received. Make sure that your provider allows you to control the outgoing CID and this is one of the numbers allocated to the FIRM.

Test on one extension and then when successful, adjust to others.
0
 
PhonebuffCommented:
Yes,

     On the Extension you can set that, but on the Trunk you also need to set the appropriate values for what's been sent / passed through..

    On Trunk -- CID options --

    On Extension -- Outbound CID --

    =====================
0
 
arnoldCommented:
There are multiple places where you can set outbound CID rules.

on the trunk is the default usually the main number

within the extension is the extension specific outbound callerID.


The asker seems to have the trunk outbound CID set, but wants three extensions to have a separate number.  I believe the inbound routing for that number is already setup to ring to these three extensions.
0
 
christoforatos1968Author Commented:
That is correct. The inbound routing is already setup. I need to configure the outbound routing, to have extensions 421,422 and 423 dial out through 2111211500. Can you give me feedback on this configuration.
Outbound-route.JPG
SIP-Trunk.JPG
0
 
PhonebuffCommented:
So in the extension(s) configuration set the outbound cid.

Also, you are currently going to try an pass the CID of any inbound call that you forward off set
0
 
christoforatos1968Author Commented:
I did set the extension 421 outbound cid to <2111211500>, but when i dial through the extension 421, on my mobile phone i see 2111211010.
0
 
PhonebuffCommented:
You should check the CLI an watch what asterisk is sending and/or turn on debug sip for that channel and see what is going out.  But it sounds like your VoIP carrier may not care what you send and is hard coding  a CID.
0
 
arnoldCommented:
What you posted is the default outbound SIP/TRUNK CID.

Please clarify what you mean you dial through the extension?  If you are placing an inbound call to a number that is then mapped to extension 421 that is then forwarded out, it will have/use the default outbound cid since it is rerouted within the PBX and because the extension 421 is not the originator of the call, your phone is.

i.e. yournumber calling 2111211500 (within your PBX 421 <=> reroute outbound)


If you place the call from extension 421,422,423 the outbound CID should now reflect the extension specific outbound CID.
0
 
christoforatos1968Author Commented:
I found the solution.
I go to outbound routes.
In Dial Patterns: Prefix is 5 and match pattern is X. In Trunk Sequence for Matched Routes, i selected the number 2111211500.
What this does is that i will select the extension that i want to dial from, then dial the number with 5 in front of it. This way the outgoing call will go through 2111211500 and not 2111211010. It works.
0
 
christoforatos1968Author Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for christoforatos1968's comment #a39856074

for the following reason:

I found the solution.
0
 
PhonebuffCommented:
Experts spent a lot of effort assisting this user and guiding him to identifying the issue,  The question should not be closed with zero points awarded.
0
 
arnoldCommented:
You created an unnecessary workaround.
Within the definition of the extension, you can define the outgoing CID in a similar manner that you define an incoming dial-plan that routes a specific external number to a specific extension or a group of extensions. using the prefix method you could run into a situation down the line where you start using 5xx extensions and those people will not be reachable.  You would then be spending hours trying to figure out what is going on especially since you would have stopped using the 5 prefix to alter the outgoing CID.
0
 
christoforatos1968Author Commented:
Thanks for the feedback. As long as i do not use 5xx extensions, i should be fine.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.