?
Solved

Exchange 2013 in a disjointed domain

Posted on 2014-02-10
8
Medium Priority
?
459 Views
Last Modified: 2014-02-15
Hi All,

I have a client with  new installation of exchange 2013. Mail flow is working but there are some issues with outlook connecting, current users have a password prompt that wont accept their credentials and autodiscover for new users resolves their names but then also promts for passwords and never accepts them.

What I know and have read about this seems to stem from the fact that the client has a disjoined domain. here is what they have, they are Johannesburg (JHB)

domain name = domain.local
DNS = domain.local and domain.co.za
NetBIOS = domainJHB

Their external mail address is mail.domain.co.za

I have set the outlook anywhere to user NTLM, outlook has been updated to the supported service packs for exchange 2013 ie outlook 2010 with SP2.

I have tried some things in dns, such as remove the autodiscover.domain.local and created a SRV record to point to autodiscover.doamin.co.za. Thus far the only way I have managed to get outlook online is to do a manual setup and make sure outlook anywhere is set up.

any advise would be appreciated.
0
Comment
Question by:Thiaan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39847001
Having a domain in the way that you have described is not a problem, as long as you have a split dns system and configure Exchange correctly to use the external name internally.
That is easily done, my Exchange 2010 instructions apply to Exchange 2013 as well.

http://semb.ee/hostnames

Autodiscover DNS records are not used internally, unless the clients are not members of the domain. The clients query the domain for the value that you can see here:

get-clientaccessserver | select indentity, autodiscoverserviceinternaluri

The host name needs to resolve to the Exchange server and be listed on the SSL certificate.

I suspect that is the core of your problem. That will be the reason Autodiscover doesn't work and the authentication prompts.

Simon.
0
 

Author Comment

by:Thiaan
ID: 39847197
Hi Simon,

Thanks for the reply.

I have changed the URLs as you suggested so both internal and external are now mail.domain.co.za/[respective virtual directory] but there is no change. If I specify the MSSTD then the client connects but not if I try use plan autodiscover during the outlook setup. I also get a certificate error that states:

There is a problem with the proxy server's security certificate. The name on the security certificate is invalid or does not match the name on the target site mail.domain.co.za.
Outlook is unable to connect to proxy server. (Error code 0)

I have never seen an error code 0, 8 and 10 I have seen and that usually is an issue with the certificate.  The certificate issued on the server looks like so:

subject: CN=servername.domain.local
SANs:
mail.domain.co.za
servername.domain.local
autodiscover.domain.co.za
servername
domain.local
domain.co.za

It is a web server cert and is valid on the machine. I am no expert when it comes to certificates but as far as I understand between the subject name and the sans the names should match one of them when outlook tries to connect?
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39847332
That cannot be a trusted certificate.
You cannot get trusted certificates with the local names on them unless it expires before November 2015. Are you using a trusted certificate?

Autodiscover is different to the name sued for Outlook Anywhere, so you have different issues, although most likely the same cause - trust on the certificate.

Simon.
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 

Author Comment

by:Thiaan
ID: 39847413
Its an internal CA which has been there for heaven knows how long. It is not linked in any public CAs
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39847433
I will drop off the question then. I don't do anything with internal CAs. For public facing services like this they are more hassle than they are worth and I will not have anything to do with them.

Simon.
0
 

Accepted Solution

by:
Thiaan earned 0 total points
ID: 39848476
Thanks for all your help Simon.

I managed to figure it out, it was indeed the certificate causing the issue but not because the certificate was wrong. I eventually discovered that the outlookproviders where set to look at mail.domain.co.za. Hence why I got the error mentioned above, as the cert name is servername.domain.local. If you run get-outlookprovider in the exchange powershell on a working exchange you get something like this

Name                          Server                        CertPrincipalName             TTL
----                          ------                        -----------------             ---
exch                                                                                      1
expr                                                                                      1
web                                                                                       1

however on my problematic exchange the certPrincipalNames were all set to mail.domain.co.za.

to reset them you need to enter set-oulookprovider EXCH -CertPrincipalName $Null.

thanks for your time though. its greatly appreciated.
0
 
LVL 12

Expert Comment

by:Md. Mojahid
ID: 39849506
What about owa? is working fine? If yes then try to reset once account password and figure it out what is status. And also check your credentials setting and sll certificate.
0
 

Author Closing Comment

by:Thiaan
ID: 39861161
I managed to figure this out in my own clean lab environment with a green fields deployment
0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question