• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4525
  • Last Modified:

Failed VPN on Sonicwall to Cisco

I am getting an error I have never seen before on my firewall. I'm trying to establish a tunnel from my Sonicwall NSA 3500 to a Cisco ASA. It establishes Phase 1 fine but then it tries and immediately fails to connect to Phase 2. The message I get is:
Deleting IPsec SA (Phase 2) and then "Incompatible with older firmware" in the notes. Both devices are on the latest general firmware releases so I'm not sure why I would be getting this error. These devices were linked at one point in the past but that connection was removed. Now they need to be connected again. I have several other tunnels working properly on my device at this time.

Please see attached file for specific log error.
sonicwall.jpg
0
Tarkisal
Asked:
Tarkisal
  • 4
  • 3
1 Solution
 
Blue Street TechLast KnightCommented:
Hi Tarkisal,

Most likely a mismatch of SA lifetime. The IPSEC is hardwired to an SA lifetime of 28800 seconds.

Reset the Lifetime value for both Phase 1 & 2 , in the Proposals tab of the GroupVPN Policy, to 28800, and let me know if that resolves the issue.

Also, make sure Enable Keep Alive is checked in the Advanced tab.
0
 
TarkisalAuthor Commented:
Thanks for the response. I changed the lifetime down to 3600 and reset the tunnel but I'm still getting that same error. The other party's device has a default of something higher - I think it's like 86400 seconds. I had tried setting mine to that number but the error remained.
0
 
Blue Street TechLast KnightCommented:
Has anything changed regarding the proposals on either end? The Lifetimes should definitely match so make them match either at 86400 or 28800. Also, make sure Enable Keep Alive is checked in the Advanced tab.
0
The IT Degree for Career Advancement

Earn your B.S. in Network Operations and Security and become a network and IT security expert. This WGU degree program curriculum was designed with tech-savvy, self-motivated students in mind – allowing you to use your technical expertise, to address real-world business problems.

 
TarkisalAuthor Commented:
The proposals are the same. I believe it may have something to do with a NAT setup on the remote client's side. When they give me the NAT address starting with 172.30 I can't access it and I get that error message listed above. However, when he gives me a direct number starting with 10.88 the tunnel shows as up and I don't get that error.
0
 
Blue Street TechLast KnightCommented:
Are you listing the Default Gateway correctly in both tunnels?
0
 
TarkisalAuthor Commented:
We finally figured out the problem. The configuration was wrong on the remote site. It turned out to be built in the wrong order which caused the issue. The admin had built the cryptomap first and the static NAT after and for whatever reason this caused the error. By reversing this process it connected normally. I still don't know what the original firmware error was from - perhaps it was because it saw a problem with the configuration?

In any case thanks to everyone for their help.
0
 
TarkisalAuthor Commented:
Though the responses I got were very helpful they did not touch on the right solution. This was most likely due to not enough information available.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now