Solved

No Exchange IIS web functions are working

Posted on 2014-02-10
9
307 Views
Last Modified: 2014-02-25
I can't get to exchange OWA, ECP, and my internal outlook clients will not connect.  I have run the powershell commands to delete and recreate the directories with no luck.  I'm not sure what to do or where to start? We are on exchange 2013 RU3.  When i try to go to any of the exchange virtual directories it get an http 500 error
0
Comment
Question by:Ninja03
  • 6
  • 2
9 Comments
 
LVL 12

Expert Comment

by:Md. Mojahid
ID: 39849147
1.  Check whether Virtual Directories Authentication configured properly. Enable the ECP Virtual Directory with Anonymous and Basic Authentication.

2.  Check on the Application Pools to view whether ECP Application Pool is running on .NET Framework v4.0. It maybe the incompletely installation of Framework that causes this error.

If so, We can try to run the following command as Administrator:

%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i

Or change the MSExchangeECPAppPool from .NET Framework from v4.0 to v2.0. Then restart IIS.

If you have any question, please do not hesitate to tell me.

For more about this error see the technet articles which will you help.

http://technet.microsoft.com/en-us/library/jj150562.aspx
0
 

Author Comment

by:Ninja03
ID: 39849159
Have check all of these settings and they are correct.  Nothing is working.  The exchange connectivity test still passes the inbound and outbound email test but nothing else.
0
 

Author Comment

by:Ninja03
ID: 39849162
I recently installed CU3.  If i reinstall it do you think it will fix my issues with IIS?  I really have to get this going again quickly
0
NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39849613
You cannot reinstall the cumulative updates. That functionality doesn't exist. If you run setup.exe then you will just get the usual prompts about removing the product.

What changed to break it? This isn't something that tends to happen on its own. Was something else installed that could have changed the IIS configuration?

Does EMS work?

Simon.
0
 

Author Comment

by:Ninja03
ID: 39850221
The EMS doesn't work. I get this message when trying to connect:

New-PSSession : [ea2.electionadministrators.com] Connecting to remote server ea2.electionadministrators.com failed
with the following error message : The WinRM client cannot process the request. It cannot determine the content type
of the HTTP response from the destination computer. The content type is absent or invalid. For more information, see
the about_Remote_Troubleshooting Help topic.

I was trying to fix the EMS and I guess that I somehow screwed up the IIS Configuration.

What if I did an install with the repair option?  I just need some why to get the virtual directories back to a working state
0
 

Author Comment

by:Ninja03
ID: 39851678
Also, I can't access the ECP anywhere, even https://localhost/ecp generates an http 500 error
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39852660
There is no repair option for Exchange. The only thing you can do is remove the client access role and then reinstall it.

What exactly did you do to try and fix EMS?
What did you change in IIS manager?

Simon.
0
 

Accepted Solution

by:
Ninja03 earned 0 total points
ID: 39874202
Well, i opened a ticket with microsoft about this.  I'm not sure what happened the IIS configuration got messed up to the point that the could not fix it.  Apparently, server 12 R2 isn't supported for exchange 2013 until SP1 is released.  I was not aware of that, but since that was the case they said they could not escalate the ticket to the IIS team.  The support ticket was my last ditch effort before doing a complete reinstall.  Which is what the support rep at microsoft also recommend.  

So I finally just backed everything up and reinstalled R2 then run CU3 in recovery mode and thankfully it completed without any problems.
0
 

Author Closing Comment

by:Ninja03
ID: 39885104
I had to do a reinstall because this is not yet a supported configuration so microsoft was unable to help me.
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
This video discusses moving either the default database or any database to a new volume.

803 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question