Exchange 2013 - Unable to send to gmail? DNS query failed

Hi,

Since about a month ago I can no longer send to any gmail accounts, but they can send to me.  It doesn't even attempt to send and holds it in the queue with "451 4.4.0 DNS query failed.  The error was: DNS query failed with error ErrorRetry".  Eventually a bounce back occurs with the following: '400 4.4.7 Message delayed' saying the message will reattempt delivery in a couple of days.

Sometimes the message will actually be sent to the gmail account but it will be hours before it goes through.

I can query the mx record for gmail.com fine from my exchange server, so I'm not sure what the actual issue is here.  I've also checked blacklists and we're fine.

Can someone give me an idea on where to look next?
ts11Asked:
Who is Participating?
 
ktaczalaConnect With a Mentor Commented:
Some services are getting more strict with exchange so I can't say that this will fix it but it won't hurt.

I use 8.8.8.8 on my forwarders, just because it's reliable & easy to remember :-)
0
 
ktaczalaCommented:
do you have a static IP address for your exchange server?  Are you using a smarthost, who is your internet provider?

check all your settings: mx, dns, txt, ptr, etc at: mxtoolbox.com
0
 
Arjun VyavahareTechnical ConsultantCommented:
Hi,

Check your Static IP address is not blacklisted (www.mxtoolbox.com) and also try to send email using telnet to gmail from your exchange server.

How to send email using telnet:
http://www.yuki-onna.co.uk/email/smtp.html
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
suriyaehnopCommented:
if you are using smart host to send email to internet, make sure your smart host able to query mx of gmail.

Try use gmail.com (8.8.8.8) DNS as your smart host resolution name.
0
 
ts11Author Commented:
I am not using smart host and am not on blacklist (per mxtoolbox).  I've checked all my settings at mxtoobox.  DNS lookup returns godaddy dns.  MX points to my mailmarshal ip (this is only for incoming mail).  I don't actually have an spf record created.

How can I add google dns as a smart host?
0
 
ktaczalaCommented:
You should have an spf record when hosting your own exchange,

go here and run the wizard.  once you have the info, Copy & paste it into your DNS hosting provider as a txt record.
0
 
ts11Author Commented:
Thanks.  Just to confirm I've added the right settings:

v=spf1 mx:smtp.mydomain.com (mailmarshalip) ip4:122.XX.XXX.XXX (exchange ip) a:mail.mydomain.com (A record of exchange) ~all
0
 
ktaczalaCommented:
looks about right
0
 
ts11Author Commented:
ok, I will update my dns with this.  However, would not having an spf record be the reason for my original issue? I noticed that today that messages sent to gmail are going through, sometimes giving the above and then later sending after I initiate a retry in exchange.

Should I create a forwarder on my internal dns to google's dns 8.8.8.8?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.