Solved

Windows Remote Desktop Access

Posted on 2014-02-11
4
515 Views
Last Modified: 2014-02-11
I have set up NATs on our new modem router : TP-Link 150Mbps Wireless N ADSL2+ Modem Router to connect to several different machines on our LAN with RDP through our public static IP, using a different port for each machine.

I have done this before with other modem routers and depending on the router I either had to set the external port to the RDP default 3389 and the internal port to something else, mapped to the machine's local IP, e.g. 192.168.1.xxx, and with other routers both external and internal ports had to be the same.

With this router the only way I can get it it work is by changing the default RDP listening port on each machine with a registry hack - this is OK since I only have 10 machines I need to access.

However, this works on some machines and not on others. Some machines are running Windows 7 and others Windows XP. All the machines have the same antivirus and all of them have the permissions set to accept RDP connections.

This obviously must be a problem on the particulat machines where access is denied and I tried looking at the Events on each machine but can't find anything there.

The modem router log shows this:
2/11/2014 11:18:6> netMakeChannDial: err=-3000 rn_p=805458d0
2/11/2014 11:18:33> Last errorlog repeat 14 Times

but I haven't been able to get anything from that either.

Can someone point me in the right direction to where I should look on the machines that don't allow access? These same machines worked before with our previous routers.
0
Comment
Question by:jdailey59
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 15

Expert Comment

by:Jaroslav Mraz
ID: 39849801
Did you add rules to firewall ? Even you change default port there is usually need to manually allow communication in and out on the new port in PC firewall.

If you try to connect form local network on new port is it working?
0
 
LVL 18

Accepted Solution

by:
Sushil Sonawane earned 500 total points
ID: 39849828
Disable your windows firewall and then check.
0
 

Author Closing Comment

by:jdailey59
ID: 39849862
Yes, that worked - it was as simple as that. I then went back and added a rule for the specific port I wanted to use, and re-enabled it and it still works, thank you.
0
 
LVL 15

Expert Comment

by:Jaroslav Mraz
ID: 39849870
No comment ...
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question