Solved

KODAK SCAN STATION 500 + SMTP EMAIL SENDING ISSUES

Posted on 2014-02-11
62
1,054 Views
Last Modified: 2016-11-23
I have a Kodak Scan Station 500 set up on a network. It has problems sending emails to the destination.  "Error processing one or more destinations"

Using SMTP protocol.

The Dell Sonicwall firewall is configured to allow all traffic to go out.

Anyone, please help.

Thanks

Sam
0
Comment
Question by:imservices
  • 32
  • 30
62 Comments
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Is the mail server (the SMTP server) inside the LAN or outside? Can you post a Screen Shot of the mail server configuration page on the Kodak (you might hide sensitive data)?
Thanks.
0
 

Author Comment

by:imservices
Comment Utility
The mail server belongs to go daddy (its outside the LAN)
please find the settings below:

More details of configuration below:
godaddy smtp settings..
Smpt server---smtpout.secureserver.net
Port: 80 ( I've also tested on port 25--both ports produces successful results)
username: user@domain.com
password: XXXXX
Domain: (blank)

result within the kodak administrator program-->Successful

godaddy hosted exchange settings

smtp.ex4.secureserver.net
Require authentication
port: 587 (starttls)
credentials
User: user@domain.com
Pass: XXXXX
Domain: (blank)

result within the kodak administrator program-->Successful
0
 

Author Comment

by:imservices
Comment Utility
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
I'll setup a test mail server and give you the credentials in order to test the KODAK using my test server. Should be back in about 3-4 hours.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Sorry for the delay. The test server is ready. Set KODAK to use the mail server 87.24.34.78 (there's no authentication needed) and try to send a test mail (from the KODAK, of course) to imservices@domain.com.
The destination mail address is NOT monitored and is set up for these tests only. Please update this EE case when you have done your test.
Thank you.

P.S.: I understand your scenario is more complex (authentication, TLS and so on) but for Troubleshooting purposes we're starting with something very simple.
0
 

Author Comment

by:imservices
Comment Utility
Thanks for the information you provided. I will need some more details to fully the smtp protocol on the server.

Server address: 87.24.34.78
Username: (cannot remain blank)
Password:  (cannot remain blank)
Port: 25, 80, 587 (please specify)
no authentication
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Your should be able to leave Username and Password blank. Please try.
The Port is the default one: 25.
0
 

Author Comment

by:imservices
Comment Utility
No go,
The kodak smtp connection test return "failed"
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Is train01.sec.local your name?
The SMTP test might return failed for many reasons. Does the SMTP test use the mail address I gave you? If it doesn't, please skip the test and try to send a mail to the address I gave you.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
I'm shutting down the test mail server. If you need more help, please ask.
0
 

Author Comment

by:imservices
Comment Utility
My apologies,
The results are the same. "failed"
errors processing one or more destinations.
0
 

Author Comment

by:imservices
Comment Utility
Is train01.sec.local your name? -->yes
The SMTP test might return failed for many reasons. Does the SMTP test use the mail address I gave you? -->yes

If it doesn't, please skip the test and try to send a mail to the address I gave you.

Yes, I have done, so and the result is still the same.
0
 

Author Comment

by:imservices
Comment Utility
I have also tried to send an email to imservices@domain.com from our company email account but that bounces back with the following error..

There was an error while attempting do deliver your message with [Subject: "test"] to imservices@domain.com. MTA p3plex2out01.prod.phx3.secureserver.net received this response from the destination host IP - 64.85.73.28 - 505 , 5.0.0 User unknown.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
This post responds ONLY to your last post of 3.
You CANNOT send a mail to the mail address I gave you, using another mail client or server. The mail address I gave you is a fake address and it works only if you use the test mail server I gave you (and in this moment it is OFF).
I will give you more details in these days and I'll bring the test mail server ON again on Monday. Please, keep monitoring this case during the WE.
Thanks.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
I attach 3 pages from the Kodak's Administrator's Guide.
Page 3-24
3. Put the IP address I gave you: 87.24.34.78
Page 3-25
5. We use an unauthenticated SMTP server. Make NO selection in these fields.
9. The port is 25
10. Select None
Page 3-26
13. Test Connection

My test SMTP server is UP and running. Please run your tests and report back the results. If the KODAK isn't able to reach my test SMTP server you should check you router/firewall if there's any rule blocking outbound SMTP traffic.
Let me know.
A61628-ss500-AG-en--37-39-.pdf
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Furthermore... the Test Connection might fail since it might try to send a mail to an unauthorized mail address (only mails to imservices@domain.com work). So if the Test Connection fails, before starting checking the router/firewall, try sending a mail FROM THE KODAK to imservices@domain.com.
Thank you.
0
 

Author Comment

by:imservices
Comment Utility
Thanks for the update, I will have to wait to send the test email from the kodak scanner, as we are in a different time zone, However, as noted before, the test within the scanner admin software failed (as you indicated might happen). I have attached a pic of the firewall settings.
All outbound traffic is allowed. (I have also created explicit rules allowing smtp traffic out (these are not needed though).
firewall.JPG
scanner-settings.JPG
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Hi. You have to wait as you are in a different time zone? What does that mean? My test SMTP server is up and running H24. You can send the test mail whenever you want. BTW... did you send the test mail? I have got no test mail. Please let me know. Thank you.
0
 

Author Comment

by:imservices
Comment Utility
Success!

Although the scanner administration program fails when testing with the settings you have given. The scanner actually sends the email to "imservices@domain.com".

I tested sending to another real email address but this failed obviously, you will be able to let me know why in time,

Please advise on next step.

Thank you.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Hi. Nice to hear from you again! Yes, I've got 3 mails each one with a PDF attached. It's the Invoice No. 2958. I'll give you more details on how should we go further tomorrow (my time zone is GMT+1 and I'm "over" for today).
Essentially, I'll setup my test SMTP server at a harder level in order to get as close as possible to your scenario. Expect more details in about 24 hours (or something less) from now.
I'll shut down my test SMTP server now. So don't expect to run further tests until I write you another post.

Yes, I confirm you cannot send mail to a real email address because this is a test SMTP server and it works (for now) with the test email address I gave you and that you used successfully to send me 3 mails.

Have a nice day!
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Please have a look at the Page 3-25 of the PDF I've uploaded in a previous post. Take the step 6. The Username is TestUser2014. Even thought this is a test SMTP server, I still must be careful in giving you the Password on this public forum. For this reason I will send you the Password via mail. Please send me a mail (not from the KODAK) to stefano.rivoli@gmail.com and I'll respond with the Password. Any other communication should continue on this forum.
Once you have both (Username and Password) record them in the already mentioned step 6.
Send a mail from the KODAK to the test mail address I gave you and ANOTHER mail from the KODAK to another REAL mail address. ATTENTION: since my SMTP server is a test one, the recipient's mail server might classify the mail as SPAM.
For example: if you send the mail to the REAL mail address such as imservices@gmail.com, GMAIL might classify this mail as SPAM.
I'm waiting for a reply from you. Bye.
0
 

Author Comment

by:imservices
Comment Utility
.I have had a chance to test, here are the results:

After configuring with the username and password that you gave me..the smtp test is successful.

1. sending emails from the kodak to "imservices@domain.com"
works (this is your mail server)

2. Sending emails from the kodak to any other real address fails....same error, error processing one or more destinations.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Hi. I see the 2 tests you have made to imservices@domain.com.
Let me have a look at the logs and I'll give you feedback in some minutes.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
I've set my logs more verbose because they do not report anything. They are useless now.
Please try once again to send a mail from the KODAK to a real address and please post the address you are trying to send to. For privacy, you might prefer to tell me the address using my gmail address instead of this thread.
0
 

Author Comment

by:imservices
Comment Utility
I sent the test mail again.
Same result.
the email to imservices@domain.com work ok
the one to the real email address (info@imservicesnv.com) failed.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
I'll send you some test mails to info@imservicesnv.com. Don't reply since they are sent from fake senders. Just count them. I'll post once again when I've finished my tests in about 10-20'.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Here I am again. I didn't mention in my previous post that I've got 2 test mails from you. Didn't even see the content.
I've just sent you 2 test mails. Please confirm you've received them.
Please make some other tests to info@imservicesnv.com but change the Username on the KODAK (the Password remains unchanged). I told you to use TestUser2014. Please try to send from KODAK using the Username TestUser2014@tecnosoft2.local and try using the Username TECNOSOFT\TestUser2014.
Please post again when you are finished. Thanks.
0
 

Author Comment

by:imservices
Comment Utility
confirmed I received 2 emails from Administrator@domain.com
I will test with the users : TestUser2014@tecnosoft2.local and TECNOSOFT\TestUser2014 (using the same password.
I will send test to info@imservicesnv.com and get back to you with the outcome.
0
 

Author Comment

by:imservices
Comment Utility
sent test with user TestUser2014@tecnosoft2.local--to info@imservicesnv.com-->failed
sent test with user  TECNOSOFT\TestUser2014--to info@imservicesnv.com-->failed
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Please have a look at the Page 3-25 of the PDF I've uploaded in a previous post. Take the step 10. We might have set it to NONE. Please set it to Use Strongest.
Let me know. Thank you.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
I kindly ask for some feedback. Otherwise I will consider the thread abandoned and will shut down the test SMTP server in about 12 hours from now. Thank you for understanding.
0
Free book by J.Peter Bruzzese, Microsoft MVP

Are you using Office 365? Trying to set up email signatures but you’re struggling with transport rules and connectors? Let renowned Microsoft MVP J.Peter Bruzzese show you how in this exclusive e-book on Office 365 email signatures. Better yet, it’s free!

 

Author Comment

by:imservices
Comment Utility
Please allow some time, I won't be able to test until later today or early tomorrow.

Thank you.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Take your time. Thank you for responding. I suspected you abandoned this thread. Bye.
0
 

Author Comment

by:imservices
Comment Utility
Thank you for your patience, I have used the settings as indicated, on the scanner admin software, the test is successful. I will be running a test on the scanner in the next few hours, once completed, I will let you know the outcome,
0
 

Author Comment

by:imservices
Comment Utility
Thanks for your patience. All the test returned successful
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
If your tests are over and you got the problem fixed, please close the question. Thank you.
0
 

Author Comment

by:imservices
Comment Utility
The problem is not yet fixed, Although the tests are successful, when I use these same settings, with my mail server (i.e. go daddy, hosted exchange settings), one of three things happen,

1. The mail is sent but is never received,
2.  Only mails from the same domain are received,
3. the mail fails.

Please allow some time for me to further test,
In either case, I believe you have been very helpful, and will be credited accordingly.
thank you
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Wait... I want you to be 100% satisfied! :-)
If you wish, I can set my server at a closer level to GoDaddy's. Let me know.
0
 

Author Comment

by:imservices
Comment Utility
All tests return successful from the scanner, however, emails are not received,
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Please be more specific: they are not received when sent using my test SMTP server or when sent using the GoDaddy SMTP server?
0
 

Author Comment

by:imservices
Comment Utility
When sent using your smtp server everything is successful and emails are received.
When sent using go daddy's smtp details, the scanner reports emails sent successfully, however, the emails never arrive at the destination.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
You tried 2 recipients with my test SMTP server:
zag...@...cnv.com
info@...snv.com

Did you try both with GoDaddy's server too and both do not arrive? Please confirm.
Please send a test scan (using GoDaddy's) to my address @gmail. Please post when you are finished.
0
 

Author Comment

by:imservices
Comment Utility
Did you try both with GoDaddy's server too and both do not arrive? Please confirm.-->Yes,

I tried both with go daddy settings and one of them arrived.

Please send a test scan (using GoDaddy's) to my address @gmail. Please post when you are finished.--->will let you know once we test it

thank you
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
OK. Which one arrived? I must ask you every single question.
I wonder if you want to solve the problem or are simply wasting my time.
If you don't care, please simply write it ("I DON'T CARE") and I'll stop responding to this thread.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Since the test SMTP server isn't needed anymore, I'm shutting it down.
0
 

Author Comment

by:imservices
Comment Utility
Dear Strivoli,
I do need to solve this problem, I did not realize, I had a spelling mistake until i saw your response, In the above reply I meant none, of them arrived when I used the go daddy settings. (for some reason the 'n' key on my keyboard did not work, and I did not double check before posting,
my apologies.
0
 

Author Comment

by:imservices
Comment Utility
Sent to your private email at gmail. scanner say successful, please let me know if you receive it,
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Hi. No, I didn't receive any mail from you on my gmail address.
I start thinking it's GoDaddy's server refusing your mail because it might consider it as spam.
a. Do you have any control of GoDaddy's server?
b. Can you read the server's logs or set the AntiSpam in order to white-list the mails from the scanner?
c. Do you have Help Desk at GoDaddy that can check the logs or set the white-list for you?
0
 

Author Comment

by:imservices
Comment Utility
Thanks for your response,
I thought the same, and have contacted support as I am not able to see the logs directly from my control panel. they will get back to me shortly, I will let you know the outcome as soon as I have heard from them.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
Furthermore: the 1st thing I would check is if GoDaddy's server receives the mail you send from the scanner.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
OK.
0
 

Author Comment

by:imservices
Comment Utility
Go daddy, have confirmed all looks ok with the account in question (i.e. the account configure on the server), it is not listed as spam, They are still checking to see if its white listed or if there are any other issues preventing the mails from coming through..they have not confirmed for me as yet whether the mails are being received or not.

I will get back to you shortly.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
OK. Thanks for the feedback.
0
 

Author Comment

by:imservices
Comment Utility
Godaddy support wasn't so good, they did confirm that the emails are being received. but since the owa work fine, there is not much they can do from their end, From their mail server everything looks ok, they said that its probably something to do with my local network or the scanner itself, the scanner may be confirming that the email is sent, but somehow somewhere along the line it is either blocked or not being sent at all.
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
OK. Lets see if I understood: GoDaddy says they receive the mails from the scanner. That means the mail reaches GoDaddy's server. If this is it, they should trace the mail and understand where it gets lost or dropped. It must be something INSIDE the GoDaddy's server.
Please confirm: does GoDaddy confirm they receive the mails?

Furthermore: the addresses you have tested (exclude mine which is gmail and isn't hosted by GoDaddy's server) are hosted on GoDaddy's server or on another mail server? If it is on another, it would be better to test a mail with an address hosted by GoDaddy.
0
 

Author Comment

by:imservices
Comment Utility
I will get exact confirmation for you.
The email address I tested (excluding yours) are all hosted at go daddy.
0
 

Author Comment

by:imservices
Comment Utility
So far, go daddy insists that as long as the webmail (owa) for that account is working, then there is no issue with the mail box, and no issue on their side, so basically, I am in a deadlock...
0
 
LVL 19

Expert Comment

by:strivoli
Comment Utility
All you need is a SMTP server and that doesn't need to be GoDaddy's. Doesn't your ISP (your Internet Service Provider - the company that supplies the Internet connection) allow you to use its SMTP server?
Or, don't you have another mail account (such as Google's Gmail) and you could use that account's SMTP server?
0
 

Author Comment

by:imservices
Comment Utility
I am currently working on this....I think its the way to go...as you rightly stated, all I need is an outgoing smtp server. I will let you know the outcome...
thanks
0
 

Author Comment

by:imservices
Comment Utility
I've requested that this question be closed as follows:

Accepted answer: 0 points for imservices's comment #a39908999

for the following reason:

I have used gmail smtp server, and that works fine,..Go daddy support is useless..
0
 
LVL 19

Accepted Solution

by:
strivoli earned 500 total points
Comment Utility
I've worked very hard and my last post suggests what the requester did.
Thank you.
0
 

Author Comment

by:imservices
Comment Utility
Dear Strivoli,

I accepted your solution and awarded you the points, if this did not happen then I might have done some thing wrong, but it is my full intention to give you the points for this as you worked very hard on this..
this is my first time on EE so I may have closed it off wrong,
Please advise, if you have not been awarded the points
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Granting full access permission allows users to access mailboxes present in their database. By giving full access permission one can open and read the content of any mailbox but cannot send emails from that mailbox.
Great sound, comfort and fit, excellent build quality, versatility, compatibility. These are just some of the many reasons for choosing a headset from Sennheiser.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now