Remote Web Workplace Error

Im using SBS 2011 and when users are trying to access company shared folders via the remote web workplace they get an unexpected error. (Screenshot attached)

If I give the server a restart it will all seem ok again then all of a sudden the same thing happens.

Is there anything I can do to stop this happening or see whats causing the error?

Thanks
Untitled.jpg
RedDoorSuppliesAsked:
Who is Participating?
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
FYI, it's set as "0" in the SBS's Blog post about it:
http://blogs.technet.com/b/sbs/archive/2014/01/13/troubleshooting-an-unexpected-error-occurred-message-when-using-remote-web-access-to-connect-to-computers.aspx

But note that it also mentions that you should have .NET Framework 4.5.1 applied.
0
 
Manjunath SulladTechnical ConsultantCommented:
Are you able to see any errors in event viewer on that server,

Please cross verify the is there any hung Services (if possible restart IIS service) and check,

Check any tasks schedules are running backend,


During the issue - are you able to access the server from client ?

try accessing \\servername and check.
0
 
WORKS2011Austin Tech CompanyCommented:
please run fix my network.

any errors in the log files showing for IIS?
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
RedDoorSuppliesAuthor Commented:
Have run the fix my network wizard which found a DNS forwarder error and a problem with the time service these have both been resolved but still get the same error.

Everything works ok from inside the network so can browse the server then onto folders etc.

I have just seen an error with event ID 3 and the following text not sure if its related though?

WebHost failed to process a request.
 Sender Information: System.ServiceModel.Activation.HostedHttpRequestAsyncResult/20873117
 Exception: System.ServiceModel.ServiceActivationException: The service '/Remote/BuiltIns/FS/FileOperationService.svc' cannot be activated due to an exception during compilation.  The exception message is: Memory gates checking failed because the free memory (557576192 bytes) is less than 5% of total memory.  As a result, the service will not be available for incoming requests.  To resolve this, either reduce the load on the machine or adjust the value of minFreeMemoryPercentageToActivateService on the serviceHostingEnvironment config element.. ---> System.InsufficientMemoryException: Memory gates checking failed because the free memory (557576192 bytes) is less than 5% of total memory.  As a result, the service will not be available for incoming requests.  To resolve this, either reduce the load on the machine or adjust the value of minFreeMemoryPercentageToActivateService on the serviceHostingEnvironment config element.
   at System.ServiceModel.Activation.ServiceMemoryGates.Check(Int32 minFreeMemoryPercentage, Boolean throwOnLowMemory, UInt64& availableMemoryBytes)
   at System.ServiceModel.ServiceHostingEnvironment.HostingManager.CheckMemoryCloseIdleServices(EventTraceActivity eventTraceActivity)
   at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath, EventTraceActivity eventTraceActivity)
   --- End of inner exception stack trace ---
   at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)
   at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result)
 Process Name: w3wp
 Process ID: 18324
0
 
RedDoorSuppliesAuthor Commented:
Right had a look and the server looks like its using all its memory (hence the error above im guessing)

Currently this box has got 14Gb of RAM can anyone recommend what it should be increased to?

Under the performance tab on taskbar its showing as 13.2Gb in use?

Thanks
0
 
Olaf De CeusterCommented:
Its fairly normal for most memory to be assigned to Exchange.
14GB of memory should be OK, but more is always better.
Exchange memory usage can be trottled but before you do try running the BPA to look for mistakes:
http://support.microsoft.com/kb/2673284
We are up to version 1.5
Issues with RWW  file access can be due to sharepoint  / IIS (need to run psconfig manually to upgrade) but BPA will tell you, or space/ permission issues.  Permission issues could be caused by AV.
Hope that helps,
Olaf
0
 
RedDoorSuppliesAuthor Commented:
Ok thanks for that, I have some more memory on order so will be putting that in ASAP

I have run the BPA which has given me a few un related bits to look at so will do those, how do I upgrade to version 1.5 as mine is still showing as 1.3?

Many thanks
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
To update the BPA, open Windows Update and select the "Check online for updates from Windows Update" link.

You can probably throttle down Exchange and SQL memory usage:
http://www.bursky.net/index.php/2012/05/limit-exchange-2010-memory-use/
http://www.bursky.net/index.php/2012/10/limit-sql-server-memory-usage/

Jeff
0
 
Olaf De CeusterCommented:
If you chose automatically update dring the install, the update will be installed automatically.
If you run WSUS the latest updates for BPA will be offered.
Or use Windows update as Jeff is suggesting. If using WSUS in oder to use the manual updates you'll have to press: "Check online for updates from Microsoft update"
Olaf
0
 
RedDoorSuppliesAuthor Commented:
Have just maxed the memory on the server to 32Gb so fingers crossed this will sort out the remote users, the memory usage in task manager looks a lot better now so thanks for that.

Im still unable to upgrade the BPA to 1.5 though, I have checked Windows updates online and they are fine. There is one (SQL 2008R2 SP1 KB2528583) from the managed updated that just fails every time I try and install it?

Thanks
0
 
Olaf De CeusterCommented:
What if you use windows update?
Olaf
0
 
RedDoorSuppliesAuthor Commented:
Yes if I open up Windows update it tell me I have the one SP update as managed by system administrators then when I check online for updates it says im all up to date?
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
FYI, I discovered what causes the error you experienced to begin with.  If it reoccurs, please review this forum post:  http://rdsrc.us/M0AG7C

As for any updates that you would like to manually install/reinstall you can get them at
http://catalog.update.microsoft.com

Jeff
0
 
RedDoorSuppliesAuthor Commented:
Just has an update the server memory usage has worked it's way up to 31.4Gb of my now installed 32Gb which im guessing is how it should work but this has once again stopped remote users from accessing the remote web workplace.

I have just applied the Exchange limits as per Jeff's post have set a min of 4Gb and a max of 28Gb so im just going to restart the server and will report back in a few days.

Thanks
0
 
RedDoorSuppliesAuthor Commented:
Sorry Jeff only just spotted your second message that does look like it may resolve the issue.

I have had a look at the web.config file in the following location Program Files\Windows Small Business Server\Bin\WebApp\RemoteAccess but this file doesn't seem to have any entry for minFreeMemoryPercentageToActivateService

Am I looking at the wrong web.config file?

Many thanks

Right I have added in the line minFreeMemoryPercentageToActivateService="0" which I hope is correct not had much experience of messing with web config files.

I have attached an image hopefully someone can let me know if what I have done is correct.

Thanks
Untitled.jpg
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
It shouldn't have had that entry already.  As you'll note in the linked recommendation:

"adding the final attribute listed below (the others are already in the web.config)."

Why did you set it to "0"?  It should be set to "1"
0
 
RedDoorSuppliesAuthor Commented:
Hi Jeff, no it defiantly didn't have than entry already which I though was odd.

I set it to 0 as found this link

http://social.technet.microsoft.com/Forums/en-US/3e753565-3bb9-4255-97da-4b1461e9e9da/sbs2011-problems-connecting-to-pcs-via-rww?forum=smallbusinessserver

Do you think it would be best setting it to 1 instead then?

Thanks
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
It's not odd... the instructions from the forum post are to ADD the attribute because it's NOT there.

Go ahead and leave it set to "0" as I looked up a couple of other things on that and "0" does seem to be right.
0
 
RedDoorSuppliesAuthor Commented:
Sorry my fault misread your message "It shouldn't have had that entry already."

Have just checked and the server is running .NET Framework 4.5.1

Hopefully this should have solved the problem so thanks very much for that.

I will keep an eye on it over the next few days while the memory usage builds up and see if any users report the same issue.

Thanks
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Be sure to throttle down your SQL memory as well --- that will definitely be good overall for the server.

Jeff
0
 
RedDoorSuppliesAuthor Commented:
Thanks that seems to have resolved the issue.

Many thanks for your help!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.