?
Solved

Citrix XenApp 6.5 logon process too slow.

Posted on 2014-02-11
11
Medium Priority
?
417 Views
Last Modified: 2016-06-02
Hello everyone.
Currently I have a server farm with Citrix XenApp 6.5 R03 on Windows Server 2008 R2 SP1.
The problem I have now , is being presented to me every day , on any server in the farm.
When a user wants to start its session, the average duration of Logon, is 25 seconds. However this duration at any time can reach up to 2 minutes, or even not complete the connection , returning the user to the local desktop.
When the event occurs , the user will receive the following message : "Waiting for Local Session Manager " and can be a long time in that message .
I searched for information, and I have applied all Microsoft and Citrix hotfixes related to the event . I have even deleted user profiles, but the problem still persists .
My platform consists of the following :
- 46 servers XenApp 6.5 R03
- Windows Server 2008 R2 Enterprise SP1
- Roaming profiles for users, a Windows Server 2012 File Server with DFS .
- Systems Center 2012 Endpoint Protection on XenApp servers .
- Redirection folders policy ( My Documents , Desktop).
- Users access from a shared desktop .

We immensely appreciate any help you can give me to resolve this event, it is becoming critical to my client.

regards...
0
Comment
Question by:omaguirre
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
11 Comments
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39851544
I know that you have explained that you installed all related hotfixes, but just to make sure: have you installed Microsoft Hotfix KB2661001? And have you restarted all the servers after applying the Hotfix?
0
 

Author Comment

by:omaguirre
ID: 39851551
Mutawadi Hi thanks for your reply.
Indeed I have it installed, in fact was the first hotfix that I installed to try to resolve the issue.

thanks
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39851612
But did you have your servers restarted?
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 

Author Comment

by:omaguirre
ID: 39851620
Sure, in fact, my servers are provisioned from Citrix Provisioning 6.1. Restart is required after installing any fix.

thanks
0
 

Author Comment

by:omaguirre
ID: 39851635
I would add this strange behavior:
A server that is affected by the event, self-recovers after about 1 hour, but after a few hours resubmits the problem.
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39852518
In order to follow a route for troubleshooting, it would be necessary to provide more info on event IDs logged during the issue and on self recovery.
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39852597
Please check the connectivity between your XA servers and DFS. How good it is?

Also if you have file server role enabled on your XA servers, then disable them.
0
 

Author Comment

by:omaguirre
ID: 39853035
Thanks for your help.
Actually my XenApp servers are dedicated. Just have enabled RDS services and XenApp.
I'll check the connectivity to the DFS as you indicate me, additionally I am in the process of migrating to citrix UPM, for not using roaming profiles.
regards
0
 
LVL 4

Expert Comment

by:Rahul Patil
ID: 39950005
Hi,

1)Is citrix server performance ok?
2)DO you have checked Qfarm load on the server?
3)Is Network connectivity causing any slowness
4)Also check com+ object response in Administration tools>>Component services.If its more then try restarting COM+ services.

Reagrds,
Rtantra
0
 

Accepted Solution

by:
omaguirre earned 0 total points
ID: 40021418
Hi all,

sorry for the delayed response, I was on vacation.
Since we solved the problem. Strangely, the problem was because we installed EdgeSight for XenApp and EdgeSight server to run out of memory generated the event.
We solved the problem by increasing the resources to the EdgeSight server.

Thank you all for the help.
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #XenDesktop #POC #Proof-of-concept
What if you have to shut down the entire Citrix infrastructure for hardware maintenance, software upgrades or "the unknown"? I developed this plan for "the unknown" and hope that it helps you as well. This article explains how to properly shut down …
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question