Solved

Sharing folder from external USB drive problems on Windows 7.

Posted on 2014-02-11
25
1,420 Views
Last Modified: 2014-03-09
-Have a 2TB Seagate external USB drive (NTFS) connected to a Windows 7 workstation on a University network.
-Shared out a folder (and set permissions) off Seagate USB few weeks ago and it worked great for a week (even a Mac could see share no problem).
Today I came in and everyone (even me) is getting the following error: Error messageWhat I tried:
-I checked the permissions and everything is perfect.
-I even tried sharing to "Everyone" and still nothing.
One thing I noticed is that the share keeps setting itself to "Read Only":
Showing "read only" box selectedIt does allow me to uncheck the "Read Only" box (it even shows a progress bar as it does the changes), but when I close and reopen the properties the "Read Only" checkbox is back on instantly!!! What the heck???

I also tried to share a folder from the C: drive on the workstation and that worked fine.
Only when I try to share from the USB drive is the problem showing.

What is going on here?
Why did it work for a while then stop?
Do I need to reformat the drive from NTFS to FAT32?
0
Comment
Question by:rr4406pak
  • 9
  • 7
  • 4
  • +2
25 Comments
 
LVL 8

Expert Comment

by:Scott Thompson
Comment Utility
If the external is not saving your settings and suddenly started having issues, you may be have hard drive problems.

Run a full chkdsk (chkdsk (letter of drive:) /v /x /r) to see if you have any bad sectors.  Then, restart the computer and try your share again.
0
 
LVL 9

Expert Comment

by:discgman
Comment Utility
Replug in the usb drive and see if you are having connection problems. Permissions to connect to drive might not mean actual file permissions. Either o/s or hard ware issues with device would be my best guess.
0
 

Author Comment

by:rr4406pak
Comment Utility
Permissions to connect to drive might not mean actual file permissions.

Can you elaborate on this?
0
 
LVL 9

Expert Comment

by:discgman
Comment Utility
What I mean is that it could be more of an issue with the usb device than how the permissions is setup on it. Doesnt mean that is the issue, but its good to check everything.
0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
As I see it your HDD is still getting accessed ok just not this one folder
What is this Milcomeda Flowcap software?
I get little info on this other than some type of wand.
Flowcap: How To
https://www.youtube.com/watch?v=zsdcAwWfzZo
So my line of thinking is if the Flowcap .exe is not running then maybe windows cannot detect it.
Is this a hardware device and this software runs it?

a 2 terrabyte shared drive on a USB would take a bit of time to load
Also is not the best way to share as windows any versions will not like USB as it is a plug and play device.
You are using drive letter J if you unplug and plug in again in a different drive letter then you need to reshare
It would be better to drag all files and folders to the public folder then it is automatically shared to anyone if you have set your networking for everyone.
a 2TB Seagate external USB drive (NTFS) connected to a Windows 7 workstation on a University network
If anyone can access check if this Flowcap is still there and functioning?
0
 
LVL 3

Expert Comment

by:Richard Schilke
Comment Utility
Set windows to always have the device on through power management.
0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
@rschilke
could show us where that windows setting is as I have several 1 terrabyte WD USB drives connected and dont see anywhere in my windows 7 power settings to always on for a USB drive?
Nothing in the properties either
Only display /  power computer
cheers
power settings
0
 
LVL 3

Expert Comment

by:Richard Schilke
Comment Utility
You're in the right area, just adjust your balanced plan setting.
0
 

Author Comment

by:rr4406pak
Comment Utility
Merete,
The problem is much simpler.
Milcomeda is just the name of the computer, and Flowcap is merely a folder name.

This question is just about simply sharing a folder from a USB drive and why I cannot access it.
0
 
LVL 8

Expert Comment

by:Scott Thompson
Comment Utility
rr4406pak,

Have you ran a chkdsk to verifiy the integrity of the drive?  If so, please post results.
0
 

Author Comment

by:rr4406pak
Comment Utility
I ran chksk (which took many hours).
I almost made it to the end when the user had to access files off the drive before she left and I had to cancel the process.
Everything looked fine up until then.
I'll try to run it again but i doubt it will show what the problem is. Just that the disk is fine.
0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
Thanks for the heads-up  rr4406pak
So it is not actually windows accessing the USB drive but rather this one folder on the USB drive  which is what I was trying to clarify.
It used to open now it doesn't is the key and to find out why the folder is now nolonger accessable.
You mention even a MAC can access this folder including other windows desktops?

Access and permission errors can be misleading.
Possible causes, it is still open somewhere on the network especially if a MAc has been accessing it.
Someone has modified the folder and this has not been refreshed in the windows 7.
The Mac has accessed this folder and windows can nolonger access it
Could be a conflict here since there could be software included with the drive that is nolonger functioning.
Such as a backup was running?

Antivirus has flagged some files as a possible threat.
Have you rebooted the Windows 7 workstation on the University network?
Can you access the folder ok on the USB drive?
What are the files inside this folder?
Is space a problem on this Disc
Can you create a new folder and move the files to the new folder while it is off the network then share it again and check if accessable?
Have you seen this>
Access Denied Error or File/Folder Permission Issues on an External Drive
http://knowledge.seagate.com/articles/en_US/FAQ/203795en

What is the USB HDD disc type for this windows 7 workstation, the HDD brand? I know it is a seagate but which seagate

Will my drive work with Windows 7?
List of compatible devices with Windows 7 and related information.
http://knowledge.seagate.com/articles/en_US/FAQ/211931en
Seagate FAQ
http://www.seagate.com/au/en/support/external-hard-drives/
A few things to do
Back to you
Merete
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 

Author Comment

by:rr4406pak
Comment Utility
The problem is really making me mad now.
I put the USB drive on my own workstation. Shared out the folder no problem.
It even remembered the permissions! (How is that possible???)
Went back to the user's office. Hooked it back up. Tried to access the share. ACCESS DENIED!
WTH???????
So you'd think it's obvious it is something to do with the user's computer right?
The user has two computers so I switched the USB to her other computer. That'll work for sure! NOPE! ACCESS DENIED! WTH????
How does the drive be selective between computers????
FYI the user (not me) was logged on to both of her computers.
When I used the USB on my workstation, I was the user (if that has anything to do with anything).
The user can access the folder locally no problem. But NOONE can access the share via a different computer.
This is impossible!
The Seagate drive is model number  SRD00F2.
What the heck is going on?????
0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
Went back to the user's office. Hooked it back up
It has to do with whichever is the host computer  that everyone is connected to the network share on that host computer
You referred to it as the Windows 7 workstation on the University network?
That one.
Is this how you have it setup?
 USB on Network
FYI the user (not me) was logged on to both of her computers.
Are they both windows7?
The workgroup name same or different
0
 

Author Comment

by:rr4406pak
Comment Utility
That diagram is not the way I have it hooked up.
I have the USB drive connected to one of the network computers. Then I share the folder out from the network computer.

All network computers but one are running Windows 7 the other network computer is a Mac with the latest operating system.

All network computers are in the University's Active Directory on same subnet.
0
 
LVL 9

Expert Comment

by:discgman
Comment Utility
How can it remember the permissions? The only difference between your pc and the other users is what? Both same domain permissions? Both same access? Any firewall or anti virus software running?

Also, are all the permissions pushing down to the folders and sub folders?
0
 

Author Comment

by:rr4406pak
Comment Utility
That's what I am confused about.
I have no clue how it is remembering permissions when I switch it from computer to computer. It's amazing!

There is no difference (other than the model of DELL computer) between my PC and others PCs here in the department.

All have the same domain permissions.

All have the same access.

We have Sophos anti-virus running on all computers. Generally no internal (local) firewalls on.

Yes, the permissions are pushing down to subfolders.

Even if I create and share a new folder on the USB drive it will give the "invalid access permissions denied" error.
If I create shares on their local computers, no problems at all. Just this USB drive has the problem that defies all logic.
Thanks.
0
 
LVL 9

Expert Comment

by:discgman
Comment Utility
Does sophos have some sort of restrictions on external media devices? Maybe something that's not enabled for you but for everyone else? Can you double check with whoever controls the main console?
0
 
LVL 3

Expert Comment

by:Richard Schilke
Comment Utility
I read the following about permissions on the Seagate website http://knowledge.seagate.com/articles/en_US/FAQ/202071en

Apparently permissions are set by default to administrator
0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
How are the other computers connecting to the one with the USB connected if not through a router?
Do you have soem kind of switch?
Or are they all wireless?
The point where they are all connecting wireless or ethernet cables is where you need to look
The fact there is a user with two computers check that users name computer name is different.
Rightclick the folder on the USB drive properties security and check if that user is correctly authenticated for two computers.
security USB folder
0
 

Author Comment

by:rr4406pak
Comment Utility
This is a huge University and the routers and switched are all in a locked closet that we do not have access to.

I think the issue is not related to the routers/switches though.

Is there a place I can download the Seagate Free Agent software? I'm thinking if I install this software it might get something to work.
There was some software on the drive but I could not run the .exe to install whatever it was they included with the drive.
0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
The software is usually included with a disc in the box the Seagate came in?
What is on the disc in the folders?
Here's their home page on FAQ and guides if it helps.
www.seagate.com
There is so many to choose from.
Your Seagate is that a Netwrok attached or simply an external USB
The following chart lists which Seagate and Maxtor-brand drives are compatible with Windows 7, as well as the compatibility of software bundled with those drives
http://knowledge.seagate.com/articles/en_US/FAQ/211931en

I have 4 WD Buffallo and in my start menue all programs under Buffalo nothing to do with sharing only the turbo boost and backup stuff
buffalo
Is this a folder you created from within an administrative account?
you say>
Even if I create and share a new folder on the USB drive it will give the "invalid access permissions denied" error.
The difference here is that the shared folder is in a local directory>
If I create shares on their local computers, no problems at all.
 Just this USB drive has the problem that defies all logic.<< not to windows!!
USB is not something windows likes to share as it is plug and play device.
Are you sharing the USB drive or just this folder?
It maybe simpler if you add /copy this one folder to the public folder on your server.
0
 

Assisted Solution

by:rr4406pak
rr4406pak earned 0 total points
Comment Utility
This is simply an external USB drive.

After much research, and trying everything, I have come to the conclusion that you cannot successfully share a folder off of an external USB drive and have it remain stable under Windows 7.
Not possible.
0
 
LVL 69

Accepted Solution

by:
Merete earned 500 total points
Comment Utility
I agree and what I said at my comment here http:#a39852662
a 2 terrabyte shared drive on a USB would take a bit of time to load
Also is not the best way to share as windows any versions will not like USB as it is a plug and play device.
But
According to Microsoft
Most likely you just need to add Everyone to the Sharing and Security settings of the drive.
Right click the drive first and go to properties "first picture" Click on the Sharing tab, click on the Advanced button, put a check mark in the box to share this folder and hit the Apply button, then click the Permissions tab you see there, click the Add button on the new window, type in Everyone in the box then put checks for full control if required and hit the apply button again.

Once that is done open up the Security tab "second picture" click the edit button, then the Add button, type Everyone in the box and hit apply.
In the last picture window below, highlight Everyone then Add the check marks for full control if required then hit the Apply button again.
You should now have access to that drive from your other networked machines.
0
 

Author Closing Comment

by:rr4406pak
Comment Utility
With research on both sides we found sharing a folder from a external USB drive is not stable or reliable.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
Our Group Policy work started with Small Business Server in 2000. Microsoft gave us an excellent OU and GPO model in subsequent SBS editions that utilized WMI filters, OU linking, and VBS scripts. These are some of experiences plus our spending a lo…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now