Solved

Getting the wrong SSL certificate when trying to access a secure site

Posted on 2014-02-11
10
11,045 Views
Last Modified: 2015-02-05
Trying to access a https site. The site has a valid SSL certificate. Whenever I attempt to access the site via this one specific laptop instead of getting the sites valid certificate I am getting this 'DO_NOT_TRUST_fiddlerroot' certificate for the site. Of course this then causes me problems as the key doesnt match and I am not able to access the site.

Did some research and it appears the certificate is tied to an network monitoring tool called fiddler. However I can not find any mention of fiddler under Start>Programs or Control Panel>Programs and Features.

I tried removing the DO_NOT_TRUST_Fiddlerroot certifcates from Internet Options>Content>certificates and from MMC but when I reboot the machine and relaunch IE they all come back.

Any suggestions on how I can either remove this certificate or somehow force this laptop to use the right certificate for the site I am trying to access.
0
Comment
Question by:dowhatyoudo22
10 Comments
 
LVL 5

Expert Comment

by:Leon Kammer
ID: 39850994
Hi,

Open Cert Manager (certmgr.msc), open the Personal and Trusted stores, and delete the fiddler CA key.

Cheers

Leon
0
 

Author Comment

by:dowhatyoudo22
ID: 39851024
Did that. But they keep coming back after I reboot and try to relaunch the site.
0
 
LVL 5

Expert Comment

by:Leon Kammer
ID: 39851069
Hi,

Try in the key store \Users\username\AppData\Roaming\Microsoft\Crypto\Keys\
IE quicklaunch \Users\username\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\
Telerik folder in Program files / app data.

Cheers

Leon
0
 
LVL 35

Expert Comment

by:Mahesh
ID: 39851121
Just install that certificate on laptops trusted root certification store to avoid errors

Fiddler is basically used to monitor SSL (HTTPS) requests
It might get installed in stealth mode with Google chrome etc

Mahesh
0
 
LVL 5

Expert Comment

by:Leon Kammer
ID: 39851366
I was under the impression that fiddler was actually a proxy server used to intercept ssl / tls traffic for logging and debugging purposes.

maybe this has changed.

Cheers

Leon
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 33

Accepted Solution

by:
Dave Howe earned 300 total points
ID: 39852900
You are correct Leon. Someone has configured the "fiddler" diagnostic proxy on this laptop (or on the network, if they are being naughty, and updated the browse on the laptop to use this proxy)

If this was not done by the poster, then the notation on the certificate is correct - you should *Not* trust this certificate,and should investigate your proxy settings accordingly to see where you are getting proxy service from and why it is trying to read "inside" a https connection.
0
 
LVL 5

Assisted Solution

by:Leon Kammer
Leon Kammer earned 200 total points
ID: 39853918
Hi,

Thanks for the confirmation Dave :)

OK, Check IE's proxy settings, and check your connection to the local network.
Confirm you are not connecting via the fiddler proxy on the local machine, or a third party proxy server like privoxy on the local machine.

There are better and easier alternatives for MITM attacks, so I don't think this is anything nefarious.

Cheers

Leon
0
 

Author Comment

by:dowhatyoudo22
ID: 39854025
Thanks everyone. I stumbled across this yesterday afternoon while working on the laptop. Changing the LAN Settings from Proxy to Automatically detect fixed the issue. I'm still not entirely sure how fiddler got on the machine in the first place and how to get it completly off. But its working now.

Dave, you were spot on with the assessment and Leon your steps are excatly what I did to resolve the issue.

Thanks again!!
0
 
LVL 5

Expert Comment

by:Leon Kammer
ID: 39854180
Glad I could help.
0
 

Expert Comment

by:steelejay
ID: 40592568
I also discovered that Microsoft Forefront Security software was controlling the proxy settings of IE. I would change the settings to Auto Discover and MS Forefront would change it right back.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

SSL stands for “Secure Sockets Layer” and an SSL certificate is a critical component to keeping your website safe, secured, and compliant. Any ecommerce website must have an SSL certificate to ensure the safe handling of sensitive information like…
Since pre-biblical times, humans have sought ways to keep secrets, and share the secrets selectively.  This article explores the ways PHP can be used to hide and encrypt information.
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now