[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Sqlplus connection through command prompt

Posted on 2014-02-11
6
Medium Priority
?
608 Views
Last Modified: 2014-02-11
Hello experts,
I need your help, I have been experience a odd thing when I connect to my oracle database through the command prompt on the client side.
Yesterday, I deinstalled and reinstalled my oracle fat client installation on the client side;  when I tried to connect using sqlplus /nolog and then "connect / as sysdba" or using the "user/pass@service_name" I got an Ora-12560 TNS:protocol adapter error, but if I connect using "sqlplus user/pass@service_name" I am able to connect.

I will appreciate any ideas that help me to find out the problem.

Thank you
0
Comment
Question by:mwells08
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 77

Expert Comment

by:slightwv (䄆 Netminder)
ID: 39851557
I can see where 'as sysdba' wouldn't work but there should be no difference using "user/pass@service_name" on the command line or with a CONNECT after '/nolog'.

Can you provide screen shots where one works and one doesn't (not the "as sysdba" one)?
0
 

Author Comment

by:mwells08
ID: 39851594
Thank you for replying so fast, I attached 3 screenshots.
sqlplus-example2.JPG
sqlplus-example1.JPG
sqlplus-example3.JPG
0
 
LVL 13

Expert Comment

by:magarity
ID: 39851598
If your new password has an '@' in it, you'll get this because it confuses the format of the user/pass@service looks like user/p@ss@service
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 

Author Comment

by:mwells08
ID: 39851610
there is no '@' on the password, I typed user/pass@service_name.

Thanks
0
 
LVL 35

Accepted Solution

by:
johnsone earned 1520 total points
ID: 39851658
If you look at examples 1 and 3 that you provided, where is the database name?

Example3, the command should be:

connect scott/pass@oraDB

I cannot see in example1 where you are specifying anything.  However the way you are using it in example1, I have only seen when connecting to a local database.  I believe that when it prompts for user, you should use:  scott/pass@oraDB, but I don't 100% remember how to do that one.
0
 

Author Comment

by:mwells08
ID: 39851694
You were right, thank you johnstone, I forgot to set the oracle_sid and oracle_home before trying to connect.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to Unravel a Tricky Query Introduction If you browse through the Oracle zones or any of the other database-related zones you'll come across some complicated solutions and sometimes you'll just have to wonder how anyone came up with them.  …
Using SQL Scripts we can save all the SQL queries as files that we use very frequently on our database later point of time. This is one of the feature present under SQL Workshop in Oracle Application Express.
This video shows how to Export data from an Oracle database using the Datapump Export Utility.  The corresponding Datapump Import utility is also discussed and demonstrated.
This videos aims to give the viewer a basic demonstration of how a user can query current session information by using the SYS_CONTEXT function

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question