Improve company productivity with a Business Account.Sign Up

x
?
Solved

Windows 2008 R2 Server as RDS..  (How To Enable/Disable Lock Computer Option)

Posted on 2014-02-11
4
Medium Priority
?
1,947 Views
Last Modified: 2014-02-12
I have been looking everywhere and must not be asking the question right.  I have inherited an RDS server which is used by THIN Clients only.  I have a request of a user to be able to go to the start menu and click the "Lock" button.  (right where the Logoff/Disconnect is).  Now somewhere in Group Policy (as we are on a domain and RDS users have a policy in place) this is turned off so as not to allow it.  When clicked it does nothing.  I did find that in GP that User Config/Policies/Admin Template/Start Menu and Taskbar, they have Remove shutdown, restart, sleep, enabled.  Which as it should be.  But where is it that I change the Lock or "Lock This Computer".   I know it is here somewhere, because I can RDP into the server (As my own administrator profile) and it locks just fine.  Just like a Ctl Alt Del,,, but they cant to that as normal users on their thin clients.  I am going a little insane.  It should be easy, but cant find it anywhere.

Any help is much appreciated.
0
Comment
  • 2
4 Comments
 
LVL 41

Accepted Solution

by:
Mahesh earned 2000 total points
ID: 39853032
You can ask users to hit Ctrl+Alt+End on thin clients to pops up lock computer option hopefully and check if it works

Mahesh
0
 
LVL 20

Expert Comment

by:Svet Paperov
ID: 39853147
Here is link of how to disable the "Lock" option. You may have this Regkey configured

http://community.spiceworks.com/topic/79131-how-to-disable-lock-option-on-windows-svr-2008-terminal-server-for-rdp-users

If you have the following key, just remove it or set it to "0"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableLockWorkstation"=dword:00000001

Open in new window

0
 
LVL 4
ID: 39853889
I actually read that one Svet and almost did that.  But I knew since I was admin and it worked, there had to be something set.  I found it. but Mahesh wins the prize.  Something so simple as ctl alt "end"!!!  Learn something everyday.  I am using this solution because even with the "Lock computer" open it is too close to LOGOFF which is the only other option available on start menu.  People accidently log off.  BUT,,, if you want to know where it is GPO style, it is User Configuration\Policies\Admin Templates\System\CTRL+ALT+DEL Options.   I seriously thought it was in Start Menu and Taskbar.  (and I think it should be).   Thanks so much for getting back to me.  Now to train everyone to do the Ctl Alt End and not the Del!...  Thanks so much!!
0
 
LVL 4

Author Closing Comment

by:get-ADuser -F ($_.Name -eq "Todd")
ID: 39853894
Excellent solution to problem and so simple.  Perfect.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Know what services you can and cannot, should and should not combine on your server.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question