• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 499
  • Last Modified:

Desktop connecting to wifi plus router possible?

Hi,

I have a desktop(A) and it's connected via LAN to a wireless router in the office for internal database storage.

There is a wireless network to the internet in my office that I hope to connect so that I can access to desktop(A) when I am outside.

I bought a D-Link Wireless AC Dual Band USB Adapter for desktop(A) but I can only access to the internet when I disable the original LAN network.

Is there anyway I can enable both simultaneously?

*PS: I google about this and I saw an article suggesting to change the IPV4 Metric Interface to different number for both network. I tried setting 10 for the LAN network and 25 for the USB adaptor but still cannot work.

Not very good in networking so let me know if there's anything I have not explained in detail. Thanks for the help/advice in advance.
0
csharp_learner
Asked:
csharp_learner
3 Solutions
 
WORKS2011Austin Tech CompanyCommented:
I bought a D-Link Wireless AC Dual Band USB Adapter for desktop(A) but I can only access to the internet when I disable the original LAN network.
if I understand what you're saying then the answer is "no" because you can only have one NIC, wireless, cable, etc connecting to another network.

Let me know if I need to clarify or if I'm off track regarding what you're looking for.
0
 
Dan CraciunIT ConsultantCommented:
It's not enough to change your metrics, you actually need to create routes to make your setup work.
See here for an explanation [link to competing site removed]

Basically, you create a default route to send all traffic through your internet gateway (wireless NIC) and another to send local traffic through the wired NIC.

HTH,
Dan
0
 
csharp_learnerAuthor Commented:
pc route
Thanks for the replies.

I am not confident in changing the settings myself hence attached my route settings and seek advice on how to change.
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
Davis McCarnOwnerCommented:
Both of your routers are set to use192.168.1.xxx for their network scope and until you change one of them to something else, it won't ever work.  Change the one with internet access to 192.168.2.xxx with a subnet mask of 255.255.252.0 and you may not need to do anything else.
0
 
Rick_O_ShayCommented:
I think you meant a mask of 255.255.255.0.
The mask you gave will still conflict with 192.168.1.0.

Subnet      Mask      Inverse Mask      Subnet Size      Host Range      Broadcast
192.168.0.0      255.255.252.0      0.0.3.255      1022      192.168.0.1  to  192.168.3.254      192.168.3.255
0
 
csharp_learnerAuthor Commented:
Thanks for all the help.
In the end I just used Create Bridge function in Windows to make it work.
Will explore the solution provided by the experts here.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now