Solved

Autodiscovery prompt on Outlook client

Posted on 2014-02-12
8
18,716 Views
Last Modified: 2014-03-05
Hello All,

I am currently running a hybrid setup between my onpremises Exchange server 2007 and Office 365. I have migrated almost all of our users to the cloud. Our MX is still pointing to our onpremises Exchange.

Our ISP has configured all of DNS entries needed, including the Autodiscover entry which is the following: CNAME  -  autodiscover  autodiscover.outlook.com  1 Hour

Email flow seems to be working properly, but in some of my Outlook clients on computers in my network I am getting the following prompt:

"Allow this website to configure user@domain server settings"
"https://mail.domain.com/autodiscover/autodiscover.xml
Your account was redirected to this website for settings
Allow or Cancel"

Of what I understand this says that the autodiscover is redirecting to my OnPremises Exchange server for settings and not to the autodiscover.oulook.com, which is the office 365 one.

I do not know if I am missing something on my internal DNS.

Can someone enlighten me on what's happening?

Also if someone can explain how autodiscover works on my situation I will appreciate it.
Now I am kind of confused on how autodiscover works.
0
Comment
Question by:LuiLui77
  • 4
  • 3
8 Comments
 

Expert Comment

by:mwiesauer
ID: 39853405
seems you do use autodiscover via http redirection. this is one of 4 ways to make it working. autodiscover will check if you do have an A record for autodiscover.domain.com and port 80 listening on that address. the "warning" is usual when using http redirection and you can click it away, so that it does not come up in the future. i recommend to check your autodiscover Settings using remote connectivity analyzer (https://testconnectivity.microsoft.com/)

Martin
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 39853492
You probably just want to suppress that warning -- there are two ways to do it.

Either install the Microsoft Sign-on assistant (which is found on your Office365 Software Downloads - Desktop Setup.

Or, follow this KB article to suppress the warnings by GPO:  http://support.microsoft.com/kb/2480582

I suggest that you install the Desktop Setup because it will also make sure Outlook is fully patched, etc.

Jeff
0
 

Author Comment

by:LuiLui77
ID: 39853839
I have installed Microsoft Sign-on Assistant already. I think I will suppress the message too, but I am still kind of confused as to why is autodiscover redirecting me to my internal Exchange server and not to the Office 365 CNAME entry: autodiscover.outlook.com
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 500 total points
ID: 39857313
As part of the initial configuration of Office365 you should have set up a CNAME record in your EXTERNAL DNS to point autodiscover to autodiscover.outlook.com.

However, if your INTERNAL domain name is the same as your EXTERNAL domain (ie, it is a .com and not a .local) then your workstations will not even know to go out the EXTERNAL DNS to find that CNAME record.  If this is the case, you must add the CNAME record to your INTERNAL DNS -- and be sure to remove any older autodiscover records that might be there.

Jeff
0
 

Author Comment

by:LuiLui77
ID: 39865044
Our Internal domain is .local, but I spotted a couple of autodiscovery entries in my internal DNS, that were most probably created when we first implemented Exchange 2007.
I have a SRV _autodiscover entry pointing to my Exchange 2007 FQDN (mail.domain.com)
and a couple of A Records for autodiscover pointing to my Exchange 2007 IP, so I think that explains it. The Autodiscover request generated by the Outlook client is directed to my Exchange box since my DNS is pointing to it, correct me if I am wrong.

I think until I don't delete all these records, the autodiscover will not be directed to Office 365, It will always be directed to my on-premises exchange box.

So I am thinking to delete these records but not sure what will be the effect. Any ideas?

Can I recreate the records (SRV and A) in case I ran into any overlooked issues?
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 39866039
Definitely remove the SRV records in your internal DNS, that is what is causing the problem.  You don't need to add anything else as long as you don't have a zone in your internal dns configured for your public domain name.

You can always create any type of record you like in your DNS.

Jeff
0
 

Author Comment

by:LuiLui77
ID: 39868769
OK Jeff, Thanks. I will remove the SRV record.

My MX record is still pointing to my on-premises. Do you see any issue caused by the SRV record removal?
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 39869025
Two completely separate things.  Go ahead and remove it.

Jeff
0

Featured Post

Gigs: Get Your Project Delivered by an Expert

Select from freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Exchange 2010 - Server crashed. Cannot mount DB 8 60
AutoCad files and Office 365 SP Site 3 19
Exchange 2010 RU 16 5 28
why is pst smaller? 11 11
Find out what you should include to make the best professional email signature for your organization.
This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

786 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question