Windows 8 - Login as administrator

Experts,

Does anyone know why when I go to test an ODBC driver the system tell me I need to be signed in as an administrator.

I then login at the prompt with the same user ID and password and I am able to go in.  

Is there a way to initially log in as an administrator to avoid this happening?
moriniaAdvanced Analytics AnalystAsked:
Who is Participating?
 
becraigConnect With a Mentor Commented:
you can grant ODBC permissions to a specific user to avoid this:

You can grant Full Control permission to Domain Users/Users as needed by using Group Policy under the following registry key, please try the following steps:
1. Navigate to Computer Configuration\Policies\Windows Settings\Security Settings\Registry
2. Select Registry Key HKEY_LOCAL_MACHINE\SOFTWARE\ODBC
3. Add Domain users and grant Full Control permission to Domain Users / Users (Power User is not available in the case)


You can also disable UAC which I generally do not recommend.

List of registry keys and what they do available at:
http://technet.microsoft.com/en-us/library/dd835564%28v=ws.10%29.aspx
0
 
Michael MachieFull-time technical multi-taskerCommented:
A couple options would suffice for this.

1) Make all Users admins by default
Go to the manage section of My Computer and add 'Everyone' as an admin to the local machine. This will remove all prompts for admin access requests for all programs - no more need to 'Run As Admin' or put your admin credentials in for any Service or program!

* R-Click the 'Computer' icon (in the start menu or the desktop icon
* Select 'Manage'
* Select 'Local Users and Groups'
* Select Groups'
* Dbl-click 'Administrators'
* Choose 'Add'
* Make sure the 'locations' box has the local machine name, if not, click 'Locations' and dbl-click your local machine name (you may need to select the + to expand and see it).
* Click 'OK'
* Under 'Enter the object names..." type in 'Everyone' (no quotes) and select 'Check names'. 'Everyone' should appear
* Click 'OK"
* '\Everyone' should be in the list now
* Choose OK and close all the windows.
NOTE: No matter who logs into your computer or which account is being used they will be a local admin.    

2) Make the specific individual a local admin so when they log in everything they do will be done as an admin.

* Follow the same steps as above but enter in the User account for the User you want to grant admin rights to.

***** If a Domain account, make sure the 'Location' is set to your Domain.
***** If a local User account make sure the location says the computer's name.

Hope this helps!
0
 
McKnifeCommented:
If the same credentials let you in, then the prompt for admin credentials is wrongly worded, that's all. MS does this in some situations: they require you to enter your own credentials to get some privileges that are stripped from your restricted account. Example: add a user to the group nework configuration operators. After logging out and in: he should be able to change network settings even as a non-admin. But alas, he will need to provide his OWN credentials again when doing so. A little madness in the method. So unless you turn off UAC, there is only compatibility shimming to stop this behavior. What is it? A comp. shim is produced by the MS tool ACT5 and tells the executable to use the highest-available token the user can get.
0
 
McKnifeCommented:
Out of interes: how did you solve it? In the ACL mentioned, domain users must have been in already, because you wrote, you could enter your own credentials once more to get in.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.