Solved

Unable to save to local desktop from RDP connection

Posted on 2014-02-12
4
2,982 Views
Last Modified: 2014-02-24
We are running our Point of Sale software on a hosted Windows 2008 R2 Enterprise server. Our agents use Remote Desktop (primarily the app, but there are a select few using the full RDP) to access the software.

Recently, while making tweaks to the app, we accidentally disabled the ability for our users to save items to their own local desktops. After going into RD Session Host Config and re-checking Drive access, as well as re enabling on the Remote App, we are still unable to save to our local machines.

I have rebooted the server, as well as restarted the Remote Desktop Services UserMode Port Redirector service that allows the redirection of Printers/Drives/Ports for RDP connections.

It seems notable that this server was configured prior to our installation of our PDC, which is running Windows Server 2012 R2 Standard back in December, however, there have been no issues accessing local folders and drives until this past weekend when we made those couple changes that we have since changed back to their original configuration.

Has anyone experienced this, and/or no how to get our local drive access back?

Thanks!
0
Comment
Question by:botsadmins
  • 2
4 Comments
 
LVL 13

Expert Comment

by:Michael Machie
Comment Utility
How are you launching the RDP session? Are any Group Policies created applied to the TS (RDS) server disallowing local saves?

If you are using a custom RDP shortcut then you can change the options, or create a new session icon, to allow local saves to any drive you want, to C: for example. You can also allow or disallow the desktop and printers etc.

1) Open a RDP session by clicking Start and typing 'mstsc' into the run/search field.
2) On the screen for the server name click 'Options' at the bottom left.
3) Choose 'Local Resources' tab.
4) Select 'More' under the 'Local Devices and Resources' section
5) Select 'Drives' and expand to select the drives you want to have available.

Review the other options in those menus and customize as needed o add clipboard, printers, sound and video pass-through etc.
0
 

Author Comment

by:botsadmins
Comment Utility
Thanks for getting back to me. I have actually already gone through those steps as well, both prior to, and after restarting the RDS Port Service. We were actually using the clipboard as a work around (save to POS desktop, then copy/paste to local), but the Drives option has been enabled ever since Monday when we first realized our initial error, it just isn't resolving.

As far as Group Policies, I never made any changes, so I'm assuming there shouldn't be any explicitly disallowing local saves. I'm digging through every setting I can find in Local Group Policy Editor on our POS server, and I did find in Computer Config>Windows Settings>User Config>Administrative Templates>Shared Folders, there are "Allow DFS roots to be published," and "Allow shared folders to be published," both of which are not configured.

Would either of these help our situation, since we now have DFS configured on our PDC here locally? I don't have a ton of experience with these particular settings.
0
 
LVL 13

Expert Comment

by:Michael Machie
Comment Utility
I don't have a lot of experience with them either but I would say those settings may help, or even resolve your issue, if you started experiencing your problems at the time you configured/started DFS services.
0
 
LVL 35

Accepted Solution

by:
Mahesh earned 500 total points
Comment Utility
DFS name space and publishing is not related to your issue
Check if you have any GPO configured for RDS server
Check on the OU in which RDS server exists
Also run rsop.msc on RDS server to find out any applied settings

Also check on users workstation who access RDS server if there is any GPO configured
Run gpresult \ rsop.msc on those machine to fin out any settings via any GPO

If you found anything related to clip board, local drives, you need to revert that settings

If none found, you can try below
Create one new OU and move your terminal server in that OU
If you already have separate OU for RDS server then just create new GPO
In GPO navigate to Computer configuration\administrative templates\windows components\Remote desktop services\remote desktop sessions host\device and resource redirection and disable below two options.
Do not allow clipboard redirection
Do not allow drive redirection

Run Gpupdate /force on RDS server, if required take one reboot and then ask users to logoff RDP session once and log back on with local resources selected from there RDP connection.
They should get the access back

Mahesh
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

Understanding the various editions available is vital when you decide to purchase Windows Server 2012. You need to have a basic understanding of the features and limitations in each edition in order to make a well-informed decision that best suits y…
New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now