Solved

How to setup Remote Desktop to go to multiple computers at office

Posted on 2014-02-13
15
717 Views
Last Modified: 2014-03-06
I have multiple servers at my office. I would like to be able to log into my servers through remote desktop. I have one working using port 3389, the standard. On my router, i setup port forwarding using a different port, forwarding to one of my other servers. I got an error saying my server isn't on, remote connections aren't allowed or my server isn't on the network. All three of those are false. The server is on, remote connections are allowed because i can get to it through RDP internally, and it is on the network. What am I missing? Thanks!
0
Comment
Question by:brasiman
  • 6
  • 5
  • 2
  • +1
15 Comments
 
LVL 19

Expert Comment

by:strivoli
ID: 39856440
Perhaps there's a firewall blocking 3389 from your client to the server.
0
 
LVL 19

Expert Comment

by:strivoli
ID: 39856442
The firewall might be the server itself or the router (or even both). Turn off the server's firewall for the time needed to perform a test.
0
 
LVL 18

Expert Comment

by:Netflo
ID: 39856454
Why not just configure NAT on your router / firewall from a high public port to internal 3389 port and IP of your respective servers.

For example:

wanhostname:33001 to internalserver:3389
wanhostname:33002 to internalserver:3389
wanhostname:33003 to internalserver:3389
0
 
LVL 19

Expert Comment

by:Ken Butters
ID: 39856472
I had similar problem myself... I thought that remote desktop services was on, but I had run several anti-malware utilities in the machine I was trying to remote desktop into... and came to find out that Remote desktop Services had been disabled by one of the utilities.

It might be worth a check on the machine you are connecting to, to go into "services.msc" and confirm that none of the "Remote Desktop" services are not disabled.

This was not obvious to me at first, because I had gone into  advanced System settings, on the "Remote" tab, I had confirmed many many times that "allow connections from computers running any version of Remote desktop" was checked.
0
 

Author Comment

by:brasiman
ID: 39856488
Thanks for the quick replies! When i go to one of my servers and to the firewall, this is the message that pops up:

windows firewall cannot run because another program or service is running that might use the network address translation component (ipnat.sys)

I don't have any other firewall on this particular server.

Netflo, sorry for the naive question. Could you exlain a little more how I would try your suggestion?
0
 

Author Comment

by:brasiman
ID: 39856516
Thanks Ken. Those things the seem "obvious" are often the ones we forget. :) I checked services and the only remote service stopped is "Remote Procedure Call Locator". When i am within the network, i can access the server using the internal IP. But when I am outside the office, i can only access my one server that has port 3389.
0
 
LVL 18

Assisted Solution

by:Netflo
Netflo earned 250 total points
ID: 39856533
First of all try to Remote Desktop internally to the servers in question, assuming this works your RDP is working correctly.

Next create a NAT rule on your router, with the external port being 33001 TCP mapping to 3389 TCP internally and pointing to the first server. For the second server, map 33002 TCP to 3389 TCP internally and so forth.

This way you will be able to remote desktop into your servers externally using your WAN IP / hostname followed by specifying the port. For example in RDC you would enter the following computer name:

1.2.3.4:33001 or remote.companywebsite:33001

Does that help or make sense?
0
Network it in WD Red

There's an industry-leading WD Red drive for every compatible NAS system to help fulfill your data storage needs. With drives up to 8TB, WD Red offers a wide array of solutions for customers looking to build the biggest, best-performing NAS storage solution.  

 

Author Comment

by:brasiman
ID: 39856615
I think that makes sense. I don't know if my router allows NAT, or atleast it might not be the best/easiest. I have a Netgear FVS318. I will look at your suggestion now and how I might do this on my router.
0
 

Author Comment

by:brasiman
ID: 39857216
Ok. I tried but can't get that to work. I setup a new router, Cisco RV180. I can access my main server from the outside. On my router, i see one-to-one NAT. Is that what i'm looking for? I played with that, port fowarding and access rules, but can't get access to my other servers from the outside. Are you familiar with the Cisco RV180?
0
 

Author Comment

by:brasiman
ID: 39857226
Say my Outside public IP is 1.2.3.4. Say my 1st server is 192.168.1.2. My 2nd server is 192.168.1.3. My 3rd server is 192.168.1.4. I can access my 1st server (192.168.1.2). I just setup port forwarding, opened port 3389 and it works. I tried setting up port 2289 to forward to my 2nd server (192.168.1.3) but it isn't working. I am trying now to figure out how to incorporate your NAT suggestion on my Cisco router.
0
 
LVL 19

Expert Comment

by:Ken Butters
ID: 39857287
Thinking it would not work...

The suggestion was to map from

1.2.3.4:32001
1.2.3.4:32002
1.2.3.4:32003

To each of these internal ports....

192.168.1.2:3389
192.169.1.3:3389
192.169.1.4:3389

The problem as I see it would be that the external request to your public IP address would always be coming in on port 3389.

You'd have to first find a way to change the port that Remote Desktop Connection is trying to use to connect with.... from the the machine you are using to start the connection.

So for example ... if you machine is x.x.x.x and you connect to your public ip of 1.2.3.4

then the RDC on x.x.x.x machine is going to be using port 3389 to communicate.... so how could mapping ports 32001 through 32003 help?
0
 
LVL 19

Expert Comment

by:Ken Butters
ID: 39857321
Ok... I think I found how to change the listing port...

Step 1 To change the listening port ... you need modify the following registry Key.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp

it by default would be set to 3389.

So for example the following machines could be set up to use the following ports by that registry change. (edit registry on each of the 3 machines you are connecting to).

192.168.1.2:3389
192.169.1.3:3390
192.169.1.4:3391

Then you need to set up a port forwarding for each of

3389
3390
3391

Also need to make sure that these ports are not blocked by firewall.

Then when you set up your remote desktop connections...

you would use your connect to IP address like this:

1.2.3.4:3389
1.2.3.4:3390
1.2.3.4:3391
0
 
LVL 19

Expert Comment

by:Ken Butters
ID: 39857344
sorry for multiple posts... but as I'm sitting here thinking about it... maybe Netflo's is the easier solution...

just that when you set up your Desktop connection you set it up as follows on the machine your are connecting from:

RDC 1 ----- 1.2.3.4:32001
RDC 2 ----- 1.2.3.4:32002
RDC 3 ----- 1.2.3.4:32003


then you could make the following port forwarding adjustments in your router:

external 1.2.3.4:32001 to internal 192.168.1:3389
external 1.2.3.4:32002 to internal 192.168.2:3389
external 1.2.3.4:32003 to internal 192.168.3:3389...

Seems like either this or the registry change solution should work....
0
 

Author Comment

by:brasiman
ID: 39857649
Thanks for the replies! I tried changing the registry, opening port 3390 and setting up port forwarding, but that doesn't work.

I guess i am still a little confused on the other way. Sorry.
0
 
LVL 19

Accepted Solution

by:
Ken Butters earned 250 total points
ID: 39858179
when I said this:

RDC 1 ----- 1.2.3.4:32001

What I mean is... that is how to set up Remote Destkop Connection (see attached JPG).

Where 1.2.3.4 is your Public IP ....

Now your router should forward port 32001 to internal port 192.168.1.2 Port 3389

Likewise you can set up

RDC 2 ----- 1.2.3.4:32002
RDC 3 ----- 1.2.3.4:32003

Where the incoming port numbers are different.... 32002.... 32003 etc.

Each port number coming into the router can be forwarded to a different machine on your home network...

That is what I meant by this:

external 1.2.3.4:32001 to internal 192.168.1.2:3389
external 1.2.3.4:32002 to internal 192.168.1.3:3389
external 1.2.3.4:32003 to internal 192.168.1.4:3389...

Where on the internal network... it is the same port every time... 3389  but a different machine... i.e. 192.168.1.2   192.168.1.3   192.168.1.4 etc...
EE-1.jpg
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Join & Write a Comment

Using in-flight Wi-Fi when you travel? Business travelers beware! In-flight Wi-Fi networks could rip the door right off your digital privacy portal. That’s no joke either, as it might also provide a convenient entrance for bad threat actors.
Transferring data across the virtual world became simpler but protecting it is becoming a real security challenge.  How to approach cyber security  in today's business world!
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now