Exchange error Even ID 3154 MSExchangeRepl

Hello,

We have an Exchange 2008 R2 server and we are getting the following error message. This is our mail Exchange server and we have a second Exchange server on a different location. We use the 2nd server as a backup in case the main server dies. We use the second server to backup our databases.

Any help will be appreciated.

Log Name:      Application
Source:        MSExchangeRepl
Date:          2/13/2014 9:26:10 AM
Event ID:      3154
Task Category: Service
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      NYC-Mail.cwcainc.com
Description:
Active Manager failed to mount database Mailbox Database NEO-Mail on server NEO-MAIL.cwcainc.com. Error: An Active Manager operation failed. Error The database action failed. Error: An error occurred while trying to select a database copy for possible activation. Error: The database 'Mailbox Database NEO-Mail' was not mounted because errors occurred either while validating database copies for possible activation, or while attempting to activate another copy. Detailed error(s):


        nyc-mail:
        Server 'NYC-MAIL.cwcainc.com' has database copy auto activation policy configuration of 'Blocked'.
       

        neo-mail:
        An Active Manager operation failed. Error Database 'Mailbox Database NEO-Mail' on server 'NEO-MAIL' cannot be mounted due to a previous error: At '1/22/2014 11:58:48 AM' the Exchange store database 'Mailbox Database NEO-Mail' copy on this server appears to be inconsistent with the active database copy or is corrupted. For more details about the failure, consult the Event log on the server for other storage and "ExchangeStoreDb" events. A successful failover restored service.
 If you have addressed the underlying problem, or if you have decided to attempt to mount the database despite this error, the mount operation may be attempted by using the '-Force' parameter of the Mount-Database cmdlet.. [Server: NEO-MAIL.cwcainc.com]
        .
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="MSExchangeRepl" />
    <EventID Qualifiers="49156">3154</EventID>
    <Level>2</Level>
    <Task>1</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2014-02-13T14:26:10.000000000Z" />
    <EventRecordID>76441092</EventRecordID>
    <Channel>Application</Channel>
    <Computer>NYC-Mail.cwcainc.com</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Mailbox Database NEO-Mail</Data>
    <Data>NEO-MAIL.cwcainc.com</Data>
    <Data>An Active Manager operation failed. Error The database action failed. Error: An error occurred while trying to select a database copy for possible activation. Error: The database 'Mailbox Database NEO-Mail' was not mounted because errors occurred either while validating database copies for possible activation, or while attempting to activate another copy. Detailed error(s):


        nyc-mail:
        Server 'NYC-MAIL.cwcainc.com' has database copy auto activation policy configuration of 'Blocked'.
       

        neo-mail:
        An Active Manager operation failed. Error Database 'Mailbox Database NEO-Mail' on server 'NEO-MAIL' cannot be mounted due to a previous error: At '1/22/2014 11:58:48 AM' the Exchange store database 'Mailbox Database NEO-Mail' copy on this server appears to be inconsistent with the active database copy or is corrupted. For more details about the failure, consult the Event log on the server for other storage and "ExchangeStoreDb" events. A successful failover restored service.
 If you have addressed the underlying problem, or if you have decided to attempt to mount the database despite this error, the mount operation may be attempted by using the '-Force' parameter of the Mount-Database cmdlet.. [Server: NEO-MAIL.cwcainc.com]
        .</Data>
  </EventData>
</Event>
LVL 2
jmerullaAsked:
Who is Participating?
 
Jamie McKillopConnect With a Mentor IT ManagerCommented:
OK, try reseeding using the instructions I provided above.

-JJ
0
 
Jamie McKillopIT ManagerCommented:
Hello,

If you check your database copies in EMC, do the show as suspended or failed? You may need to reseed the databases. Here are the instructions:

http://community.spiceworks.com/how_to/show/45338-how-to-reseed-a-failed-mailbox-database-copy-in-exchange-server-2010

-JJ
0
 
jmerullaAuthor Commented:
the database copy on EMC shows its copy status as "dismounted". None of them are suspended or failed.

Is this giving you more insights?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Jamie McKillopIT ManagerCommented:
Try mounting the copy of the database that shows as dismounted.

-JJ
0
 
jmerullaAuthor Commented:
My manager tried to mount the DB and it fails.

In his words "The database can't be mounted on the server due to a previous error.  The copy on this server appears to be inconsistent with the active database copy or is corrupted (this copy is the active database)."
0
 
jmerullaAuthor Commented:
Hello experts,

I'm having the same issue I described above again. we stopped having the problem but it is back.
My manager was able to mount the database on the active server but we are now unable to update the passive copy of the database so its in a failed state. When he attempted to update the passive copy on the database he keeps getting an error message, please see it below: (your help is appreciated)

Error:
A source-side operation failed. Error An error occurred while performing the seed operation. Error: Communication was terminated by server 'ActiveServer': Data could not be read because the communication channel was closed.. [Database: MailboxDatabase, Server: PassiveServer]

Communication was terminated by server 'Active Server': Data could not be read because the communication channel was closed.
Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.3.174.1&t=exchgf1&e=ms.exch.err.Ex4543D9

Exchange Management Shell command attempted:
update-MailboxDatabaseCopy -Identity 'MailboxDatabasel\PassiveServer' -SourceServer 'ActiveServer' -DeleteExistingFiles
0
 
Jamie McKillopIT ManagerCommented:
It sounds to me like you may have some network issues between your sites.

-JJ
0
 
emgit47Commented:
We had this event popping up, but also event 1035 from exchange transport which is an authentication problem, turned out to be time was wrong at one side and out by 6 minutes which is enough to throw authentication failures. queues started pumping through within minutes.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.