Windows Remote Desktop Errors

I am having great difficulty using remote desktop lately due to encryption errors which cause my session to end or to fail immediately when a session is started.  This is not limited to a particular VPN client; it happens when no VPN is in use or when using SonicWall or OpenVPN.  This is not limited to a particular version of Windows server; it happens with 2008 R2 and 2003 (don't know about 2012).  This is not limited to my main workhorse, a Dell E6430; it also happens on a Dell E6400 and my HP Pavilion, all with Windows 7 Pro.

My location also does not matter, so I'm pretty certain that no firewalls or routers are to blame.

I am pretty much unable to RDP to any of my clients right now, so a solution is GREATLY appreciated.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.


I've had these issues recently also.  but the second attempt usually succeeds.  So it doesn't matter how many tries you attempt right?

- gurutc
Jason WatkinsIT Project LeaderCommented:
Are you using RDP over a VPN session? Could there be a certificate mismatch between your machines and the VPN server?
wolf2008Author Commented:
Gurutc, believe me, the first thing I do is make a second and then a third attempt.  This matters not.

Firebar, as I wrote initially, I experience these errors with a direct remote desktop session, and also when using or trying to make a session over OpenVPN or Sonicwall Global VPN.
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

wolf2008Author Commented:
I'm posting the exact error message I get in case it's helpful and in case someone might be drawn here via web search.

"Because of an error in data encryption, this session will end.  Please try connecting to the remote computer again."
Jason WatkinsIT Project LeaderCommented:
Change Security layer of the RDP-TCP session to "RDP Security Layer".  That seemed to allow us to bypass the schannel errors we were seeing in the logs.  Seems like when you have a second IP it does something to break the SSL host-specific certificate.


Is the PC in a DMZ of some sort? If so, remove it and try again.
wolf2008Author Commented:
Firebar, thanks.  I think I saw this posted somewhere else before creating my own post.  I tried to make the RDP session layer change you suggest, but it did not help me.

Definitely not in a DMZ.  As I have written, I have experienced this problem when attempting remote desktop sessions from various locations and from behind various firewalls.
wolf2008Author Commented:
Hi Everyone.  I really appreciate your attempts to assist to this point.  Here is another piece of information.

I have been playing with Ubuntu recently to see if it might serve any purpose in our environment.  Yesterday I configured xRDP and was experimenting with a remote desktop session to my Ubuntu host.  My xRDP session ended with the exact same error message that I have been getting when trying to access Windows 2003 and 2008 servers.
Jason WatkinsIT Project LeaderCommented:
Is your mstsc software configured to use a Microsoft RD Gateway?
wolf2008Author Commented:
My current configuration is "Automatically detect RD Gateway server settings"
wolf2008Author Commented:
Here is the solution that worked for me: delete the Citrix DNE Lightweight Filter from NIC.  Immediate and complete results were obtained for me, and I've had no problems for a week now.

Thanks a lot for all contributions.
wolf2008Author Commented:
I found that deleting the DNE filter renders Sonicwall Global VPN client useless.  Having Citrix in the name of this plugin is misleading, as it is not directly tied to the Citrix client that also have installed on my laptop, which was my assumption.  I did not care about the Citrix client since I hardly ever need it, and could live without it.  Unfortunately, I need my global VPN client from SonicWall.

How ironic is this?  When I have my VPN client installed properly, it disrupts my ability to remote desktop over that VPN.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wolf2008Author Commented:
my solution worked
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.