Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Cannot establish a Homegroup

Posted on 2014-02-15
12
Medium Priority
?
377 Views
Last Modified: 2014-02-16
I have two PCs, both connected to a Comcast modem/router combo unit via CAT5, both running Windows 7 Home Premium.  Let's call them "Desk" and "TV", which is being used as a media center.  I have tried everything I could find here and everything Mr. Google could suggest but Desk is denied connection to the Homegroup established by TV.  So I thought I would start over, killed the Homegroup on TV, and selected to "Create a Homegroup"  on Desk.  But Desk says "Windows cannot set up a Homegroup on this computer."  Windows 7 Home Premium is supposed to be able to do that, and it will on TV.  So I think my first problem to overcome is simply getting Desk to be enabled to set up a Homegroup.  If it could create one, I assume it could join one.
0
Comment
Question by:Mike Caldwell
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
12 Comments
 
LVL 35

Expert Comment

by:Dan Craciun
ID: 39861816
Check in Control Panel->Network and Sharing Center if your network type is "home". If it's not, change it to home.

If it's "Public" you cannot set up/join a Homegroup.

HTH,
Dan
0
 
LVL 98

Expert Comment

by:John Hurst
ID: 39861886
Also, on the problem computer, go to Network and Sharing Center, Advanced Sharing Options and check the settings at the bottom of Home to make sure Homegroup is enabled. Using Password protected sharing turns Homegroup OFF.

Once done, go back to Control Panel, Homegroup settings and see if you can enable it.

You can also look in Services to ensure the Homegroup services are running.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 39862397
The only thing that needed changing was to turn password protected sharing off.  The rest were already as you suggest.  And Homegroup is running in Services.  But it has not changed anything.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 98

Expert Comment

by:John Hurst
ID: 39862541
Since you did have to re-enable Homegroup on the problem computer, then try this:

Remove the Homegroup from each computer (do this from Control Panel, Homegroup).
Restart all computers.
Now try making a new Homegroup on the computers.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 39862878
No change:  I can start a Homegroup on TV but the same error message on Desk.
0
 
LVL 98

Expert Comment

by:John Hurst
ID: 39863053
Please double check the settings and the bottom of the screen below:

Windows7-Advanced-Network-3a
Please double check that both Home Group Provider and Home Group Listener services are started and running.

And you appear to have verified your NIC is set to be Home/Work above.

Then if nothing works on the problem computer:

1. Run System File Checker to see if it repairs system files. Open cmd.exe with Run as Administrator and run SFC /SCANNOW and allow to complete. Restart and test.

2. If no, you may have to back up and run a Windows 7 Repair Install.
0
 
LVL 98

Accepted Solution

by:
John Hurst earned 2000 total points
ID: 39863064
I also found the suggestion below in a Microsoft Support Forum.

Deleting the file  idstore.sst under
windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking

http://social.technet.microsoft.com/Forums/windows/en-US/a85eaa65-d73a-4324-ad0c-e9a2c1469bd7/windows-cannot-set-up-homegroup-on-this-computer?forum=w7itpronetworking

See if that file is there (this was not a solution for everyone) and if so try deleting it.
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 39863192
My settings are per your screen capture, but confirm that you are saying media streaming should be off.

And in your earlier input you indicated that password protected sharing should be OFF, but here you show it ON.

Home Group Provider is listed on the  Task Manger services list, but Listener is not.  But under Control Panel services both indicated Started, but they were also Manual.  So I set them both to Auto start.  i'm going to restart now and see what happens.
0
 
LVL 98

Expert Comment

by:John Hurst
ID: 39863202
And in your earlier input you indicated that password protected sharing should be OFF, but here you show it ON.

My picture was from an existing setup. You can try disabling password protected sharing to see if it helps. I am not certain if that setting affects Homegroup. The bottom one certainly does.

Home Group ... Listener is not.

Listener needs to be ON. See what happens after setting to Auto Start and restarting.
0
 
LVL 98

Expert Comment

by:John Hurst
ID: 39863279
Please let us know after restarting. As I search for reasons about Homegroup services, I see the same two solutions several times

1. System File Checker:  Did you run this?  And the result?

2. Deleting the file  idstore.sst :   Did you try this/
0
 
LVL 1

Author Comment

by:Mike Caldwell
ID: 39863284
John: deleting idstore.sst did the trick.  Both are now connected.  Thanks so much for your patience and persistance.

Next I will be posting for how to get my wife's Mac visable on the network.  Don't care if it is technically part of the Homegroup, just want her to be able to access my folder with all of our important PDF documents.
0
 
LVL 98

Expert Comment

by:John Hurst
ID: 39863291
@old_mike - Thanks for the update. I was very happy to help get Homegroup going.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A small collection of useful tips and tricks for Windows 10 users that I decided to write as a result of recent questions that were asked and answered at Experts Exchange. Two short video tutorials included. Enjoy..
Windows 10 Creator Update has just been released and I have it working very well on my laptop. Read below for issues, fixes and ideas.
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum editing capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question