• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 722
  • Last Modified:

redhat cluster

I recently setup redhat cluster.  fencing is working fine.  I created a new service group for apache. when i tried to do manually everything fine. If i try to start the service its failing. Please advise.

[root@node1 ~]# cat /etc/cluster/cluster.conf
<?xml version="1.0"?>
<cluster config_version="31" name="prod">
        <clusternodes>
                <clusternode name="node1.rnd.ca" nodeid="1">
                        <fence>
                                <method name="vmfence">
                                        <device name="fence_testserver1" ssl="on" uuid="423331fe-8301-8171-5079-9a5007a792d4"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="node2.rnd.ca" nodeid="2">
                        <fence>
                                <method name="vmfence">
                                        <device name="fence_testserver1" ssl="on" uuid="4233f57e-a8fc-8fce-b413-ff39ec992fcc"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="node3.rnd.ca" nodeid="3">
                        <fence>
                                <method name="vmfence">
                                        <device name="fence_testserver1" ssl="on" uuid="4233c09b-347e-b13b-cb9b-6c88d3101e3c"/>
                                </method>
                        </fence>
                </clusternode>
        </clusternodes>
        <rm>
                <resources>
                        <lvm lv_name="halv" name="halvm" self_fence="on" vg_name="webvg"/>
                        <apache config_file="conf/httpd.conf" name="web-server" server_root="/etc/httpd" shutdown_wait="0"/>
                        <fs device="/dev/webvg/halv" force_unmount="on" fsid="49557" mountpoint="/var/www" name="wwwfs" quick_status="on" self_fence="on"/>
                        <ip address="192.168.2.35/255.255.255.0" disable_rdisc="on" sleeptime="5"/>
                </resources>
                <failoverdomains>
                        <failoverdomain name="web" ordered="1">
                                <failoverdomainnode name="node1.rnd.ca" priority="1"/>
                                <failoverdomainnode name="node2.rnd.ca" priority="1"/>
                                <failoverdomainnode name="node3.rnd.ca" priority="1"/>
                        </failoverdomain>
                </failoverdomains>
                <service domain="web" name="webSG" recovery="relocate">
                        <lvm ref="halvm"/>
                        <fs ref="wwwfs"/>
                        <apache ref="web-server"/>
                        <ip ref="192.168.2.35/255.255.255.0"/>
                </service>
        </rm>
        <fencedevices>
                <fencedevice agent="fence_vmware_soap" ipaddr="192.168.2.23" login="administrator" name="vmware-fence" passwd="Oracle@to" power_wait="5"/>
                <fencedevice agent="fence_vmware_soap" ipaddr="192.168.2.23" login="administrator" name="fence_testserver1" passwd="Oracle@to"/>
        </fencedevices>
</cluster>




[root@node1 ~]# tailf /var/log/messages
Feb 15 20:37:56 node1 rgmanager[10440]: Service service:webSG is recovering
Feb 15 20:37:56 node1 rgmanager[10440]: #71: Relocating failed service service:webSG
Feb 15 20:38:02 node1 rgmanager[10440]: Service service:webSG is stopped
Feb 15 20:39:54 node1 kernel: EXT4-fs (dm-2): mounted filesystem with ordered data mode. Opts:
Feb 15 20:40:39 node1 rgmanager[10440]: Stopping service service:webSG
Feb 15 20:40:40 node1 rgmanager[13277]: [apache] Stopping Service apache:web-server
Feb 15 20:40:40 node1 rgmanager[13299]: [apache] Checking Existence Of File /var/run/cluster/apache/apache:web-server.pid [apache:web-server] > Failed - File Doesn't
Feb 15 20:40:40 node1 rgmanager[13321]: [apache] Stopping Service apache:web-server > Succeed
Feb 15 20:40:40 node1 rgmanager[13428]: [fs] unmounting /var/www
Feb 15 20:40:41 node1 rgmanager[10440]: Service service:webSG is disabled


^C
[root@node1 ~]# date
Sat Feb 15 20:41:13 EST 2014
[root@node1 ~]#
[root@node1 ~]#
[root@node1 ~]# clustat
Cluster Status for prod @ Sat Feb 15 20:43:57 2014
Member Status: Quorate

 Member Name                                                     ID   Status
 ------ ----                                                     ---- ------
 node1.rnd.ca                                                        1 Online, Local, rgmanager
 node2.rnd.ca                                                        2 Online, rgmanager
 node3.rnd.ca                                                        3 Online, rgmanager

 Service Name                                                     Owner (Last)                                                     State
 ------- ----                                                     ----- ------                                                     -----
 service:webSG                                                    (node1.rnd.ca)                                                   failed
0
ittechlab
Asked:
ittechlab
  • 3
  • 2
1 Solution
 
asavenerCommented:
OK, I have to ask:  The whole purpose of using RedHat over some other distro is to get support.  Have you opened a ticket with them about this?
0
 
multimacCommented:
Does the directory
/var/run/cluster/apache/
exist?

If not, recreate
mkdir -p /var/run/cluster/apache/
0
 
ittechlabLinux SupportAuthor Commented:
in what order i have to create the service group.

here are the resources i am using

HA-LVM
File system
IP - floating IP
Apache
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
multimacCommented:
The order is ok
0
 
ittechlabLinux SupportAuthor Commented:
I am going to recreate the service group and lets see.
0
 
ittechlabLinux SupportAuthor Commented:
my solution worked out.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now