Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

SMTP not sending emails but I can receive emails: Centos Linux VPS

Posted on 2014-02-16
12
Medium Priority
?
2,803 Views
Last Modified: 2014-08-06
Hi,

I'm wondering why I can receive emails for my domain but not send any emails. I'm on a Centos VPS using WHM/cPanel.

I read that it could be my iptables so I turned off (temporarily) my iptables using:
/sbin/iptables -F

But still can't send the emails.

I noticed in my WHM->Mail Queue Manager that I have emails that are frozen. Why is it frozen?

So I clicked on "unfreeze" on one of them and it's now in queue.

On a couple of other emails I tried to "Deliver Now" but I get this error message:

LOG: MAIN
  cwd=/usr/local/cpanel/whostmgr/docroot 4 args: /usr/sbin/exim -v -M 1WF2oO-0006mf-R9
delivering 1WF2oO-0006mf-R9
LOG: MAIN
  Unfrozen by forced delivery
Connecting to p3plsmtps2ded-v01.prod.phx3.secureserver.net [208.109.80.210]:25 from 173.201.24.210 ... connected
  SMTP<< 220 p3plsmtps2ded03.prod.phx3.secureserver.net : DED : ESMTP
  SMTP>> EHLO yeshua.emailmarketingservicesco.com
  SMTP<< 250-p3plsmtps2ded03.prod.phx3.secureserver.net hello [173.201.24.210], secureserver.net
         250-HELP
         250-SIZE 30000000
         250-ENHANCEDSTATUSCODES
         250-8BITMIME
         250 OK
  SMTP>> MAIL FROM:<myultrat@${lc:${domain:$h_from:}}> SIZE=2182
  SMTP<< 550 5.1.0 <myultrat@${lc:${domain:$h_from:}}> SIZE=2182 invalid address
  SMTP>> QUIT
LOG: MAIN
  ** vkimura@gmail.com R=send_to_smart_host T=remote_smtp: SMTP error from remote mail server after MAIL FROM:<myultrat@${lc:${domain:$h_from:}}> SIZE=2182: host p3plsmtps2ded-v01.prod.phx3.secureserver.net [208.109.80.210]: 550 5.1.0 <myultrat@${lc:${domain:$h_from:}}> SIZE=2182 invalid address
LOG: MAIN
  cwd=/var/spool/exim 8 args: /usr/sbin/exim -v -t -oem -oi -f <> -E1WF2oO-0006mf-R9
LOG: MAIN
  Error while reading message with no usable sender address (R=1WF2oO-0006mf-R9): at least one malformed recipient address: myultrat@${lc:${domain:$h_from:}} - domain missing or malformed
LOG: MAIN
  Process failed (1) when writing error message to myultrat@${lc:${domain:$h_from:}} (frozen)

Open in new window


So something isn't set up correctly. What do I need to set up? I had a similar message when trying to send an email using webmail in cPanel for this domain.

the domain is myultratrust.com.

Here's some extra info:

exigrep test@myultratrust.com /var/log/exim_mainlog
2014-02-16 08:10:41 1WF3Mf-0007GS-QY <= vkimura@gmail.com H=mail-yk0-f173.google.com [209.85.160.173]:55868 P=esmtps X=TLSv1:RC4-SHA:128 S=1718 id=CAD7dL_WxkX_ZQEV=sL1unbrfq-YNs8jeSi491p6f7kc-e+tdNw@mail.gmail.com T="test" for test@myultratrust.com
2014-02-16 08:10:41 1WF3Mf-0007GS-QY => test <test@myultratrust.com> R=virtual_user T=virtual_userdelivery
2014-02-16 08:10:41 1WF3Mf-0007GS-QY Completed

root@ip-184-168-116-73 [~]# cat /etc/resolv.conf
search emailmarketingservicesco.com
domain emailmarketingservicesco.com
nameserver 184.168.116.73
nameserver 184.168.28.15

Open in new window


Much thanks for your help in advance<><
0
Comment
Question by:Victor Kimura
12 Comments
 

Expert Comment

by:YoavZ
ID: 39863571
cPanel changes many configuration files for exim.

One of the changes is change the sender name.

It's using a template: myultrat@${lc:${domain:$h_from:}} (probably username@...) but it can't get the domain name for some reason.

I know that with cPanel there are several options for config files rebuilding.

If the problem persists, upload a copy of your exim config files.
0
 

Author Comment

by:Victor Kimura
ID: 39863705
Hi YoavZ,

Thank you for that good information.

I can see the exim options in the WHM->Exim Configuration Manager->Advanced Editor tab. But you probably mean upload and manually configure, correct?

I don't have a working copy of the exim config files. Where are the exim config files that I should look for? Do you have some good examples of files and what to change? I'm still a bit new to exim.

thank you.
0
 
LVL 13

Expert Comment

by:Sandy
ID: 39864438
Do you have CSF installed ? if yes just try once with #csf -x and try to send the mails.

TY/SA
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Victor Kimura
ID: 39864603
I don't think I have it. When I'm in WHM->Manage Plugins I don't see it.
0
 
LVL 13

Expert Comment

by:Sandy
ID: 39864611
while looking for error msgs you are getting i can say it is like exim sender verification and few more settings which can be modify in tweak settings.

Pls check once.

TY/SA
0
 

Author Comment

by:Victor Kimura
ID: 39864846
You mean like SPF (Sender Policy Framework) and Domain Keys? I can show you what I have in my DNS. Is it safe to send all that information here publicly?
0
 
LVL 13

Expert Comment

by:Sandy
ID: 39864954
yes, same as those, its purely safe to put content here but i suggest to remove hostname and IP's while putting anything here.

I am more concern about Tweak settings of mail.

TY/SA
0
 

Author Comment

by:Victor Kimura
ID: 39865368
Ok, thanks. Here is a snapshot of my DNS settings. I'm not quite sure what is wrong. This is the settings for the myultratrust.com.

The second snapshot is the DNS settings for another domain on the same VPS server. I have set up SPF and am using smtp.com as the external send out. However, the smtp.com external SMTP is used for sending out bulk emails for email marketing. I don't use it for normal email send outs.

I haven't got the SMTP server to work for any domain on this VPS. Even when I try via cPanel using the web mail. See the third screenshot. The Identity in the 3rd photo looks malformed. So some setting I'm thinking is misconfigured.

Thanks for your help. =)
WebHost-Manager---ip-184-168-116.png
WebHost-Manager---ip-184-168-116.png
Screenshot-2014-02-17-09.32.15-v.png
0
 

Accepted Solution

by:
Victor Kimura earned 0 total points
ID: 39869404
It's figured out. Praise the Lord!

I called the VPS tech and he tried and changed the setting from Dovecot to Courier and then it worked! =)
0
 

Author Closing Comment

by:Victor Kimura
ID: 39880403
Changing from Dovecot to Courier in WHM solved it. =)
0
 
LVL 35

Expert Comment

by:gr8gonzo
ID: 40243794
I know this is an old thread, but I just came across it. Since others might also come across it, I wanted to add my two cents here. Changing Dovecot to Courier is not going to solve SMTP issues. Those two programs have nothing to do with SMTP at all.

Changing Dovecot to Courier is like changing the person that sits behind the desk at the post office. They may have a different personality, but it doesn't change the delivery of inbound or outbound messages. It just changes who you're talking to when you want to get your mail. Courier and Dovecot both simply provide a way for email clients to retrieve existing messages from a mailbox.

If SMTP started working after that change, my guess is that there was an unrelated change that may have happened at the same time that actually did fix the problem. It's like deciding to get a new car one day and your dinner just happens to taste fantastic that same day. They don't have anything to do with each other - they just happened to be in a similar timeframe.
0
 

Author Comment

by:Victor Kimura
ID: 40245150
Perhaps, then because it's WHM/cPanel then maybe changing it in WHM from Dovecot to Courier changes some additional settings that made the SMTP work. That'll be my guess.

Thanks, gr8gonzo, for that insight.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will explain how to establish a SSH connection to Ubuntu through the firewall and using a different port other then 22. I have set up a Ubuntu virtual machine in Virtualbox and I am running a Windows 7 workstation. From the Ubuntu vi…
You ever wonder how to backup Linux system files just like Windows System Restore?  Well you can use Timeshift in Linux to perform those similar action.  This tutorial will show you how to backup your system files and keep regular intervals. Note…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses
Course of the Month12 days, 23 hours left to enroll

971 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question