Solved

public folders in exchange 2013

Posted on 2014-02-16
18
1,365 Views
Last Modified: 2014-03-06
I just migrated from exchange 2007 to 2013. I never received any emails from exchange saying that my public folders are becoming too large.

Now, with exchange 2013, I keep on getting emails from exchange saying "your public folder is becoming too large"
Then in the email body, this is what it says:

Your public folder "\Media\Aim Reports\Station Summary" is becoming too large. The current size is 57 MB.
Please reduce the size of your public folder by deleting any items you don't need.


Why is this happening?  I never set quotas on public folders....

Any advise how to fix this?
0
Comment
Question by:afacts
18 Comments
 
LVL 11

Assisted Solution

by:Technodweeb
Technodweeb earned 100 total points
ID: 39863813
Try this PowerShell command to turn it off:
Set-PublicFolder -Identity "\My Public Folder" -UseDatabaseQuotaDefaults: $False

Open in new window

0
 
LVL 9

Assisted Solution

by:Marshal Hubs
Marshal Hubs earned 100 total points
ID: 39863833
A solution to your problem is given in this article : http://searchexchange.techtarget.com/tip/Set-storage-limits-for-Exchange-public-folders . Just go through this article and then follow the steps given to resolve your problem.
0
 

Author Comment

by:afacts
ID: 39863922
Marshal hubs, that article is for exchange 2003.  I have 2013.

My total size of public folders is only 2.8 gb.
For the total size.
0
 

Author Comment

by:afacts
ID: 39863937
Technodweeb,

Where it says \my public folders,   Do I just put the name of my root folder of my public folders?   I believe the name is public folders, so I just substitute that in there, and will it work for the root, which should propagate to every other sub public folder, right?
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39864091
"My total size of public folders is only 2.8 gb."

This is probably the reason for the prompt.
Remember that public folder behaviour in Exchange 2013 has changed. They are no longer stored in their own database, but with the mailboxes in a special public folder mailbox.
By default, the mailbox size is 2gb, hence the alert.
You will need to remove the limit on the public folder mailbox to stop the warning message.

Simon.
0
 
LVL 2

Assisted Solution

by:allen_rich
allen_rich earned 100 total points
ID: 39864234
0
 

Author Comment

by:afacts
ID: 39865770
Well, in looking via the ECP at my public folders, it's already set to "unlimited", so why is it still sending out emails that we're low on space?

I've attached the picture.
pfusage.jpg
0
 

Author Comment

by:afacts
ID: 39868272
Technodweeb,

When I ran that command, I get this error message:
"A parameter cannot be found that matches parameter name 'UseDatabaseQuotaDefaults'"

I just copied and pastes your command and only changed the name of my public folders, which is "\Public Folders"

Any thoughts?
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39869966
That is because that is a command for Exchange 2010/2007 public folders. It doesn't apply to Exchange 2013.

Simon.
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 

Author Comment

by:afacts
ID: 39871001
So what do I do for exchagne 2013, as that's what I'm running now?
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39871442
I told you what I suspected it was above - the size of the public folder mailbox.

Simon.
0
 

Author Comment

by:afacts
ID: 39874572
So how exactly do I increase the size of the public folder mailbox.  The ECP is not that good at managing public folders.  2003 was great, everything was done via the gui, there's no all of these commands you have to learn.

I think the total size of the public folders is 2.8GB, but the size is set to 15 GB I believe.
0
 

Author Comment

by:afacts
ID: 39874581
I tried finding what the folder size limits are via the GUI, and I don't see it anywhere. This is so frustrating to have some settings via the ECP and some via the powershell.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39876466
Better get used to the command line - as that is how all Microsoft products are going. Command line first, GUI second. Everything can be done in the command line and it is a lot more efficient way of doing things. I configured a 12 server installation last week in less than 15 minutes using the command line, if I had to use the GUI it would have taken me hours.

The first thing you should do is check the limit of the Mailbox itself.
You can do that with the GUI if you wish - under Public Folders, Public Folder Mailboxes. Double click on the mailbox and then select Mailbox Usage.

The limits for each public folder are on the properties of the folder, under limits.

Simon.
0
 

Author Comment

by:afacts
ID: 39877125
Simon,  Thanks for the reply.

I have attached the picture with my settings.  Everything was already set to "unlimited", but the mailbox still shows that I'm using 1.6Gb of 2GB, I don't understand that, because if it's set to unlimited, what doesn't it understand of unlimited?

I guess I'm not sure where else there might be settings that I need to change?

I agree with you that powershell is very powerful and that you can probably do things much faster, but I guess I'm just to busy to learn a new language, I'm the only admin managing my entire organization and up til now, I guess I've been telling myself I don't have time to learn a new language, but perhaps somewhere, I should carve time and learn it.
My next question is, how would you recommend that someone that knows almost NOTHING about powershell learn it?  What's the easiest way for me to learn it? Do I just buy a book and read through the book, are there any very good websites that I can learn it?

I still have 3 major problems from this migration and I guess that's what still frustrating me with this exchange 2013, as I had very few issues when I upgraded to ex 2007.

Not sure if you know the following as well, or if I should make a new post:
1. All my remote users, whether win xp or win 7, it just continuously prompts them for their user/pass.  I have verified that they are entering the correct information and that their accounts are not locked, as they can access the web outlook app.  With one user, I even uninstalled office, and installed office 2013 from scratch, and it's still prompting him, internally, I actually had this user bring in their laptop, and on my LAN, and it's still doing this.

2. Internally, I have some users, win 7, outlook 2010, with all the required updates, where email will not send, just stays in outbox.  I deleted the .ost file, and that solved it for a few hours, or a day, but the problem comes right back.  I'm lost as how to solve this issue as well.

Thanks,
Dan
PF.JPG
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 200 total points
ID: 39879607
Username/password prompts are very common. If you search this site and others for that problem you will easily find the most common solutions. Usually it is an SSL certificate issue - nothing to do with the username/password, as Outlook cannot cope with the SSL prompts if there is an SSL issue.

For the other problem about messages staying in the outbox, I would suggest a new question.

As for the public folder size, that may well be a bug. SP1 is due shortly, so you should probably deploy that. Another option would be to set a specific limit rather than unlimited. That will have to be done via the shell, perhaps set it to 4gb.

Simon.
0
 

Author Comment

by:afacts
ID: 39893085
Can anyone modify the above command to also include what the total storage limit is?
The code that Technodweeb attached above.

That would really help me  a lot, because then I would know which accounts are affected.
0
 

Author Closing Comment

by:afacts
ID: 39910263
thanks guys for your help, I called a friend and helped me get it going.
0

Featured Post

Are your corporate email signatures appalling?

Is it scary how unprofessional your email signatures look? Do users create their own terrible designs and give themselves stupid job titles? You can make this a lot easier for yourself by choosing an email signature management solution from Exclaimer today.

Join & Write a Comment

Resolve DNS query failed errors for Exchange
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
This video discusses moving either the default database or any database to a new volume.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now