Solved

Backup Exec 2012 & Robotic Library

Posted on 2014-02-16
4
2,479 Views
Last Modified: 2014-09-08
I had a HP StorageWorks 1/8 G2 LTO-4 Ultrium 1760 SCSI Autoloader hooked up to a server using Backup Exec 12d and it was working fine. I had a drive fail and happened to have another server Proliant 360 G6 that I thought it would serve me a couple more years.

So I obtained a Sc11Xe SCSI Host Bus Adapter and installed it into the server running win2008 r2.

That's where my grief starts.

I can see within device manager that the SCSI card is installed. However it appears numerous times. It appears as HP LTO Ultrium 4-drive and HP Ultrium 4 SCSI
All of this instances have a different Target ID

IE: Location 2 (Bus Number 0, Target Id 7, LUN 0)

As documented by Symantec I changed the drivers to theirs and loaded the "unknown" medium changer

I also see many unknown medium changer references. None of these are referencing the drive LUN4.

IE Location 2 (Bus Number 0, Target Id 9, LUN 1)

******
Vendor ID  HP  
Product ID  Ultrium 4-SCSI  
Firmware Revision  W55W  

SCSI Element Address  1  
Autoloader LUN Hosted By Drive  Yes  
Data Compression  Yes  
Interface Type  SCSI  SCSI ID  4  
Physical Drive Slot Number  1  

******
Within BE2012 I can see

Robotic library 0001
Tape Drive 0001 (no media )
Tape Drive 0001 (no media )
(TWICE)
SLOTS

UNDER SLOTS
I can see 7 tapes with barcodes all saying 0 bytes.


**
If I run a backup to Robotic library 0001 it just runs without ending

I can create partitions and then run a job to anyone of them and it runs without ending *queued*

All are associated with a media set that is over writable and apendable

........
I'm not sure what the tape Drive SCSI ID (LUN) (4) should reflect. I presumed the medium changer would reflect that ID but it doesn't.

Seems there is an issue with the tapes loading to the drive automatically
0
Comment
Question by:unitedvoice
  • 2
  • 2
4 Comments
 
LVL 20

Expert Comment

by:SelfGovern
ID: 39864758
The 1/8 G2 is the 1U high library, single half-height tape drive, correct?

Sometimes Windows does get confused.  I'd uninstall the medium changer and any tape drives in Windows Device Manager (mangler?) and then "scan for new hardware".  Perhaps there was something left over from a previous install or connect.

Then --
- Have you done an inventory on the library?
- Have you catalogued the tapes in the library?

You may know that you brought the library over and didn't change any tapes, but BE doesn't know what's in there until you give it a chance to ID them -- and that's what the two steps above do.

If you've brought over your BE catalogue from the prior install, you probably just have to inventory the library.  If you've done a new install of BE, you'll have to import or catalogue every tape to know what's on it -- and be aware that this applies to tapes outside the library as well.  (Implication: if you don't import the tapes first, add the time to do a catalogue to your recovery time.  Realize that BE won't be able to tell you which tape to get until the tape has been catalogued, so you might have to dig through your whole store of tapes to find the right one... and this is unlikely to make people happy when you're trying to get a critical server back up and running!)

If you have done the two bulleted steps above, what messages are showing in the BE log?  It will probably tell you that it's waiting on some resource, or give us another clue about what's going on (or not).
0
 

Author Comment

by:unitedvoice
ID: 39866134
I made these changes

Vendor ID  HP  
Product ID  Ultrium 4-SCSI  
Firmware Revision  W55W  
SCSI ID  0  
Physical Drive Slot Number  1  
SCSI Element Address  1  
Autoloader LUN Hosted By Drive  Yes  
Data Compression  Yes  
Interface Type  SCSI  

Which I actually did previously but it didn't work.

Now I see one tape drive device and an unknown media changer

I can also get the tapes to the drive now which I couldn't before so an inventory was impossible. I'm running an inventory now

If I reboot the machine I get this error

LSI_SCSI The driver detected a controller error on \Device\RaidPort1.

The only error I get is a red pulsating icon and if I hover over it - reads - The query for adapter6 failed
0
 
LVL 20

Accepted Solution

by:
SelfGovern earned 500 total points
ID: 39866557
The raidport error is interesting; to the best of my knowledge, the SC11XE  does not support RAID.

There are known problems with Storport drivers built in to many versions of Windows; visit the product page )http://h20566.www2.hp.com/portal/site/hpsc/public/psi/home/?cc=us&exit=product_series_oid&jumpid=reg_r1002_usen_s-001_title_r0002&lang=en&sp4ts.oid=3191201&ac.admitted=1392701559847.876444892.199480143) to make sure you have the latest firmware, then go to Microsoft to view http://support.microsoft.com/kb/932755/en-us and download and install the fix if your OS is listed.

I'd then suggest downloading HP's free Library & Tape Tools (http://h18013.www1.hp.com/products/storageworks/ltt/index.html?jumpid=reg_r1002_usen_c-001_title_r0003)  which will allow you to verify connectivity and run diagnostics on the tape drive, including making sure it has the latest firmware.
0
 

Author Comment

by:unitedvoice
ID: 39866641
The SCSI card was provided by a HP partner with information about all the various components. I would imagine they have given me a card that works.

I did go to that site but there's a couple of issues. One is when you try and open the exe it's for a 32 bit machine and also they want you to create a floppy WHAT!

Any ideas?

I also downloaded the tape tools and everything shows up fine and functioning.

I will grab that MS patch and give it a go.

Just for the fun or it I tried swapping and changing the drivers..

***********************************************************************

Tried to inventory nothing appears to happen for over 20 minutes

Uninstalled Symantec drivers rebooted

ERROR
ADAMM configuration warning.
The device driver may not be installed for device :
Identifier : HP Ultrium 4-SCSI  W55W (although driver listed in devices)

Backup Exec rediscovered devices

Library offline
Drive Offline
(put online)

Tried to erase a tape 0007
ERROR
Erase Library 00008 -- The job failed with the following error: Physical Volume Library Drive or Robot paused, offline, or disabled.
HP StorageWorks 1/8 G2 LTO-4 Ultrium 1760 SCSI Autoloader
HP Proliant 360 G6
SC11Xe
Backup Exec 2012


*******************************************************************
Changed to "unknown media changer" as suggested by Symantec
Rebooted
Library online
Tape drive online and listed as active
WEB GUI from HP autoloader states ready and no tapes in drive
Tried to erase a tape
Nothing

Tried to initialize
Initialize Library 00005 -- The job failed with the following error: A device attached to the system is not functioning.

ERROR

The following event was reported on 2/18/2014 11:47:05 AM:

The driver detected a controller error on \Device\RaidPort1.

*******************************************************************

Install Symantec drivers
Removing the IDR CD-ROM burner driver (drvmcdb.sys) association for tape drives.
Updating Symantec inf file
Installing Symantec "halfinch.sys" for "SCSI\SequentialHP______Ultrium_4-SCSI__W55W"
Installation complete.

REBOOT

=====
Can see a tape in drive and has a capacity of 781MB Full, Gen. 4  GQZ012L4 Slot 6

Import Library 00012 -- The job failed with the following error: Library error - a problem, possibly hardware related, has been detected. Cause may be user, device, or system error.  Manual intervention may be required.

The following event was reported on 2/18/2014 12:11:58 PM:

The driver detected a controller error on \Device\RaidPort1.

*******

UNINSTALLED Symantec Drivers
REBOOT

Tape 0006 wont move from drive
Manual move autoloader from web gui
Backup exec still registers media in drive

**************************************************************

Seems to throw up less errors without the Symantec drivers and with the media changer as unknown.
0

Featured Post

Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

Join & Write a Comment

VM backup deduplication is a method of reducing the amount of storage space needed to save VM backups. In most organizations, VMs contain many duplicate copies of data, such as VMs deployed from the same template, VMs with the same OS, or VMs that h…
The article will include the best Data Recovery Tools along with their Features, Capabilities, and their Download Links. Hope you’ll enjoy it and will choose the one as required by you.
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now