How do I direct my computer to make all http / DNS requests to the WAN

Windows 8.1 Home network

I Have 2 LAN Cards on my main computer. One for LAN and One for WAN (Internet). I have it so my other home PCs can RDP to my main computer.

How do I direct my computer to make all http / DNS requests to the WAN instead of the LAN. It seems to take a long time to access the internet and I perceive that this may be the problem.
ambantinAsked:
Who is Participating?
 
ambantinConnect With a Mentor Author Commented:
Figured it out!!! My LAN Router was serving DNS and Gateway addresses in DHCP. I eliminated them and all is well!!!
0
 
Giovanni HewardConnect With a Mentor Commented:
This all has to do with your routing table, specifically your default route/gateway.

Modify your IPv4 settings to reflect the WAN gateway as your default gateway.

Alternatively, you can modify your routing table directly, using the route command from an elevated privileged command prompt.

route delete 0.0.0.0
route -p add 0.0.0.0/32 10.0.0.1

Open in new window


Where 10.0.0.1 is your WAN gateway.  You'll also want to ensure you're using a fast DNS server, as resolution delays will bottleneck the entire process.

208.67.222.222
208.67.220.220


Try running namebench to determine the fastest publicly accessible DNS servers from your geo location.
0
 
Robert Sutton JrConnect With a Mentor Senior Network ManagerCommented:
In addition to whats been stated above, you may also want to view your DNS settings on the SOHO router to ensure that the DNS ip's are hard-coded in there for faster resolution. If not using a SOHO router, ensure that its hard-coded into the "WAN" NIC on your pc.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
gurutcConnect With a Mentor Commented:
You'll want netbios enabled on your LAN so that DNS isn't needed on that.  Then just use the public DNS servers hard coded for all adapters.

- gurutc
0
 
ambantinAuthor Commented:
ok... sorry for the delays.. weather and meetings have been my enemy.. I need a step-by-step here... Something your mom would be able to understand...lol

My "workstations" are connected to a router (LAN network) that is connected to my main computer. The router is connected to my "LAN" NIC (192.168.3.102) which gets its address dynamically from the same router... (If you have  better way let me know)...

My "WAN" NIC (192.168.2.100) is connected to a router (WAN Network) which serves wireless and is connected to my modem.

Here is something that is weird and made me think it was an issue between the NICs. When i try to access the internet from any of the routers, it is very slow and never quite completes the page. However, as soon as I disable the LAN NIC the main computer the wireless connections work flawlessly. As soon as I enable the LAN NIC it has issues...

@x66_x72_x65_x65 knowing my IPs, could you wite me another script to enter into my elevated CMD window...

Also know that I am using DynDNS on my WAN router... (192.168.2.1)
0
 
ambantinAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for ambantin's comment #a39903513

for the following reason:

Figured it out!!
0
 
gurutcCommented:
So you weren't helped at all?  OK
0
 
ambantinAuthor Commented:
I would like to reopen this question to give points to others for their contributions
0
 
ambantinAuthor Commented:
I would like to reopen this question to give points to others for their contributions
0
 
ambantinAuthor Commented:
Figured it out!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.