Solved

Only homepage appears - the rest are 404 not found

Posted on 2014-02-17
4
264 Views
Last Modified: 2014-02-22
We just established a new Apache web server account, and they provided us with the FTP info and TEMPORARY web address (since our current site is still on another web host - the eventual address will just be http://www.skynursery.com). We installed the latest WordPress on it.

The temporary address is http://s1069063.instanturl.net/skynursery.com/ and if you click it, it takes you to the new site's (work in progress) homepage.

So far so good. The problem: any attempt to view an internal page (such as http://s1069063.instanturl.net/skynursery.com/products/) results in a page not found.

We've built many wordpress blog themes and installed them on many web hosts, but this is the first time something like this has been encountered. I think it may have to do with the temporary address? (although we've set up many on temporary addresses before, but this is the first temporary address with a subfolder in its name).

Here is the .htaccess file:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /skynursery.com/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /skynursery.com/index.php [L]
</IfModule>
# END WordPress

Open in new window


Our permalinks settings are set to use the Post Name option:
http://s1069063.instanturl.net/skynursery.com/sample-post/

 Has anyone else run into this? Any ideas on what we can do/try?

thanks experts!
0
Comment
Question by:rascal
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 

Expert Comment

by:SmartRxCloud
ID: 39865684
Please check site name in wp-config.php
0
 
LVL 1

Author Comment

by:rascal
ID: 39865702
>>Please check site name in wp-config.php
I don't understand - there is no site name in wp-config.php. That file only contains a few define statements such as DB_CHARSET, etc. There is no site name setting in that file.
0
 
LVL 1

Accepted Solution

by:
rascal earned 0 total points
ID: 39865719
I found the solution - the web host requires that we manually re-sync the site's htaccess file by logging into the Control Panel for the account and clicking a link to resync the .htaccess file.  Once we did that, the links worked fine.
0
 
LVL 1

Author Closing Comment

by:rascal
ID: 39879021
I found the solution.
0

Featured Post

Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Build an array called $myWeek which will hold the array elements Today, Yesterday and then builds up the rest of the week by the name of the day going back 1 week.   (CODE) (CODE) Then you just need to pass your date to the function. If i…
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
The purpose of this video is to demonstrate how to set up basic WordPress SEO. This will be demonstrated using a Windows 8 PC. The plugin used will be WordPress SEO by Yoast. Go to your WordPress login page. This will look like the following: myw…
The viewer will learn how to count occurrences of each item in an array.

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question