Solved

setting up IIS 6 for port 81 (Server 2003)

Posted on 2014-02-17
4
504 Views
Last Modified: 2014-02-23
I am moving IIS to port 81 and setting up Apache 2.4 on our server to handle our main site while IIS will handle the apps. No issues with Apache because it is NOT installed yet, this is purely a Windows issue. I have configured IIS Manager site properties to listen to 81 only.  I have even tried setting IIS via "httpcfg set iplisten -i" - and that was successful because "httpcfg query iplisten" yields this:

C:\>httpcfg query iplisten
    IP                      : 192.XXX.XXX.6:81
-----------------------------------------------
    IP                      : 192.XXX.XXX.2:81
-----------------------------------------------

but "netstat -aon" yields this:

Proto  Local Address          Foreign Address        State           PID
TCP    192.XXX.XXX.6:80       0.0.0.0:0              LISTENING       4
TCP    192.XXX.XXX.6:81       0.0.0.0:0              LISTENING       4
TCP    192.XXX.XXX.2:80       0.0.0.0:0              LISTENING       4
TCP    192.XXX.XXX.2:81       0.0.0.0:0              LISTENING       4

any ideas for figuring out AND stopping/moving the process staying on port 80? PID 4 is "SYSTEM" by the way.

Thanks!
0
Comment
Question by:kbdaemon
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 29

Expert Comment

by:becraig
ID: 39866346
Open your IIS >
right click on web site in question
Properties
Web Site Tab
Advanced..
Change  the host binding  here, or simply delete the site if you do not plan to use it.
0
 

Author Comment

by:kbdaemon
ID: 39867427
Thanks, but as I mentioned above that has already been done. Are there any other processes listening on TCP port 80 by default?
0
 

Accepted Solution

by:
kbdaemon earned 0 total points
ID: 39867812
SQL Reporting services listens on port 80 but does not identify itself as such. Just figured that out. If anybody else has this issue make sure you click on the advanced tab under SQL reporting manager to make sure you have switched the port <>80.
0
 

Author Closing Comment

by:kbdaemon
ID: 39880408
I hope anyone else struggling with IIS port reassignment on Windows Server who also have SQL running will benefit from my frustration on this. SQL, despite being a separate piece of software, will NOT identify itself on the port usage command ("netstat") so if you have IIS configured correctly but still see a problem then check out your SQL settings.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

What is an ISAPI filter?   •      It's an assembly (.dll file) that can add or change the way IIS works.   •      They can be enabled globally for your web server or on a site-by-site basis.   When the IIS server receives a request, enabling the ISAPI fi…
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…
Suggested Courses

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question