Solved

Windows Update Error 80072EFD

Posted on 2014-02-17
11
1,579 Views
Last Modified: 2014-08-30
I have a Windows 2008 Standard server that is only used as a terminal server.  Also, one of the users is running Windows 7 SP1. Both report the same error when trying to process Windows Updates. “An error occurred while checking for new updates for your computer”. Errors found, code 80072EFD. Updates are not being processed at all.

I have researched this error to no avail. I would like to focus on the server.  I have tried a multitude of fixes that I found from many websites, mainly Microsoft KB sites, but nothing has worked. Not to confuse the issue, but the SBS server had a similar error code, and it was solved by many weird registry entries and an update to the Windows Installer software. Honestly, I am not sure what fix worked, but the same fixes did not work on this server. The problem started on 11/11/2013 after processing Windows updates. I have not researched the “Security” updates applied, but it cannot be a coincident.

Any help would be greatly appreciated.
Here is a snipet for the WindowUpdateLog.log

2014-02-14      19:19:40:498      1448      137c      AU      #############
2014-02-14      19:19:40:498      1448      137c      AU      ## START ##  AU: Search for updates
2014-02-14      19:19:40:498      1448      137c      AU      #########
2014-02-14      19:19:40:498      1448      137c      AU      <<## SUBMITTED ## AU: Search for updates [CallId = {4EA12D2D-C244-41EC-9446-60CDA81FC40D}]
2014-02-14      19:19:40:498      1448      3ad4      Agent      *************
2014-02-14      19:19:40:498      1448      3ad4      Agent      ** START **  Agent: Finding updates [CallerId = AutomaticUpdates]
2014-02-14      19:19:40:498      1448      3ad4      Agent      *********
2014-02-14      19:19:40:498      1448      3ad4      Agent        * Online = Yes; Ignore download priority = No
2014-02-14      19:19:40:498      1448      3ad4      Agent        * Criteria = "IsInstalled=0 and DeploymentAction='Installation' or IsPresent=1 and DeploymentAction='Uninstallation' or IsInstalled=1 and DeploymentAction='Installation' and RebootRequired=1 or IsInstalled=0 and DeploymentAction='Uninstallation' and RebootRequired=1"
2014-02-14      19:19:40:498      1448      3ad4      Agent        * ServiceID = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7} Managed
2014-02-14      19:19:40:498      1448      3ad4      Agent        * Search Scope = {Machine}
2014-02-14      19:19:40:514      1448      3ad4      Setup      Checking for agent SelfUpdate
2014-02-14      19:19:40:514      1448      3ad4      Setup      Client version: Core: 7.4.7600.226  Aux: 7.4.7600.226
2014-02-14      19:19:40:514      1448      3ad4      Misc      Validating signature for C:\Windows\SoftwareDistribution\SelfUpdate\wuident.cab:
2014-02-14      19:19:40:514      1448      3ad4      Misc       Microsoft signed: Yes
2014-02-14      19:19:43:837      1448      3ad4      Misc      WARNING: Send failed with hr = 80072efd.
2014-02-14      19:19:43:837      1448      3ad4      Misc      WARNING: SendRequest failed with hr = 80072efd. Proxy List used: <(null)> Bypass List used : <(null)> Auth Schemes used : <>
2014-02-14      19:19:43:837      1448      3ad4      Misc      WARNING: WinHttp: SendRequestUsingProxy failed for <http://LSCSVR:8530/selfupdate/wuident.cab>. error 0x80072efd
2014-02-14      19:19:43:837      1448      3ad4      Misc      WARNING: WinHttp: SendRequestToServerForFileInformation MakeRequest failed. error 0x80072efd
2014-02-14      19:19:43:837      1448      3ad4      Misc      WARNING: WinHttp: SendRequestToServerForFileInformation failed with 0x80072efd
2014-02-14      19:19:43:837      1448      3ad4      Misc      WARNING: WinHttp: ShouldFileBeDownloaded failed with 0x80072efd
2014-02-14      19:19:47:144      1448      3ad4      Misc      WARNING: Send failed with hr = 80072efd.
2014-02-14      19:19:47:144      1448      3ad4      Misc      WARNING: SendRequest failed with hr = 80072efd. Proxy List used: <(null)> Bypass List used : <(null)> Auth Schemes used : <>
0
Comment
Question by:THEarle
  • 4
  • 2
  • 2
  • +3
11 Comments
 

Author Comment

by:THEarle
ID: 39866661
Windows Update Error 80072EFD
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 39866706
So, your SBS is running WSUS and that is where this machine is trying to get its updates from.

Open Internet Explorer on that machine and see if you can go to:
http://LSCSVR:8530/SimpleAuthWebService/SimpleAuth.asmx

If you cannot, then you have a problem with your WSUS configuration on the SBS and you need to look at the WSUS Console in the SBS to resolve it.

If you prefer to NOT use WSUS to get the updates to this server you need to disable the Group Policy on the SBS which enforces WSUS.  Then you can access Windows Update manually.

Jeff
0
 
LVL 16

Expert Comment

by:Dirk Mare
ID: 39866752
Have you tried using the WSUS diagnostics tool?

Can you look for updates from the internet?

DirkMare
0
 
LVL 19

Expert Comment

by:*** Hopeleonie ***
ID: 39867529
I would try my troubleshooting steps:

Step 1. Run System Update Readiness Tool
http://windows.microsoft.com/en-us/windows7/what-is-the-system-update-readiness-tool

Step 2. Start in Clean Boot.
http://support.microsoft.com/kb/929135

Will you get the same error?

Step 3. Test with different users.
Step 4. Disable Windows Firewall.
Step 5. Check GPO settings.

Step 6. Backup and rename the following folders:
==============
1. c:\Windows\System32\Software Distribution
2. c:\Windwos\System32\Catroot2


Step 7. Check related services
==============
1. Open services.msc.
2. Make sure the following services have been started and configured to Automatic.

3. Stop and start service:
Background Intelligent Transfer Service
Windows Update
Cryptographic service
0
 
LVL 47

Expert Comment

by:Donald Stewart
ID: 39868330
Check both your windows firewall and antivirus firewall settings
0
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

 
LVL 16

Expert Comment

by:Dirk Mare
ID: 39872658
Download and run the WSUS daignostics tool from
http://www.microsoft.com/en-za/download/details.aspx?id=30827

DirkMare
0
 

Author Comment

by:THEarle
ID: 39877629
Thank you for your suggestions. This server is a terminal server that must stay available 24 hours a day. I have made arrangements to have full access to the server this weekend. I will try to fix this and post to this question as I get results.
0
 

Author Comment

by:THEarle
ID: 39933585
Thank you for your patience. I got access to the server today and performed several of your suggestions. Our firewall is run on our router, a Linksys WRT54G2 with a fairly standard setup and Windows firewall is disabled on the terminal server.  Our Antivirus is Trend Micro version 8 with no firewall functions enabled.  WSUS was not installed as a role in this domain.

I found and installed the February 2014 update readiness tool KB947821, renamed Catroot2 and Software Distribution folder and restarted the server.  When I go for updates I get the same error 80072EFD. All of the logs I have examined all basically say the same thing, cannot connect to server.  The issues are it being able to contact an update server, either Windows or WSUS.

Next I ran all of the suggestions in KB2509997 and KB958056, all of which did not work and Windows Update report error 80072EFD. Since I suspected the problem was created on a Windows security update from 11/18/13, I uninstalled all updates that applied that day and rebooted again.  Got the same error.

After more research, I went to the registry keys under HLM\Software\Policies\Windows\WindowsUpdate and \AU:
Changed UseWUserver from 1 to 0. Ran Windows update and got error 80070057.  It then wanted to install KB947821 again. The system readiness tool ran but failed to correct error 80070057. After a clean boot  applied the readiness tool and completed ok. Now when I search for updates, the window perpetually looks for updates and never concludes.

That is where I am now.
0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 500 total points
ID: 39933660
If WSUS is not installed on the domain, then you need to disable the WSUS Group Policy Objects on your SBS 2008 which are affecting the Terminal Server.

There should be three policies configured in the Group Policy Management Console:

Update Services Client Computers Policy
Update Services Common Settings Policy
Update Services Server Computers Policy

You can disable all three of these if WSUS is NOT installed on your SBS 2008.

After disabling these.  Run the following command on both your SBS and your Terminal Server using an elevated CMD prompt:

GPUPDATE /FORCE

Jeff
0
 
LVL 13

Expert Comment

by:Santosh Gupta
ID: 39961295
please share windowsupdate.log file under C:\windows folder
0
 

Author Comment

by:THEarle
ID: 40294603
The problem was solved by scrapping all of the group policies relating to updates and having them rebuilt.  Once done the update server was found and began downloading.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I had a question today where the user wanted to know how to delete an SSL Certificate, so I thought that I would quickly add this How to! Article for your reference. WHY WOULD YOU WANT TO DELETE A CERTIFICATE? 1. If an incorrect certificate was …
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now