Exchange mail delivery issue

I have a strange error within Exchange...

Users cannot send to a number of different domains (that we've been able to send to for years) and the messages are just sitting in the queue on Exchange

The "last error" text shows
451 4.4.0 Primary target IP address responded with "421 please try later" attempted failover.....

I have checked our domain against blacklists and come up with nothing, though several have reported that our

Forward DNS does not match Reverse DNS - is this a problem?

I have also tried to telnet into the problem domains on port 25 and the connection gets immediately dropped with error "421 please try later"

I'm supposed to be on holiday tonight, any help gratefully received !!
dangermouse1977Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Simon Butler (Sembee)Connect With a Mentor ConsultantCommented:
Don't waste your time changing the Receive Connector banner. It is a change to satisfy a very stupid test, it will have NOTHING to do with your email flow.

http://blog.sembee.co.uk/post/Exchange-200720102013-Outbound-SMTP-Banner-Testing.aspx

Leave the connector as per the default, it will be fine.

The error message you are getting is usually caused by greylisting. Do all of the domains that you are using show the identical error? If so, that would be unusual unless they are all on the same host.

Exchange 2010 should cope with greylisting fine, with the messages going out shortly afterwards. However I have seen problems caused by third party tools stopping this from happening.

Simon.
0
 
MAS (MVE)Technical Department HeadCommented:
Please mention the version of exchange
0
 
dangermouse1977Author Commented:
Sorry, running Exchange server 2010
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
dangermouse1977Author Commented:
I've run the test connectivity tool within exchange and it's passed everything except

Error performing sender ID validation

That error seems to be something called "parsing the SPF record"
SPF record evaluation resulted in sender ID failure, the SPF record could not be parsed.

Checking the SPF record with an online tool, it seems to refer to the old mx record IP address from before we transferred our e-mail to our in house exchange server
0
 
MAS (MVE)Technical Department HeadCommented:
Please make sure your MX records are correct using the URLs below

https://testconnectivity.microsoft.com/
http://www.mxtoolbox.com
0
 
dangermouse1977Author Commented:
OK, the first one reports a sender ID validation failure due to SPF record mismatch -

the second seems to have a number of issues but i'm not quite sure whether they are relevent.... the domain concerned is adc-international.com if you want to check for yourself, you can use o.error@adc-international.com for the e-mail address
0
 
MAS (MVE)Technical Department HeadCommented:
On the "Default receive" connector please specify your external FQDN to avoid this warning.

Warning - Reverse DNS does not match SMTP Banner

check this
http://community.mxtoolbox.com/blog/what-does-the-warning-reverse-dns-does-not-match-smtp-banner-mean-smtp-diagnostic-tool/
0
 
dangermouse1977Author Commented:
OK,

Please forgive me for asking stupid questions but I see a potential for this to go very wrong if I make the wrong change...

So, I have opened Exchange System Manager and navigated to

server configuration / hub transport

Under "receive connectors" at the lower half of the middle of the screen I have 3 entries...
client <servername> default <servername> and "local network"

If I right click and select properties, I see an option on the "general" tab that says "specify an FQDN this connector will provide.... etc etc

on the "client <servername> tab this is set to "mail.adc-international.com" but on the default <servername> and "local network" tabs this is set to the internal network address of our mail server <servername.adc-int.com>

Should I change these 2 entries to "mail.adc-international.com" or am I barking up the wrong tree completely!
0
 
dangermouse1977Author Commented:
I think this must have been the issue as I changed nothing and within 24hrs mail flow was back to normal.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.