Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1342
  • Last Modified:

Exchange 2010 - Setting quota for personal archive

Hi,
I'm trying to enable a quota for few users archives but have some issues with this.
First run:
set-mailbox "john.doe" -enable archive
set-mailbox -Archive Quota 5GB -ArchiveWarningQuota 4GB

No errors here, but when I open outlook and stand on the archive folder, I can see that the limit is 50GB.

Running:
get-mailbox "john.doe" |fl *archive* returns correct parameters:
ArchiveQuota: 5GB
ArchiveWarningQuota: 4GB

Any suggestion why the limits are not being enforced?
0
webox_suuport
Asked:
webox_suuport
2 Solutions
 
Jeff PerryWindows AdministratorCommented:
It may need to have the service restarted.

Edit:

Yes the information store has to be restarted if you want the quota's reflected immediately, otherwise they are enforced once the cache is refreshed.

The default on refreshing the cache is 2 hours.
0
 
comfortjeaniusCommented:
Should the commands look as follows

Enable-Mailbox "John Doe" - Archive

Open in new window


then
Set-Mailbox "John Doe" -ArchiveQuota 5GB -ArchiveWarningQuota 4GB

Open in new window


to quota for all mailboxes in a store
Get-Mailbox -Database | Set-Mailbox -ArchiveQuota 5GB -ArchiveWarningQuota 4GB

Open in new window

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now