SBS2008 DHCP not updating DNS

I have a Linux host in my SBS2008 domain that get its DHCP address from the SBS2008 server (see underlined entry in DHCP image). However, it does not put the DHCP IP into the DNS list so other hosts cannot get to it (see DNS image). I know I can put a static IP into the DNS list for this host, but I'd rather use DHCP. For DHCP > IPv4 Properties > DNS, I have "Enable DNS dynamic updates according to the settings below:", "Always dynamically update DNS A and PTR records", "Discard A and PTR records when lease is deleted", and "Dynamically update DNS A and PTR records for DHCP clients that do not request updates (for example, clients running Windows NT 4.0)". I also have DHCP > IPv4 Properties > Advanced > Credentials, set with the administrator ID and password.

What do I need to do to get this host into DNS (host 192.168.0.50 is another Linux host showing up in the DHCP leases, but not in the DNS)
DHCP.jpg
DNS.jpg
LVL 1
MarkAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Miguel Angel Perez MuñozCommented:
try configuring DHCP to register hosts on DNS: http://technet.microsoft.com/en-us/library/cc787034(WS.10).aspx
0
MarkAuthor Commented:
Yes, as stated in my initial post, I already have "Always dynamically update DNS A and PTR records" set, but it's not doing it. The DHCP lease obviously does have both the IP and the hostname, so I'm puzzled as to why it is not updating the DNS.
0
Miguel Angel Perez MuñozCommented:
Have you marked force update records? have you provided adequate user with privileges?
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Just
create a DHCP reservation for this machine and it will solve your problem.

Jeff
0
MarkAuthor Commented:
Sorry for the delay ...

Drashiel: > Have you marked force update records? have you provided adequate user with privileges?

Forced update is set, see image. The DNS properties has secure and non-secure set for DNS updates. Not sure where to find the user privileges settings, but I believe those are set to the system administrator. What would user privileges be for anyway? If DHCP is set up update DNS, what would privileges be needed for?

 Jeffrey Kane: > Just create a DHCP reservation for this machine and it will solve your problem.

Yes, this did have the effect of getting the reserved IP into the DNS list! However, it's not exactly what I want. For one thing, I need to set the MAC address to do a DHCP reservation, which means I'll have to remember that if/when I change the network hardware in the DHCP client. Is this just a "bug" in SBS 2008 in that it will only DNS register Windows-only DHCP clients? If so, I guess I'll live with the DHCP reservation solution.
0
MarkAuthor Commented:
Correction: creating the DHCP reservation DOES NOT appear to do the trick. After rebooting the SBS 2008 server (after an update), the DHCP reservation shows in the DHCP manager, but is no longer in the DNS list.

Is this just a "bug" in SBS2008 whereby Microscoft simply doesn't like supporting non-Microsoft systems, or am I doing something fundamentally wrong?
0
MarkAuthor Commented:
OK, I'm going to try this this weekend. I'll have to modify it a bit since I'm using slackware
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
You may have wanted to mention that in the first place:
http://www.slackwiki.com/DHCP_Hostname_Entry_in_DNS
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MarkAuthor Commented:
Sorry for the delay - this question fell off my radar.

Jeffery Kane, that link seems to have done the trick! The short answer is to put the local/client hostname in the /etc/rc.d/rc.inet1.conf as:

DHCP_HOSTNAME[0]="thishost"

Normally I do mention distro and version, but for whatever reason I didn't think this was an issue on the Linux side. The version is question is Slackware distro 13.37.0, kernel 2.6.37.6. Interestingly, I have another host with the most recent version: Slackware distro 14.1, kernel Linux 3.10.17. This one does *not* have the hostname set, but appears to work propertly anyway.

man dhcpcd says, "-h hostname ... If hostname is an empty string then the current system hostname is sent."

Apparently this works correctly for kernel 3.10.17, but not for 2.6.37.6
0
MarkAuthor Commented:
Thanks! This one's been stumping me for a while!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.