Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 929
  • Last Modified:

microsoft exchange 2007 security alert error on outlook open the name on the security certificate is invalid or does not match the name of the site

hello all- in an attempt to upgrade an ssl certificate on one of our exchange servers, it seems something wrong has been done and now we are all receiving the following alert when we open outlook
a Security Alert popup appears with the FQDN of my exchange server and there is a Check mark for the first 2 items (1) the security certificate is from a trusted certifying authority and (2) the security certificate date is valid but a red X for the last item which states "The name on the security certificate is invalid or does not match the name of the site."
Do you want to Proceed?
if i hit yes, i get the same error one more time and can hit yes to get rid of it, but i still get this error every time i open outlook
the following commands were run on the exchange server to "upgrade" the certificate
import-exchangecertificate -path c:\certificate.txt
enable-exchangecertificate -services SMTP (enter thumbprint)
enable-exchangecertificate -services IIS (enter thumbprint)

im sure this overwrote an existing exchange cert and im not sure why this was done this way, but, i wasnt the tech that handled it, i am just trying to clean up the mess!
0
jsctechy
Asked:
jsctechy
  • 2
2 Solutions
 
Suliman Abu KharroubIT Consultant Commented:
On the top of the wraning message that you get in outlook, you will find a neme FQDN. does this name indluded in the cert ?   you can check by open the certificate and check issued to field .

Is it a SAN certificate or Single name?
0
 
jsctechyAuthor Commented:
its a single name
and the FQDN wasnt included in the cert... the cert was for our outlook web access so its our internet facing address
0
 
Suliman Abu KharroubIT Consultant Commented:
Check this out, how to change exchange internal and external virtual directories to match the name in SSL cert:
http://social.technet.microsoft.com/wiki/contents/articles/5163.managing-exchange-2010-externalinternal-url-s-via-powershell.aspx
0
 
Simon Butler (Sembee)ConsultantCommented:
If it is a single name certificate then you need to setup a split dns solution, so the external name resolves internally http://semb.ee/splitdns and then configure Exchange to use the single host name. http://semb.ee/e2007singlessl

That will resolve the issue for both internal and external traffic.

Simon.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now