• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 250
  • Last Modified:

PHP issue ( need ASAP Please)

we had a project running very well in the testing server, once we move to the production server it says 500 internal server error.

site details:
php 5.5
codeignter
iis 7.5

there is no errors in php error log
in the iis we got this

2014-02-18 16:34:39 10.0.20.10 POST /McIntosh/Authentication - 80 - 54.209.40.209 Mozilla/5.0+(compatible;+MSIE+10.0;+Windows+NT+6.1;+WOW64;+Trident/6.0) 200 0 0 218

let me know if you need any details
0
romeiovasu
Asked:
romeiovasu
1 Solution
 
GaryCommented:
Make sure you have error reporting enabled in your php pages

error_reporting(E_ALL);
ini_set( 'display_errors','1');


A 500 error could be anything in your code
0
 
romeiovasuAuthor Commented:
I will check it in the ini file and reload the page again.
0
 
artsecCommented:
Please follow instructions here http://mvolo.com/troubleshoot-iis7-errors-like-a-pro/ to enable full error report in ISS to find out where is the problem.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
Loganathan NatarajanLAMP DeveloperCommented:
It might be URL rewriting issue due to Apache mod rewrite module not configured in IIS windows.  more details, http://ellislab.com/forums/viewthread/91954

For this, you could install this, http://www.isapirewrite.com/
0
 
rinfoCommented:
My experience with CodeIgniter is there are a number of factors that causes 500 Internal server error.
Most prominent is bug in php script. Maybe if you are moving from windows to linux server
problem with file name - being case sensitive in linux.
Problem with database - incorrect database credentials, incorrect queries or query failing.
Try running a script page directly without CI convention you will get error for not being allowed but you can be ascertained that there is nothing wrong with configuration and it has
something to do with url redirect.
If i were you i would recheck  configuration files , router and database included.
This is a monster of an error message with no clue.
Best of luck.
0
 
romeiovasuAuthor Commented:
Thanks a lot for your help.
It suddenly worked fine after I enabled the display error in php.ini.
I don't know the actual reason. but it is up and  running now.

Thanks again
0
 
skullnobrainsCommented:
if this is actually what helped, you probably have accidentally solved a credentials problem with that file while editing it.
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now