Lync 2013 Location Database WAP

I have been updating my e911 location database and am having issues getting the WAPs added.  Subnets were completed easily.

Below is the command ran and the error output.  Lync shell is running in administrator mode.


PS C:\Users\xxx> Set-CsLisWirelessAccessPoint

cmdlet Set-CsLisWirelessAccessPoint at command pipeline position 1
Supply values for the following parameters:
BSSID: 00:08:30:EE:EE:EE
Set-CsLisWirelessAccessPoint : BSSID
At line:1 char:1
+ Set-CsLisWirelessAccessPoint
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (:) [Set-CsLisWirelessAccessPo
   int], ArgumentException
    + FullyQualifiedErrorId : BSSID,Microsoft.Rtc.Management.Lis.SetOcsLisWire
   lessAccessPointCmdlet


Also tried:

Set-CsLisWirelessAccessPoint -BSSID 00:08:30:EE:EE:EE

With the same results.

Of course I am trying to add all the location information as well but can create the error with the basic commands.  What am I missing?

Thanks!
trg-sysadminInfrastructure ManagerAsked:
Who is Participating?
 
Mohammed HamadaConnect With a Mentor Senior IT ConsultantCommented:
Can you try to publish your Lync topology and report if there's any errors reported??
If there's any errors in Lync server could you please share it as well. anything that's related to Lync.

in PS try this link and paste the input please here
Enable-CsTopology -Verbose
0
 
Mohammed HamadaSenior IT ConsultantCommented:
When you type  Get-CsLisWirelessAccessPoint what's the output of this command ?

Are you also running the PS as an admin?
0
 
Mohammed HamadaSenior IT ConsultantCommented:
Try also checking whether the DB is storing anything identical to the MAC address that you want to configure.

run this and let's see what's the output

Get-CsLisWirelessAccessPoint | Where-Object {$_.BSSID -eq "00:08:30:EE:EE:EE"}

BTW, try using the entire command and replace the address with yours along with description and the rest and see if that works!

Set-CsLisWirelessAccessPoint -BSSID 00:08:30:EE:EE:EE -City “Southern City” -CompanyName “My Company” -Country US -Description “Wireless AP” -HouseNumber 100 -HouseNumberSuffix “” -Location “My Wireless AP” -PostalCode 99999 -PostDirectional “” -PreDirectional “” -State GA -StreetName “My Street” -StreetSuffix Str.
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
trg-sysadminInfrastructure ManagerAuthor Commented:
Thanks moh10ly,

I am running the the PS as admin.

So I have run Get-CsLisWirelessAccessPoint  and I get no output.   I also ran Get-CsLisWirelessAccessPoint | Export-csv c:\wap.csv and the csv is blank.

When I try to add the wap with the full info I get the same error.

Set-CsLisWirelessAccessPoint : BSSID
At line:1 char:1
+ Set-CsLisWirelessAccessPoint -BSSID 00:08:30:EE:EE:EE -City "Southern City"
-Com ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~
    + CategoryInfo          : InvalidOperation: (:) [Set-CsLisWirelessAccessPo
   int], ArgumentException
    + FullyQualifiedErrorId : BSSID,Microsoft.Rtc.Management.Lis.SetOcsLisWire
   lessAccessPointCmdlet
0
 
Mohammed HamadaSenior IT ConsultantCommented:
When you view the eventviewer, can you check the Lync server's tab and see if there are any errors there?

Please post them here, you might have a problem with your Lync server's database.
0
 
trg-sysadminInfrastructure ManagerAuthor Commented:
No errors related to database that I can find.  No errors following the command failure.

I have no problems adding sites by subnet or manipulating the locations.
0
 
trg-sysadminInfrastructure ManagerAuthor Commented:
I see multiple errors on the Lync Event Viewer:
Storage Service had an EWS Autodiscovery failure.

Enable-CsTopology -Verbose completed without error.  I reviewed the output in AppData\Local\Temp\ and see no sign of error,  Everything comes back 'Success'
0
 
trg-sysadminInfrastructure ManagerAuthor Commented:
Figured it out!  Doesnt like the : in the command string.  turns out you need to enter it as a dash.  

ran get-help Set-CsLisWirelessAccessPoint -examples and saw the example had -

Thanks for helping lead me down a path that helped me find the answer.
0
All Courses

From novice to tech pro — start learning today.