How to configure time on Windows 2008 R2

We have three locations on two of them the time is off by 2 minutes which I understand is really not an issue.  The third is off by 25 minutes.  I went through the setting on our Main office and compared them to the one that is off by 25.  I used kb/816042 and verified the setting were the same.

After I did a while ago, the the servers were very close in time for weeks.  I was informed today that the one site is off by 25 minutes.

From all I've read over the years, a few minutes variance is to be expected.

So my question is what could be causing the one site to be off so much.  And is there a better way to set the time than the KB I used.
J.R. SitmanIT DirectorAsked:
Who is Participating?
 
J.R. SitmanConnect With a Mentor IT DirectorAuthor Commented:
Still need advice on my last post. 39882573
0
 
Mike KlineCommented:
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Are any of these systems virtualized? If so, they could be getting time from the host and the host might not be syncing to an appropriate time source.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
J.R. SitmanIT DirectorAuthor Commented:
Yes this is an Active Directory domain.

Yes the PDC is a Virtual DC.  How do I sync the Host to a good time source?
0
 
Sarang TinguriaSr EngineerCommented:
Thumb rule is PDC should sync to external time source and all other DC's should be in sync with PDC role holer

I have written an article on how to configure this using command prompt (Registry based configuration may confuse administrators)

Refer below article and let me know if you face anymore challenges or have any difficulties

Time Service Configuration
http://www.experts-exchange.com/Software/Server_Software/File_Servers/Active_Directory/A_10789-Time-Service-Configuration.html
0
 
J.R. SitmanIT DirectorAuthor Commented:
@sarang_tinguria when I get to your instruction w32tm /unregister, I get the error "Access is denied , <0x80070005>
0
 
J.R. SitmanIT DirectorAuthor Commented:
@sarang_timguria I was able to continue and use w32tm /register but now I'm stuck at net time /setsntp;.  See attached.  It states /setsntp have been depreciated.  How do I continue?
w32time.png
0
 
J.R. SitmanIT DirectorAuthor Commented:
@Mike Kline, I also tried your 2nd article.  when I get the "status" it states source is "local CMOS clock"

Now I concerned I've messed things up.  How do I make sure I didn't?
0
 
Sarang TinguriaSr EngineerCommented:
For your first comment make sure you are using elevated command prompt even if still gives access denied you skip to next step

for second comment as this is depriciated in 2008 you may ignore it

Make sure you are getting PDC Server hostname as output in w32tm /query /source if you run from Non PDC domain controller and pool.ntp.org if running from PDC role holder
0
 
Sarang TinguriaSr EngineerCommented:
Are these DC's physical or Virtual ..If virtual the Hyper V or VMWare

Time Service issues on Hyper V
http://blogs.msdn.com/b/virtual_pc_guy/archive/2010/11/19/time-synchronization-in-hyper-v.aspx

Time Service issues on VMWare
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1189
0
 
J.R. SitmanIT DirectorAuthor Commented:
It is a VM Hyper-V.  I'm reading the article now.
0
 
J.R. SitmanIT DirectorAuthor Commented:
I read and re-read the article on Hyper-V.  I added an external time source of 69.25.96.13, 216.171.124.36 and 64.147.116.229.  Ans when I run w32tm /resync /force they all fail stating "no time data was available.
When I run w32tm /query /source i get the results of "Source Local CMOS clock" which the article states is "bad"

What do I do now?
0
 
Sarang TinguriaSr EngineerCommented:
have you run below command to add registry on guest system
reg add HKLM\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\VMICTimeProvider /v Enabled /t reg_dword /d 0

Open in new window


If not please do it
0
 
J.R. SitmanIT DirectorAuthor Commented:
yes
0
 
J.R. SitmanIT DirectorAuthor Commented:
The time on the server is holding to the correct time,   However, I'm still getting "Source Local CMOS clock"  from the VM PDC.  From what I've read, this is not correct.  

Still need advice on this.
0
 
J.R. SitmanIT DirectorAuthor Commented:
no solution found.  Please close
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.