Solved

Microsoft Dynamics NAV 2013 with integrated Outlook view shows Enterprise Vaul Addin error at Navision startup

Posted on 2014-02-19
9
295 Views
Last Modified: 2016-06-02
Dear Community

A user customized the start-up page of Microsoft Dynamics Nav 2013 with an embedded Microsoft Outlook view
MS Dynamics 2013 - Main Startup Page
It is a feature of Microsoft Dynamics Nav 2013
MS Dynamics 2013 - Customize This Page
MS Dynamics 2013 - Outlook

Now every time the user is starting Microsoft Dynamics NAV 2013 before starting Outlook the following error shows up

MS Dynamics 2013 - Enterprise Vault Error in Navision 2013
Outlook 2010 does not show the Enterprise Vault ribbon.

If the user starts Outlook 2010 before Navision 2013 the ribbon of Enterprise Vault is available and no error message in Microsoft Dynamics NAV 2013 at start up.

Environment
XenApp 6.5 FP2 on Windows 2008 R2
Microsoft Dynamics Nav 2013 W1 7.00 – 7.0.34797.0
Office 2010 14.0.7106.5003 (32-bit)
Symantec Enterprise Vault Outlook Add-in 10.0.3.1090

Did anyone experienced the same issue?

Best regards
0
Comment
Question by:DangerExperts
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
9 Comments
 
LVL 3

Expert Comment

by:Krishna Patil
ID: 39869885
Which error you are getting in outlook addin logs?
0
 

Author Comment

by:DangerExperts
ID: 39869962
I see the following entry in the event logs:

Event Log entry for Outlook Add-ins
Outlook loaded the following add-in(s):

Name: Enterprise Vault Add-in
Description: Provides features within Outlook for the Enterprise Vault application.
ProgID: EnterpriseVault.DesktopUI
GUID: {6DB3F999-745B-11D5-A688-0008C711C41A}
Load Behavior: 03
HKLM: 1
Location: C:\Program Files (x86)\Enterprise Vault\EVClient\Valkyrie.dll
Boot Time (Milliseconds): 31

No error or warning visible.
0
 
LVL 3

Expert Comment

by:Krishna Patil
ID: 39872662
Thanks, Can I get detailed logs from
Enterprise Vault Outlook Add-In client log files are saved in folder below:

"<Windows Users Profile Root Folder>\<User Name>Local Settings\Temp"
0
Instantly Create Instructional Tutorials

Contextual Guidance at the moment of need helps your employees adopt to new software or processes instantly. Boost knowledge retention and employee engagement step-by-step with one easy solution.

 

Author Comment

by:DangerExperts
ID: 39876208
The following entries are in the Enterprise Vault event log (ev_client_log_20140221105302)

21/02/2014 09:53:02.447[15316][H]: Log file created (level 1).
21/02/2014 09:53:02.447[15316][H]: Unable to perform a MAPI Logon: 0x80040111
21/02/2014 09:53:02.449[15316][H]: Loaded UI Language Path: c:\program files (x86)\enterprise vault\evclient\languages\en
21/02/2014 09:53:02.451[15316][H]: Loaded Help Language Path: c:\program files (x86)\enterprise vault\evclient\languages\en
21/02/2014 09:53:02.453[15316][H]: Module path: C:\Program Files (x86)\Enterprise Vault\EVClient\Valkyrie.dll
21/02/2014 09:53:02.454[15316][H]: No language resource module was loaded, the default English resources in Valkyrie.dll will be used
21/02/2014 09:53:02.456[15316][H]: A std::exception has been caught: Failed to create Desktop object.

Many thanks for your support.
0
 
LVL 12

Expert Comment

by:Daniel Borger
ID: 39876794
Perhaps it's NAv is looking for the outlook add-in to be loaded at start.  you could look into using a batch file to launch outlook and then Nav and publish the bat or com executable.
0
 

Author Comment

by:DangerExperts
ID: 39882732
Thanks for the good idea. I wrote a start-up PowerShell script with an Outlook.exe check. It works fine for the start-up and running with Navision 2013.

BUT as soon a user closes Outlook and Navision 2013 is still running the Enterprise Vault error appears again. Just for information, same behavior in Navision 2013 R2.
0
 
LVL 12

Expert Comment

by:Daniel Borger
ID: 39882742
Perhaps there is a spawned process from outlook that can be ran as part of that script that would not allow the users to see outlook and close it.
0
 

Accepted Solution

by:
DangerExperts earned 0 total points
ID: 39899819
Solution: We told the users to start Outlook first or remove the view in Navision 2013 / Navision 2013 R2.
0

Featured Post

Salesforce Made Easy to Use

On-screen guidance at the moment of need enables you & your employees to focus on the core, you can now boost your adoption rates swiftly and simply with one easy tool.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

What does UTC stand for?  “Coordinated Universal Time” – Think of this as the true time on Planet Earth that never changes with the exception of minor leap seconds here and there to account for the changes in the planet's rotation.   What does th…
In this article I discuss my selections of the Top Four free Outlook OST File Viewers available. Open, view and read even damaged OST files by using these tools. They all provide a clear preview of all data such as emails, notes, tasks, calendars, e…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question