?
Solved

Reset Cisco Embedded AP password

Posted on 2014-02-19
12
Medium Priority
?
1,892 Views
Last Modified: 2014-02-25
Hi,

I have a 800 Series Cisco with wireless capabilities. I can login to the router just fine, but can't login to the embedded wireless AP. I know that before entering the AP you must first login with router credentials again, but I can't get any further from there.

Is there a way to reset the password set on the embedded AP without losing your configuration in the process? I know about the commands that will reset the AP-s configuration(and also the passwords), but I need the configuration to remain intact.

Thanks in advance.
0
Comment
Question by:ht_comp
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
12 Comments
 
LVL 12

Expert Comment

by:Infamus
ID: 39870835
I don't think you will need a password to access wifi feature.

Are you able to get in to enable mode?  (it will say name# after you log in)

Can you post sh run once you are in?
0
 

Author Comment

by:ht_comp
ID: 39872735
I'm able to get to routers enable mode, but if I  use service-module wlan-ap 0 session to get to the AP-s module, I can't get pass the login screen.
0
 
LVL 11

Accepted Solution

by:
marek1712 earned 1000 total points
ID: 39872837
Per CISCO TAC: LINK
There is no password recovery available on emebdded AP only a password reset. this is achieved by resetting Ap to factory default
Router# service-module wlan-ap0 reset default-config
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:ht_comp
ID: 39872852
Hi,

I tested it out earlier and this will reset the configuration the embedded AP, but I need the configuration to remain intact.

I tried resetting the bootloader and got to the AP-s ROMMON. Is there any way I can go on from there, without losing my configuration in the process. I was thinking about trying to export the running configuration to a tftp server from ROMMON, and then resetting the AP. After that If I can get inside the AP-s module, I can import the configuration as might just be able to reset the password. Would that be an option?
0
 
LVL 11

Expert Comment

by:marek1712
ID: 39872938
That works for normal IOS. Dunno about WLAN-AP. I've tried to find information about configuration registers of this module but can't find any.
0
 

Author Comment

by:ht_comp
ID: 39872949
I'm also able to see the inside of the embedded AP-s flash and I was thinking whether I could just change to name of the running configuration, but don't know exactly which file it is and don't know what the concenquences of changing it is.

Flash:

2    -rwx  5         <date>               private-config
3    -rwx  2775      <date>               config.txt
4    drwx  256       <date>               ap801-k9w7-mx.124-21a.JA1
152  -rwx  414       <date>               env_vars
153  drwx  128       <date>               ap801-rcvk9w8-mx
156  -rwx  2775      <date>               cpconfig-ap801.cfg
157  -rwx  2775      <date>               back_up.txt
158  -rwx  1048      <date>               private-multiple-fs
0
 
LVL 11

Expert Comment

by:marek1712
ID: 39872994
One of the .cfg files should contain the configuration. Use MORE command to display its' contents and then use i.e. PuTTY's "Copy to clipboard" function to backup configuration.
Restore the WLAN-AP to the default and then import the script.
0
 

Author Comment

by:ht_comp
ID: 39873046
I used the command "more flash:cpconfig-ap801.cfg" but it seems that this is the default configuration file. I also opened back_up.txt and config.txt but they were all default configurations.

I noticed that the ap801-rcvk9w8-mx is a directory which also contained a 2 files, one of them was ap801-rcvk9w8-mx, but I can't manage to open it - It sends me an error, permission denied. I thought that maybe I'm using a wrong command. How can I use more on a directory which is situated inside of flash directory?

I used the command : more "ap801-rcvk9w8-mx:ap801-rcvk9w8-mx"
0
 
LVL 11

Expert Comment

by:marek1712
ID: 39873067
This file seems to be the system image.
Can you post the output of the following command?
dir all-filesystems

Open in new window

0
 

Author Comment

by:ht_comp
ID: 39873075
The command "dir all-filesystems" gives me an error : unable to stat all-filesystems:/: permission denied.

But if I just use the command dir, I get the following output:

List of filesystems currently registered:

               flash[0]: (read-write)
              xmodem[1]: (read-only)
                null[2]: (read-write)
                tftp[5]: (read-only)
0
 
LVL 11

Expert Comment

by:marek1712
ID: 39873102
It seems only flash: is accessible. But you've listed the contents and valid config isn't there.
I can't think of anything else. If you have valid SmartNET subscription then I think your only way is to contact TAC.
0
 

Author Closing Comment

by:ht_comp
ID: 39885151
Isn't an actual solution.
0

Featured Post

Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses
Course of the Month8 days, 10 hours left to enroll

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question