Solved

OWA through TMG 2010

Posted on 2014-02-19
3
697 Views
Last Modified: 2014-05-19
Hi
I have an Exchange server 2010 behind a TMG 2010, all was working fine OWA, ANYWHERE & ACTIVESYNC until the certificate expired.

I have renewed the certificate, ANYWHERE & ACTIVESYNC  is working fine, I got an issue with OWA when accessing from outside.
Errors:
1. The website is not available
2. 404 error
3. sometimes I got the trust certificate and 404 error

From the TMG I can access OWA on Exchange but not from external.
I even delete the rule & Listener and create a new one, issue persist.

note: I use a  listener for each service.
In the TMG Logs,  I created a filter on HTTPS, but I did not see my request coming in, I see for ActiveSync and others

Note: OWA is configured with FBA and in Exchange 2010 the Service FBA is started.

Thanking you in advanced
Regards
Jeff
0
Comment
Question by:JAY2013
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 16

Expert Comment

by:Dirk Mare
ID: 39872750
New certificate should be in the following places

Exchange Management Console
Exchange IIS; bind the certificate to the https and 443 ports. make sure you don't bind the local IP/443 to the external certificate.

TMG Server you must add it to you listener

In TMG go to your rule that's publishing OWA to the internet. Go to listener TAB Select properties. Select Certificates TAB. Click Select Certificate.  Also please run this rule test and post your findings

Make sure the new certificate is selected.

As best practice reboot both Exchange and TMG server after changing the certificate.

another troubleshooting utility is
https://testconnectivity.microsoft.com/

DirkMare
0
 
LVL 16

Expert Comment

by:Dirk Mare
ID: 39872752
one more thing..

Godaddy has nice interactive step by step guides on how to change your Certificate.

Google should help you here..

DirkMare
0
 
LVL 23

Accepted Solution

by:
Suliman Abu Kharroub earned 500 total points
ID: 39884167
As outlook anywhere and active sync are working fine, but OWA not working, it is mostly an authentication issue.

Check the authentication/delegation tab in publishong rule and authentication tab in listener if they are configured correctlly or not.
0

Featured Post

[Live Webinar] The Cloud Skills Gap

As Cloud technologies come of age, business leaders grapple with the impact it has on their team's skills and the gap associated with the use of a cloud platform.

Join experts from 451 Research and Concerto Cloud Services on July 27th where we will examine fact and fiction.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have been asked to explain on many, many occasions the correct way to setup network cards and DNS settings on ISA Server 2004, 2006 and forefront Threat management gateway (FTMG) and have willing done so. I have also promised my self everytime tha…
Log files are useful in diagnosing and repairing problems.  This is a list of common log files and their standard locations that I've compiled.   While this is not exhaustive, it is a pretty good list that I've found to be useful.  I may update it f…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question