Mail to Exchange Foreign Connector Stopped Working on 1 of 2 CAS servers

We have been running Exchange 2007 servers for a number of years.  Until this week everything has been running correctly.  The only change was one of our CAS/Hub Transport servers was given more RAM and rebooted.  Here is our setup.

1 Mailbox Server
2 CAS/HUB Transport Servers

MB Server = Inside network.
CAS1 = DMZ server handles webmail/iPhones etc.
CAS2 = Inside network, has Foreign Connector for FAX servers.

When someone wants to send a fax, they use an email address @1234567890.fax.  I believe the standard is for the mailbox server sends round robin to the two CAS servers.  What has started happening this week is when a message gets routed to CAS2 from MB the fax works, but if the message goes to CAS1 it tries to send it out the external connector to the Internet, which then fails due to invalid DNS.  

We have reinstalled the foreign connector (FAX software.)  We have spoken with the FAX software vendor and they claim the problem is with Exchange.  We have spoken with Microsoft and they have said we can disable CAS1 from receiving emails inside or install the software on CAS1.  The later would require opening up NETBIOS through our firewall.  Neither is acceptable especially since it has worked flawlessly for years.

I have researched this on the Internet and have found a couple of things.  1 person said that a send connector should be installed on CAS1, I believe Microsoft tried that, but not sure if they did it correctly.  The other person stated that installing in on 1 Hub transport server should allow all the Hub to route messages destine for the Foreign Connector.

What is the correct way it should work and how can I fix it?
RGreen978Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
RGreen978Connect With a Mentor Author Commented:
The solution as strange as it was, was to turn off the CAS1 server for 30 minutes then turn it back on.
0
 
Jamie McKillopIT ManagerCommented:
Hello,

So, you have a Send Connector setup for this fax service? If so, in EMC, go to Organization Configuration / Hub transport / Send Connectors. Open the Properties page for this connector. On the Source Server tab, make sure only CAS2 is listed.

-JJ
0
 
RGreen978Author Commented:
We don't have a send connector setup for this fax service.  It uses a Foreign Connector and a service install on CAS2 to drop the messages into a shared folder.  The FAX server then uses a process to map to the server and grab the messages out of the folder.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
Jamie McKillopIT ManagerCommented:
On the foreign connector, make sure you only have CAS2 listed as a source transport server.

-JJ
0
 
RGreen978Author Commented:
We do.  I was thinking of trying to add a Send Connector from CAS1 to CAS2 for SMTP:*.FAX, though I didn't think it should be needed.  Any thoughts?
0
 
Jamie McKillopIT ManagerCommented:
If CAS2 is the only source transport server listed, it should automatically be going to that server.

-JJ
0
 
RGreen978Author Commented:
Thanks for the suggestions, this is the dilemma, "it should be working."  I understand the connectors are stored in AD, any idea if there could be something screwed up on AD?  FYI, we have uninstalled and reinstalled the foreign connector.
0
 
Jamie McKillopConnect With a Mentor IT ManagerCommented:
It is possible. I would check your AD health, specifically the replication.

-JJ
0
 
RGreen978Author Commented:
While JJ did confirm the correct setup, the solution came from an escalated Microsoft ticket.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.