Solved

Hyper-V Virtual SAN on SuSE multipath

Posted on 2014-02-20
25
629 Views
Last Modified: 2014-11-12
Hello!

does anybody knows a tutorial for setup a Hyper-V (Windows Server 2012 R2) Virtual SAN on a SuSE VM?

I've already setup a virtual SAN, bind some LUNs on SAN's admin, but my SuSE doesn't detect it. The multipath still isn't recognizing the disks.

Thanks a lot
0
Comment
Question by:FlavioCardoso
  • 13
  • 11
25 Comments
 
LVL 11

Expert Comment

by:gmbaxter
ID: 39875239
Hi, in a windows environment you would configure the virtual SAN on each hyper V node - one virtual San for each fabric you have ( usually 1 or 2 ). You then add 2 virtual fibre channel adapters which have 2 wwpn each.

Virtual fibre channel only works on Windows unfortunately.
0
 

Author Comment

by:FlavioCardoso
ID: 39879313
Hi gmbaxter, thanks for your atention !!!

I've found this link on TechNet, Virtual Fibre Channel doesn't work with Suse, but Oracle, RHEL, CentOS and Ubuntu:
http://technet.microsoft.com/en-us/library/dn531027.aspx
http://technet.microsoft.com/en-us/library/dn531026.aspx
http://technet.microsoft.com/en-us/library/dn531029.aspx

I'll continue trying. Thank you!
0
 
LVL 11

Expert Comment

by:gmbaxter
ID: 39879466
Thanks, that's new. I might have to try out virtual fc on centos.

Do you have to use suse?
0
 

Author Comment

by:FlavioCardoso
ID: 39879482
Suse  was my first choice, but it's not compatible yet. I'm trying Oracle now. Unfortunatelly still no success...
0
 
LVL 11

Expert Comment

by:gmbaxter
ID: 39879813
Ok, can you confirm whether all the FC devices, switches NBA and storage support NPIV? If they do then please list your zoning information.
0
 
LVL 11

Expert Comment

by:gmbaxter
ID: 39879815
That should be HBA not nba sorry.
0
 

Author Comment

by:FlavioCardoso
ID: 39879833
I've just installed Windows Server 2012 R2 on the same VM. The virtual HBAs was detected correctly. I tryied with Oracel 6.5, no success. I'm downloading CentOS now.
0
 
LVL 11

Expert Comment

by:gmbaxter
ID: 39880650
Any luck with CentOS ?
0
 

Author Comment

by:FlavioCardoso
ID: 39882324
Nope.... tryied 6.5 and 6.3. I've installed IC3.5, kernel modules installed:

# yum info kmod-microsoft-hyper-v

Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * base: centos.xpg.com.br
 * extras: centos.xpg.com.br
 * updates: centos.xpg.com.br
Installed Packages
Name        : kmod-microsoft-hyper-v
Arch        : x86_64
Version     : rhel63.3.5
Release     : 20131212
Size        : 5.5 M
Repo        : installed
Summary     : microsoft-hyper-v kernel module(s)
License     : GPLv2+
Description : This package provides the microsoft-hyper-v kernel modules built for
            : the Linux kernel 2.6.32-279.el6.x86_64 for the x86_64
            : family of processors.

# yum info microsoft-hyper-v

Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * base: centos.xpg.com.br
 * extras: centos.xpg.com.br
 * updates: centos.xpg.com.br
Installed Packages
Name        : microsoft-hyper-v
Arch        : x86_64
Version     : rhel63.3.5
Release     : 20131212
Size        : 36 k
Repo        : installed
Summary     : Microsoft hyper-v drivers and utilities
License     : GPLv2+
Description : This package and subpackage contain drivers and utilities for the Microsoft Hyper-V environment.

Open in new window


Modules installed:
# lsmod | grep hv

hv_netvsc              24279  0
hv_utils                9565  0
hv_timesource           1113  0 [permanent]
hv_storvsc             11739  2
hv_vmbus              146659  6 hid_hyperv,hv_netvsc,hv_utils,hv_timesource,hyperv_fb,hv_storvsc

Open in new window


no HBA:
# lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (AGP disabled) (rev 03)
00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 01)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:08.0 VGA compatible controller: Microsoft Corporation Hyper-V virtual VGA

Open in new window

0
 
LVL 11

Expert Comment

by:gmbaxter
ID: 39917950
Apologies for the delay - I've had a few things on but have also recently had to work with virtual fibre channel in Linux. I have it working (just have the multipath to do now). Here's what I did:

Installed Centos 6.4
yum update to 6.5 (6.5 has no need for the IC or kmod packages as they are already installed)
reboot

lspci won't show the hba devices as they are vm_bus not pci

What does the following show for you?

cd /dev
ls | grep sd

?
0
 

Author Comment

by:FlavioCardoso
ID: 39920140
Hi gmbaxter,

I'll set ip up again, please, gime some more time. =)

thanks again
0
 

Author Comment

by:FlavioCardoso
ID: 39934292
Hi gmbaxter, pleas, sorry my delay... Lot of work these days... =)

Now using CentOS 6.5, here is the output:
# ls | grep sd
sda
sda1
sda2

thanks !!!
0
Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

 
LVL 11

Expert Comment

by:gmbaxter
ID: 39934955
I'm wondering whether this is a zoning issue. Can you post your FC topology and zoning config?
0
 

Author Comment

by:FlavioCardoso
ID: 39935179
We're using FC-SW
DS Storage Management - LUNsDS Storage Management - ServerHyper-V - VHBAsHyper-V - VHBAs
0
 
LVL 11

Expert Comment

by:gmbaxter
ID: 39935526
So you have the VM - Host TesteVHBA with 2 luns TesteVHBA-VHBA1 and TesteVHBA-VHBA2

Is your second HBA associated with a virtual HBA on the VM?

What have you used to map the luns to the server? the WWNN or the WWPN?

What model of HBA do you have on the server hosting the VM?
0
 

Author Comment

by:FlavioCardoso
ID: 39936573
So you have the VM - Host TesteVHBA with 2 luns TesteVHBA-VHBA1 and TesteVHBA-VHBA2
  --> YES

Is your second HBA associated with a virtual HBA on the VM?
  --> No, I've just mapped one for these testes

What have you used to map the luns to the server? the WWNN or the WWPN?
  --> WWPN

What model of HBA do you have on the server hosting the VM?
  --> QLogic  QL2300i
0
 
LVL 11

Expert Comment

by:gmbaxter
ID: 39937507
Have you used both WWPNs for the mapping? EG. address set A and B ?

Have you enabled NPIV on the QL2300i ?
0
 

Author Comment

by:FlavioCardoso
ID: 39940738
Hi gmbaxter, sorry another delay... I was setting up this VM running Win 2012 R2 in the same environment, using the same physical HBA, same Fabric, same SAN etc.
Note in the Hyper-V manager, the Linux VM (from previous post) which I can't get it to work...
Win VM with LUN 0
0
 
LVL 11

Expert Comment

by:gmbaxter
ID: 39946474
Does windows see the lun twice? If so, does installing the mpio feature and adding the DSN then rebooting make it display as a single disk?
0
 

Author Comment

by:FlavioCardoso
ID: 39952881
Yes, there was two luns. I've installed DSN on MPIO and after reboot a single drive has appeared.
0
 
LVL 11

Expert Comment

by:gmbaxter
ID: 39954118
Ok. On the linux vm, run yum install system-config-lvm

Then open logical volume manager from the administration menu in the hui

Do you see multiple disks listed under initialized ?
0
 

Author Comment

by:FlavioCardoso
ID: 39954202
=/
No X server in this machine.....
I'll setup a new one
0
 

Accepted Solution

by:
FlavioCardoso earned 0 total points
ID: 39976506
Hello bmgaxter,

I'll stop trying making this work and give some time.

Thanks for your help
0
 

Expert Comment

by:Roman Korobkov
ID: 40340762
Hello.
Does anyone found solution for this issue? I have exactly the same situation.
SLES 11 sp3 installed on Hyper-v 2012 R2, SAN HP 3PAR
0
 

Author Closing Comment

by:FlavioCardoso
ID: 40389837
no solution was find
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

First I will try to share a design of a Veeam Backup Infrastructure without Direct NFS Access backup. Note: Direct NFS Access backup transport mechanism is only available in Veeam v9 In above I try to design the Veeam Backup flow between i…
Veeam Backup & Replication has added a new integration – Veeam Backup for Microsoft Office 365.  In this blog, we will discuss how you can benefit from Office 365 email backup with the Veeam’s new product and try to shed some light on the needs and …
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now