Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Quickbooks 2012 Database Server Manager can't get multi user working

Posted on 2014-02-20
10
Medium Priority
?
3,350 Views
Last Modified: 2014-03-19
Was hosting quickbooks on a workstation but then I installed QuickBooks database server manager on a server and copied the company files to the server.   Ran the scan on server and it found the files.  When I try and connect more than one user it says it is not in multi user mode.  The documentation says that when the scan is done it would put the files in multi user mode.  Have not found much documentation on database server manager and multi user mode.  I did not install QuickBooks on the server only the database server manger software.  Any ideas how to get this configuration working?  Thanks.
0
Comment
Question by:gseales
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
10 Comments
 
LVL 97

Assisted Solution

by:John Hurst
John Hurst earned 2000 total points
ID: 39876603
Check to see if QuickBooks is still in Hosted mode. If so, this needs to be changed.

First, make sure there are not ledgers (company files) on personal computer (you moved the company files to the server). Make sure you moved the .QBW file and the .TLG file. DSN and ND files will remake themselves and should not be move.

Now open QuickBooks and CLOSE any open file so that QuickBooks is running but no file is open. Go to the large center window and choose Open Company File. Navigate to the server location and open the company file. The purpose this is to avoid Recent Files which can confuse things.

Once the company file is opened, go File, Utilities and ensure Host Multi User Access is NOT checked. Then go File, Switch to Multi User Mode. Make sure this works.

Now follow the same method for each QuickBooks client.

Also make sure you are using mapped drivers to the server and not browsed drives.
0
 
LVL 97

Expert Comment

by:John Hurst
ID: 39881586
Hello gseales - Did you disable Host Multi User access?  And did that help?

Thanks.
0
 

Author Comment

by:gseales
ID: 39914775
Hi John,

Sorry it has been so long, I never had a chance to make it over there and try this.  I did everything you said, but get a message when I try and switch it to Multi-User mode.  

"Problem: The company file is located on another computer and QuckBooks cannot contact that computer."  Error code: H202.

"Solution: Fix the hosting setup.  Recommended: On the computer where the file is located verify that QuickBooks is set up to host multi-user access"

Before I copied the files from the workstation to the server, I did check under "File" and it is on "Switch to Multi-User Mode"

Any idea what I did wrong?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 97

Accepted Solution

by:
John Hurst earned 2000 total points
ID: 39914790
The problem and error code you are getting can result from having the Company File on a different physical partition than the Server Manager. Make sure both Server Manager and Company file are on the same partition (say C:) on the Server.

Make sure you do this and have a good backup of the Company file.

Then delete local copies of the file.

Then try again.
0
 

Author Comment

by:gseales
ID: 39926613
Will give that a try and let you know how it goes.
0
 

Author Comment

by:gseales
ID: 39930552
Still had same error message.  One other thing that I did not include in the error message before was the last thing:

File: Q:\CompanyNameInc.QBW
Disk is attached to 192.168.1.102
Running on Server:  \\Server\QuickBooks\CompanyName.QBW
    (, port not available)

Do I need to allow some port on the server and or clients?
0
 

Assisted Solution

by:gseales
gseales earned 0 total points
ID: 39930568
I added the ports 8019, 56722, 55348 to the server and client firewalls and it worked switching to multi user mode now.  Probably was the problem all along.  Anyway thank you for all you help.
0
 
LVL 97

Expert Comment

by:John Hurst
ID: 39930911
Thanks for the update. I do not normally have to adjust ports to make QuickBooks share files properly, but I am glad it worked for you.
0
 

Author Comment

by:gseales
ID: 39932609
.
0
 

Author Closing Comment

by:gseales
ID: 39939092
In the end this was the final piece that made this work.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Code that checks the QuickBooks schema table for non-updateable fields and then disables those controls on a form so users don't try to update them.
Instead of error trapping or hard-coding for non-updateable fields when using QODBC, let VBA automatically disable them when forms open. This way, users can view but not change the data. Part 1 explained how to use schema tables to do this. Part 2 h…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question