Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions

UC520 Cisco Unity Express (CUE) has lost contact with host router

Posted on 2014-02-20
Last Modified: 2014-03-23

I'm having issues login into CUE
System details:
CCUME v4.2(0)

Basic error = "Cisco Unity Express has lost contact with the host router"

Attached screen shots may be more helpful

Screenshot1, I'm able to login to cue but it then takes me to screenshot2 where it states that cue has lost contact with the host router" I tried the same user/pass word I used in screenshot1 but no luck

I tried these steps with no success.
Enabling the HTTP Server
Enabling GUI Access for the System Administrator

Any help will be greatly appreciated
Question by:jbridges9
  • 6
  • 4
LVL 77

Expert Comment

ID: 39891013
It seems that your cue is not started.  What happened before this happened?
Did you update or restore some configurations?


Author Comment

ID: 39896289
Looks like I'm able to login via CLI but not web (it takes me to screenshot2). Not really sure what's going on. I did see read/write errors with flash. Just recently, I rebooted and was taken to rommon. Boot couldn't open flash and could not determine first file name. I was able to recover from this, but now the phones will not register, and I still can't login to CUE via web interface

Also, I don't see the voice vlan (100) defined in CCA. I only see the default vlan of This may be part of the problem I suppose? I've tried adding this, but doesn't allow me.

Author Comment

ID: 39896371
I've added the voice vlan (100), and now the phones register. Still can't log into CUE via web.
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

LVL 77

Expert Comment

ID: 39896411
The cue relies on the cUe starting, if it can not read/write to the second flash, that might be an issue.  A mismatch between the startup/router config and cue will prevent it from starting.
Do you still have access to cisco support?  Do you have a good back up of the cue?

Author Comment

ID: 39898087
No Cisco support. Don't think there's a backup of CUE. CUE is started however. See screenshots (cue1.png and cue2.png). My issue appears to only be with cue web access. Does the flash card contain cue web files? If so, I don't see cue related web files on the flash drive. The flash had read/write issues and needed to be reformated and IOS reinstalled. I noticed that it also lost the vlan.dat and needed to recreate it. Phones wouldn't register until I added vlan 100. I don't know if cue web interface is complaining about missing web files, or if cue can't communicate with the router because of issues with vlan 90? Vlan 90 is created but no IP associated with it. If I log into CCA > configure > switching > vlanls, I see default (, vlan 100 (, and vlan 90 (no IP info). Like I said, I had to recreate vlan100 and vlan90, but I'm unable to add IP to vlan 90. States that it is being used by local loop.
LVL 77

Expert Comment

ID: 39898211
Your configuration is off.
Usually: is the cue IP. is the CUE web interface. VLAN 90

you need to add the IP range and VLAN 90 to the integrated
interface Integrated-Service-Engine0/0
 description cue is initialized with default IMAP group
 ip unnumbered Vlan90
 ip nat inside
 ip virtual-reassembly in
 service-module ip address
 service-module ip default-gateway

Open in new window

Do you have a backup of running/startup config?
It might but when you are going through the web browser, what IP are you connecting to?

Author Comment

ID: 39898840
I do have a backup of the running config. is the web browser IP I use. I can access this page and login fine, but redirects me to screenshot2.png page "lost contact with router".  I can ping and I can telnet and login to cue with no issue. Just issues with the web interface.

I've added the IP ranged specified above. I think this was part of the issue, but I think I'm still missing something. After adding "ip unnumbered Vlan90 (before it was "ip unnumbered Loopback0"), the login seems to try longer but ultimately fails. It may be due to this error? "You may need to copy the GUI files on the CME flash and enable the HTTP server on the CME router". I don't see GUI files in flash..

Looks like I have a CCA backup that was created 11/15/2013. This backup should be fine since there hasn't been any changes configuration wise since that time. Do the cca backup do a complete system backup (Callmanager, cue, flash)? If it recovers the Items in flash, then I think this may fix my issue.
LVL 77

Accepted Solution

arnold earned 100 total points
ID: 39899436
There are two types of backup one can make using CCA all inclusive and a partial i.e. backup a components separately.

Create a backup with CCA of the current setup.
Then restore the prior and see if that restores your data.
If something goes wrong, you can at least bring the system back to the current environment.

Note that some restore have an adverse impact i.e. tries to bring non exiting references, etc.

Assisted Solution

jbridges9 earned 0 total points
ID: 39938561
The restore fails, but I can see how it attempts to restore files to flash. Unfortunately it fails before it restores the gui files.

Since CUE CLI works, I've learned to use this instead.

Thanks for the assistance.

Author Closing Comment

ID: 39948388
Wasn't able to restore the gui files. It was to much of a hassle to do this. CUE CLI works fine for me and will my alternate solution

Featured Post

How Do You Stack Up Against Your Peers?

With today’s modern enterprise so dependent on digital infrastructures, the impact of major incidents has increased dramatically. Grab the report now to gain insight into how your organization ranks against your peers and learn best-in-class strategies to resolve incidents.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently purchased a Bluetooth headset called the Music Jogger (model BSH10). The control buttons on it look like this: One of my goals is to use it as the microphone and speakers for Skype calls. In that respect, it works well. However, I …
Moving your enterprise fax infrastructure from in-house fax machines and servers to the cloud makes sense — from both an efficiency and productivity standpoint. But does migrating to a cloud fax solution mean you will no longer be able to send or re…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

861 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question