• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3894
  • Last Modified:

Solaris 10 - file descriptors changing values -

Hi experts.

What is the real value of file descriptos?
Using oracle user to enter the server and it is the working user in this case.
I need this to be 4096, but Unix system Admin told me, the number is 8192.
Oracle is telling me that it is not set to 4096.
Who has the truth, and how to change if it is not set?

For our Cloud Control agent, we need files descriptors should be 4096
Once you do the changes, please restart the agent and monitor.



pasatimeDB:/export/home/oracle/product/agent/agent_inst/bin> prctl -n process.max-file-descriptor  -i process $$
process: 10343: -ksh
NAME    PRIVILEGE       VALUE    FLAG   ACTION                       RECIPIENT
process.max-file-descriptor
        basic             256       -   deny                             10343
        privileged      8.19K       -   deny                                 -
        system          2.15G     max   deny                                 -


/export/home/oracle/product/agent/agent_inst/bin> ulimit -a
time(seconds)        unlimited
file(blocks)         unlimited
data(kbytes)         unlimited
stack(kbytes)        8192
coredump(blocks)     unlimited
nofiles(descriptors) 256
vmemory(kbytes)      unlimited


/export/home/oracle/product/agent/agent_inst/bin> cat /etc/release
                   Oracle Solaris 10 1/13 s10s_u11wos_24a SPARC
  Copyright (c) 1983, 2013, Oracle and/or its affiliates. All rights reserved.
                            Assembled 17 January 2013
0
LindaC
Asked:
LindaC
  • 5
  • 3
  • 2
  • +1
2 Solutions
 
woolmilkporcCommented:
Hi Linda,

The important thing is the the file descriptor limit of the concerned user which is 256 in your case.

You should try to raise this limit by means of "ulimit -n 4096"

If this fails you will have to ask your system admin to raise at least the "hard limit" for file descriptors of this user to 4096.
Better have them also raise the "soft limit" so the right value will be set at login which gets you rid of the need to add the ulimit command to the user's profile.
0
 
Brian UtterbackPrinciple Software EngineerCommented:
You can just set the limit you need for the process using the prctl command.
0
 
LindaCAuthor Commented:
Is this going to be persistent if I quit the session?  And how can I change it if I'am login as Oracle?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
woolmilkporcCommented:
@LindaC - who is the adressee of your last questions above?
0
 
LindaCAuthor Commented:
You.
0
 
woolmilkporcCommented:
All that follows applies to a regular user, e.g. "Oracle".

"ulimit -n 4096" (if allowed) will not persist across sessions, but I think it's good for testing anyway.

To make it "persistent" you must either

- add the above statement to the "Oracle" user's  .bash_login (for login shells) or  .bash_profile,  .bashrc or .profile (fallback if none of the previous files exists)  whatever is your standard.

- ask your system admin to raise the soft limit for nofiles (descriptors) of the Oracle user to 4096.

If "ulimit -n 4096" is not allowed due to hard limit restrictions you must ask your system admin to raise the "nofiles" hard limit  as well as the soft limit  to 4096.

If "ulimit" isn't useable at all or has no effect in your environment let's hope that "blu" drops in again to explain how to use "prctl" in this case.
0
 
LindaCAuthor Commented:
Thank you.
0
 
Reza_aCommented:
ulimit is legacy and solaris has better way of managing system resources, via projects.

You can ask your system administrator to run following command to add a project for Oracle user and specify maximum file descriptor size. this will be permanent and you can apply change to all current running process as well as new process, so you don't even need to restart oracle database.
 
 
#projadd -U oracle -K “process.max-file-descriptor=(priv,4096,deny)” user.oracle

For applying this change to all current running process:

#for p in `ps -o pid -u oracle`; do
#newtask -p user.oracle -p $p
#done
 

To see current value for file descriptor for current shell run this:

prctl -n process.max-file-descriptor $$
0
 
LindaCAuthor Commented:
Reza_a thank you.
What the system Admin told me is that the oracle user is a "privileged"user and it is already set to 8192.
Oracle Company said is not set because when I ran as oracle user ulimit -a it gave 256

pasatimeDB:/export/home/oracle> prctl -n process.max-file-descriptor $$
process: 13020: -ksh
NAME    PRIVILEGE       VALUE    FLAG   ACTION                       RECIPIENT
process.max-file-descriptor
        basic             256       -   deny                             13020
        privileged      8.19K       -   deny                                 -
        system          2.15G     max   deny                                 -
pasatimeDB:/export/home/oracle>
0
 
Reza_aCommented:
As you can see there are three values you can define in file-descriptors:
basic: is equal to soft limit
privileged: is equal to hard limit
system : is maximum number can be used by system

for you case you need to to change basic value, you can change it yourself but to make it permanent ask your system administrator to run following command


projmod -U oracle -K “process.max-file-descriptor=(basic,8192,deny)” user.oracle
0
 
LindaCAuthor Commented:
Thanks so much Reza_a.
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 5
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now